8 Replies Latest reply: Oct 22, 2014 10:51 PM by miktav
Tlmlvr Level 1 Level 1 (5 points)

I already searched the forum, this questions has been poppped up many times, but there was no clear answer.

In my case it working fine until today, and in particular when I booted up in Bootcamp the same Wireless Network is working perfectly.

Please, help.


MacBook Pro, OS X Mountain Lion (10.8.5), late 2011 15-inch model 6770M GPU
  • sterling r Community Specialists Community Specialists (5,565 points)

    Hey there Tlmlvr,

     

    It sounds like you are unable to connect to your Wi-Fi with a self assigned IP address, but the bootcamp partition OS is working fine with the Wi-Fi.I want to recommend a few items from the article named:

    Wi-Fi: How to troubleshoot Wi-Fi connectivity

    http://support.apple.com/kb/HT4628?viewlocale=en_US

    OS X Mountain Lion v10.8.4 or later

    Use the Wireless Diagnostics application included with OS X Mountain Lion v10.8.4 and later to identify and resolve Wi-Fi issues. For further information, please see About Wireless Diagnostics.

     

    Then:

    1. Does the symptom occur with more than one Wi-Fi device?
      • Wi-Fi issues may be related to the network in question or they may be related to the Wi-Fi computer joining that network. Usually, if other computers or devices (such as the Apple TV or iPhone) are able to get on the Internet without issues, then your Wi-Fi router is probably fine.
      • If you only have one Wi-Fi device, proceed with this article.
    2. Make sure your software is up-to-date.
      • Install all software updates available for your Mac.
      • If you use a third-party Wi-Fi router, check with the manufacturer to confirm that it has the latest firmware installed. If an update is available, follow the manufacturer's instructions for updating the firmware.
      • To determine if your Apple Wi-Fi base station firmware is up-to-date, see Updating your software.
    3. Check your connections.
      • Some networking issues may be caused by loose or disconnected cables. Verify that all Ethernet and power cables connected between your modem and your Wi-Fi router are correct. Checking that devices such as your router and modem are on, disconnecting and carefully reconnecting Ethernet cables, and/or replacing damaged Ethernet cables may resolve the issue without any further troubleshooting.
    4. Verify that you are using the recommended settings for your device.
    5. Restart your network devices.
      • Powering your modem or router off for a few seconds and then on again may resolve network issues without any additional troubleshooting. If you have phone service through your ISP, power cycling your modem may interrupt that service. You may need to contact your ISP in order to restore your phone service if your modem is reset or powered off. Ensure that you have alternative means to contact your ISP (such as a cell phone) to avoid unnecessary delays in restoring your Internet or phone service

     

    And lastly, if needed this section toward the bottom:

    Symptom: My Mac does not connect to the Internet

     

    Thank you for using Apple Support Communities.

    All the best,

    Sterling

  • Tlmlvr Level 1 Level 1 (5 points)

    I have been struggling with this problem for a month, tried all advises, suggestions above and others without any success.

    Today, I tried a most silly "attempt" by clicked the WiFi symbol on the top row of the screen, instead of selecting the network which I used to connect with, I selected "Join Other Network ..." simply typed in exactly the name of the "old network" as well as password, encryption mode (WEP ot WPA ...) etc : the connection was established, and began working well.

     

    Any network guru here can give an explanation?

  • sterling r Community Specialists Community Specialists (5,565 points)

    Thank you for the update!

    I was thinking, based on the new information that the saved network profile in your Preferred Networks may have needed to be removed so it could refresh.

    Check out the info in this article:

    OS X Mountain Lion: Choose preferred Wi-Fi networks

    http://support.apple.com/kb/PH10667

     

    Glad to hear its now working as expected.

    Take care,

    Sterling

  • bhurlburtclan Level 1 Level 1 (0 points)

    I don't know if this will help or not, but I had a colleague set my Macbook up for Internet Sharing the other day.  He didn't tell me all of the ramifications to that but one of them was that my Wifi was set to a self assigned IP.

     

    Anyway, it took me a while to realize that I was not going to be able to solve the problem in the Network settings, but in the Sharing settings by unchecking off the Internet Sharing box.

  • EberhardHofer Level 1 Level 1 (0 points)

    This actually helped me. I checked my Airport Extreme and it needed to be updated. I updated them (2 of them) and the problem of the self assigned ip address dissapeared!

    Thanks

  • jbirken Level 1 Level 1 (0 points)

    Do this ...

    Remove IPFW File to make sure WiFi works

    1. Open the Terminal app located at /Application/Utilities/Terminal
    2. Copy the following text and paste into the Terminal window and press enter:     sudo rm /usr/local/etc/ipfw.conf
    3. You should be prompted to enter your Mac password, please do so.  Note that as you type your password nothing is shown on the screen
    4. If the file was there you will receive no error or output.  If the file was missing you will receive an error.  Either way this file is no longer present which is good.
  • unsubscriber Level 1 Level 1 (0 points)

    OK, so I hit this problem yesterday and I thought it was just one friend's mac. This morning I found that several macs were having the same problem on wifi. (Ethernet was OK, but not wifi.) I have SOLVED it for me - so here's the info in case it helps!

     

    NB - I have tried most of the solutions on most of the help threads. (Once, years ago, I had the same problem, and one of the fixes I found back then did work. I think it was either deleting the  wifi setting from Network Preferences or fixing the keychain or both. But this time, those fixes were achieving nothing.)

     

    Anyway, the solution was simple! My modem-router included a setting for its DHCP server that was limited to 20 addresses. In other words, it was offering addresses from 192.168.1.1 to 192.168.1.20.  At first I dismissed that possibility, since you'd think 20 would be plenty for one house! However, I was very wrong. Here's why.

     

    1. Yes, we do own several Macs, and some of these are connected by ethernet AND wifi, so those ones use two addresses each.

    2. Yes, we own several iPhones, iPods, an AppleTV etc.

    3. Yes, we had visitors in the house. My daughter's friend had brought her iPad; my parents had brought their laptops and their phones!

    4. I have an Airport Extreme and a Time Capsule, both connected (in Bridge Mode) to the modem-router, so that's two more addresses.

    5. Remember that DHCP leases last for 24 hours (or whatever your router is set to), so even when visitors are gone or machines are turned off, those addresses might not become free.

     

    SOLUTION? I changed the router's setting to offer all addresses up to 192.168.1.40. (I might even go back and offer even more than 40 - no reason why not).

     

    My wifi macs had no trouble from that point. Hope this helps!

     

    [NB - The reason my ethernet was always OK was that those connections had been running a long time. But if an Ethernet connection had gone down, and I had reconnected it at a time when its address had been stolen by another device, then I likely would have hit the same "self-assigned IP" error. In other words, in my case I don't believe the issue made any real distinction between wireless and wired connections.]

  • miktav Level 1 Level 1 (0 points)

    I have a Linksys WRT54GL router. I had the same problem for months. None of my devices would connect to the network automatically -- I always had to manually configure their IP addresses. This included an iMac, MacBook Pro, iPhone, and Android phone. So clearly the problem wasn't with the devices -- it was with the router.

     

    Finally got tired of this problem, and tonight my son and I reset the router. The network name we had been using was "NuclearReactor". (I guess I thought that was cute.) After resetting, the router got the default name "linksys". Using the admin page for the router, we configured the network name as before, "NuclearReactor", and tried connecting the iMac. It did not work.

     

    We then reset the router again, got the default name "linksys" and tried connecting the iMac. It worked! We then renamed the network to a name that was 7 lowercase letters, and it still worked. I then connected my MacBook Pro and iPhone successfully, without having to configure manual IP address. I am so happy!

     

    My suggestion to you is to try using a short, all lowercase name for your network and see if that works.