Previous 1 2 Next 24 Replies Latest reply: Sep 17, 2015 11:26 PM by K2Climber Go to original post
  • vspinnet Level 1 Level 1

    Had this issue with my iPad for a week, and your solution of turning iMessage feature off and back on, worked for me.

  • yegdad Level 1 Level 1

    The problem is your "presence" settings on Apple's XMPP iMessage server got corrupted.

     

    Logging out and logging back in to iMessage will fix it it. (Rebooting your devices won't help.)

     

    Since you can sign into iMessage from multiple devices simultaneously, a presence setting problem on one device can create problems across multiple devices simultaneously.

     

    On each device (iPad, iPhone):

     

    -  go to SETTINGS > MESSAGES > IMessage

    -  toggle it OFF

    -  wait a minute or so

    -  toggle it ON

    -  log in to iMessage again using your Apple ID

  • MJ McFly Level 1 Level 1

    yegdad's suggestion work for me: turn off imessage on all devices, and then turn it back on.

     

    thanks!

  • taburere Level 1 Level 1

    I tried this solution on my iPhone 5S and it didn't seem to work. I wonder if I'm doing something wrong though -- I waited for about 2 minutes with iMessage set to OFF in settings, and when I turned it back on, it activated iMessages without prompting for Apple ID authentication.

  • jakob.joergensen Level 1 Level 1

    Did iMac, MacBook, iPad and iPhone all at the same time ... didn't work.

     

    All devices are saying not deliveret, though receiver has received it.

    (they tend to respond)

  • Prenaud1 Level 1 Level 1

    Shutting off my iPad iMessage worked, and now my phone is fine

  • nicoladie Level 1 Level 1

    You have to turn on the same phone number and email accounts in iMessages on all devices to send as... and received from... all these phone number and email accounts to make it work.

     

    If you forgot to turn on send as your phone number or any of your email, then it won't receive from them.

     

    You have to turn them on in all your devices, iPhone, iPad and computers.

     

    Go to:

    iMessages > Settings > Send & Receive > turn on all your phone numbers and email.

     

    Most importantly, set "Start new conversations from" your phone number, not from your email addresses.

  • Woodwyn Level 1 Level 1
    expertise.iphone
    iPhone

    Sorry, this does not work for me. My iPhone, iPad and Mac have all been set to use the same phone number to send from before this started and it still does not work.

  • zhuuu Level 1 Level 1

    THANK YOU!!!

     

    This issue has been bugging me for months!!! I think I was slowly going insane. Finally solved after signing out of iMessage on all devices and re-logging in.

  • K2Climber Level 1 Level 1

    This happened to me while setting up a new mac.  Every iMessage sent from mac would say "not delivered".  I tried many things, but ultimately, i went to my phone (after reading a previous post) and turned iMessage off on the phone.  I turned it back on a few moments later, and went back to my mac and tried to send a message.  BINGO!  it worked!!!

     

    Thinking about it... since the iMessage system is working in conjunction with your phone number and texting, it seems to make sense that the issue somehow would all relate back to the phone and it's needing some kind of restart to recognize the changes made on the device or mac.

Previous 1 2 Next