4 Replies Latest reply: Feb 22, 2014 1:45 PM by JayhawkTeacher
chrrob Level 1 (0 points)

I just purchased a new HP Photosmart 7520 printer.  One of my Macs at home is an iMac G5 that is running Mac OS X 10.4 Tiger.  It connects to the HP printer via Wi-Fi.  HP does not provide drivers for Mac OS 10.4 for the Photosmart 7520 printer.  I tried all sorts of old HP drivers and finally found one that worked, so I figured I would post here to help out anyone else who is trying to solve the same problem.  The driver download you need is the OS 10.4 driver for the Photosmart C7250 All-In-One printer.  Here is the link to the download page:

http://h10025.www1.hp.com/ewfrf/wc/softwareDownloadIndex?softwareitem=mp-55650-2 &cc=us&dlc=en&lc=en&os=219&product=3382185&sw_lang=

After downloading and installing the drivers, I ran the HP Printer Setup Utility.  It was not able to detect my printer.  I had to go to System Preferences on my Mac and add the printer manually in the Print & Fax control panel.  The Print & Fax control panel was not able to auto-select the correct driver to use, so I selected "HP" from the "Print Using" drop-down list, and then selected "HP Photosmart D7400 Series" from the "Model" list.  That worked for me.  Good luck!

According to the driver download page, this driver will work for Mac OS X v10.3.9, v10.4 and v10.5

iMac G5, Mac OS X (10.4.10)
  • Limnos Level 8 (47,146 points)

    Thanks! It's good to have a reference for possible future replacements.

  • BDAqua Level 10 (122,202 points)

    Great work/tip, thanks for the post!

  • BlackDark Level 1 (0 points)

    Thank you very much, I just bought this printer without paying attention to the compatibility of my Imac. Thanks to you, I just install it without too much difficulty. Thank you again.


    Merci beaucoup, je viens d'acheter cette imprimante sans faire attention à la compatibilité de mon Imac. Grace à vous, je viens de l'installer sans trop de difficulté. Encore merci.

  • JayhawkTeacher Level 1 (0 points)

    Thank you, thank you, thank you!!!


    Was also surprised to see that OS 10.5 and below were not supported...so did the work-around suggested and it's working fine.  Awesome!