0 Replies Latest reply: Dec 19, 2013 5:17 PM by DJWebDUck
DJWebDUck Level 1 Level 1 (5 points)

For the last few days, after upgrading to Mavericks, there was something about my MacBook Pro that just hasn't felt right. It was running a lot slower and responding very jumpy and not smooth like it always has.  I installed the 10.9.1 update and it sent my laptop into a kernel panic/trap boot loop.


I then booted into safe mode and looked around for problems but didn't find any.  I then booted into recovery mode and ran a disk verificaiton and repair but it didn't find anything wrong.  I then restarted and was able to boot up like normal.  However, it was when I unplugged that my laptop that a lot of issues really became apparent. It was running very--VERY--slowly and hardly responsive at all.  Yet, when I plugged it back into the charger, all those problems went away.


I opened Activity Monitor to see what process was doing this. When I unplugged my laptop with Activity Monitor open, kernel_task was culprit behind the chaos, spiking each time the laptop became unplugged.  Using the iStat widget on my dashboard, it showed the system CPU skyrocketing once the laptop was unplugged.  However, my laptop wasn't hot--internally and externally--at all, the fans weren't spinning, I still had plenty of RAM available (10GB), and there were no peripherals of any kind plugged into my laptop.


At first I thought it may have been a software issue. After some googling, I found a solution which, for the most part solved what I thought the issue was.  However, after reinstalling 10.9.1 (again), something still just wasn't feeling right.


I decided to run the Apple Hardware Test -- press & hold the Option + D keys before seeing the screen on startup. Make sure your laptop is plugged at all times.


On the screen that came up, I decided to run a regular (quick) test to see if there were any issues. It gave me this message:




Wanting to make sure it wasn't a false positive, I ran the extended test as well. The result was the exact same. So, sadly, I'm back to square 1 but at least this time I know that there's a hardware problem. Now the question is does anyone know specificially what the issue is?  I know the 4SNS means it has to do with a sensor.  The only question is does it have to do with a power sensor? Heat sensor? Or something else entirely??

MacBook Pro, OS X Mavericks (10.9), 13" Early 2011 i5 16GB RAM 1333MHz