4 Replies Latest reply: Dec 22, 2013 5:51 AM by gaginker
gaginker Level 1 Level 1 (5 points)

Trying to select a new photo for my desktop: roughly half the photos in click on in iPhoto 9.5.1 result  only in a question mark in the box, rather that a thumbnail.


Intel iMac, Mavericks,  10gb RAM, Safari  7.0.1


Comments would be welcomed.

iPad 2, iOS 5.0.1
  • Terence Devlin Level 10 Level 10 (135,595 points)

    The ? usually indicates a permissions issue in the iPhoto Library.


    Back Up and try rebuild the library: hold down the command and option (or alt) keys while launching iPhoto. Use the resulting dialogue to rebuild. Choose to check and repair Library permissions.

  • gaginker Level 1 Level 1 (5 points)

    Thanks Terry...


    Will try the technique you describe.....



  • gaginker Level 1 Level 1 (5 points)



    No good on the permissions repair. Also tried all the other buttons, with no change at all. My desktop photo always defaults to the same Apple picture.


    Thanks anyway....



  • gaginker Level 1 Level 1 (5 points)

    Terry: Update. Think I have solved the difficulty....I was using the usual method (Settings, then selecting a photo from the popup display) but on reading in the Help menu, find that it's now necessary to select a photo in iPhoto, then going to "Share" in the toolbar, and clicking on 'Set Desktop'. I didn't hear anything about this change in procedure......


    Would appreciate your comments on this.