1 Reply Latest reply: Dec 23, 2013 7:57 PM by abs()
The Mighty Doosh Level 1 Level 1 (0 points)

I know it's been covered a million times, and I have read the forum and support pages and tried everything imaginable, but I still get a plain black screen after I install windows 7 on my late 2009 iMac 27" macos 10.8.5.


I know this is because the display drivers are not installed, and I have downloaded the correct drivers from here: http://support.apple.com/kb/HT3983?viewlocale=en_US&locale=en_US


...and followed the instructions to the letter from here: http://support.apple.com/kb/TS3173


...but it still doesnt work.



For whatever reason, it is not installing the drivers from my MS-DOS (FAT) formatted USB drive. I have the 'drivers' folder and the 'AutoUnattend.xml' file in the root of the USB drive.


at the end of the page in the second link above it says: "If the screen remains black after several minutes, power it off (hold the power button for several seconds), then go back to step 4.  Ensure that your USB device or SD card is formatted as Master Boot Record, FAT, and that AutoUnattend.xml and Drivers are on the root level of the directory."

I have done this over and over and over again. A problem with bootcamp assistant, is that you have to start from scratch each time, I dont need to partition the drive and reinstall Windows, I know it is installed, I just need to install the drivers.


Is there anyway to install the drivers manually? Or does anyone have any other ideas?


Many thanks in advance.

iMac, OS X Mountain Lion (10.8.5)