Previous 1 2 Next 18 Replies Latest reply: Jan 5, 2014 3:18 PM by Ferd II
jdhursh Level 1 Level 1 (0 points)

I placed my calender, contacts and email on iCloud and now my iCal won't allow me to use it because it keeps updating. I've log off my computer, restarted and forced closed iCal and none of this has worked.


MacBook Pro
  • Ferd II Level 7 Level 7 (24,050 points)

    jd,

     

    Quit/Force Quit iCal, and try removing the com.apple.iCal.plist file from your Macintosh HD/Users/yourusername/Library/Preferences Folder. To find the proper Library Folder,paste this text ~/Library into the Finder>Go>Go to Folder...window and select "Go." Then open the Preferences Folder in Library, and move the com.apple.iCal.plist file to the Desktop.

     

    Log out/in or restart, and open iCal.

    SmallWings.png

    OS X Mavericks (10.9.1), iPad Air Wi-Fi, Cellular, iPhone 5s

  • jdhursh Level 1 Level 1 (0 points)

    Thank you for your suggestion, however this didn't work for me. Maybe it's me, I'm not sure. I couldn't find the file so I couldn't accomplish the task at hand. I searched many different ways and still couldn't find this file.

     

    Is there another way to find it? Or, can you give me even more basic literal direction to make sure I'm not messing it up. I understand what you're wanting me to do, but I may be not executing it correctly.

     

    Thanks for your help...this is so frustrating. It worked fine until the Apple guys hooked me up to iCloud. All other functions seem fine, but iCal is constantly trying to "update".

     

    All the best,

     

    John

  • Ferd II Level 7 Level 7 (24,050 points)

    John,

     

    Here is another way to find the proper Library folder, use Finder>Go Menu>Depress the "Option" key>Library. Then open the Preferences Folder in Library, and move the com.apple.iCal.plist file to the Desktop.

    SmallWings.png

  • jdhursh Level 1 Level 1 (0 points)

    Ferd II

     

    Good morning and thanks for your suggestion. I went to Finder, clicked Go and the drop down doesn't have Library. I tried using GO TO FOLDER to serach and still nothing. Other thoughts or ideas?

     

    Thanks,

     

    JD

  • Ferd II Level 7 Level 7 (24,050 points)

    JD,

     

    Ever since Apple released OS X Lion, the user Library has been hidden from view by default.

     

    Follow the instructions listed in OS X Mountain Lion: What is the Library folder?

    SmallWings.png

  • jdhursh Level 1 Level 1 (0 points)

    Ferd II

     

    I got to the Library and found the Preferences file, however I searched the folder and can not locate the "com.apple.ical.plist" file

     

    JD

  • leagal Level 1 Level 1 (0 points)

    I'm having the exact same problem (and it took me forever to even find the Library>Preferences folder!) -- the iCal file simply does not exist. And I even wonder why it tried to update itself when I'm using iCloud and was only trying to sync my iCloud calendar with my iPod Air (which it still won't do either). Frustrating!

  • Ferd II Level 7 Level 7 (24,050 points)

    JD,

     

    What version of OS X are you using?

     

    Quit/Force Quit iCal. Then paste this text ~/Library into the Finder>Go>Go to Folder...window and select "Go," or use the same procedure that you used previously to find the proper Library Folder.

     

    Then open the Calendars Folder in that Library Folder, and move any any files with "Cache" listed in the name field to your Desktop.

     

    Log out/in or restart, and open Calendar.

    SmallWings.png

  • jdhursh Level 1 Level 1 (0 points)

    I don't know the OPS, but I think it worked. Thank you! What should I do with the file sitting on my desktop? Can I put it in the trash?

     

    JD

  • Ferd II Level 7 Level 7 (24,050 points)

    JD,

     

    Yes, you can delete the file on your desktop.

  • carsonfromca Level 1 Level 1 (0 points)

    Hello Ferd II,

     

    I just wanted to let you know, I've been tearing my hair out trying to figure out this problem for weeks, to the point I only opened/updated/created-appointments in iCal on my iPhone 5s and NEVER on my MacBookPro Retina.

     

    I'm am so happy to have found this discussion thread and your instruction for the solution.

     

    Simply, IT WORKED!!!!!  For the first time, weeks after trying to switch my calendar to iCloud, I no longer have that irritating "update" notification with the horizontal busy bar never going away.

     

    THANK YOU! 

     

    Another happy Apple user because the community is so rich with knowledgeable folks.

     

    All the Best!

    Carson

  • Ferd II Level 7 Level 7 (24,050 points)

    You are welcome...glad to hear that.

  • leagal Level 1 Level 1 (0 points)

    This worked for me as well (hoorah!) BUT now the iCal calendar opens on my desktop whenever I boot my Mac. It never appeared before. If I'm using iCloud, why is the iCal calendar suddenly opening up automatically? (I never used it before really.) More importantly, how do I make it go away?

     

    (System is a MacBook Pro running 10.7.5)

  • Ferd II Level 7 Level 7 (24,050 points)

    leagal,

     

    Read OS X Lion: Open items automatically when you log in for an explanation of controlling startup items.

    SmallWings.png

Previous 1 2 Next