6 Replies Latest reply: Dec 30, 2013 11:24 AM by dianeoforegon
jimpascale Level 1 Level 1

I use Apple mail. Comcast, which is POP, is my internet provider. In order to use IMAP capability I forward my email to my Gmail acct. All worked flawlessly until Mavericks came along. Even after the 10.9.1 upgrade

Here are my issues:

(1) draft emails are copied every minute so I get multiple drafts like this:

Hello

Hello John

Hello John, how

Hello John, how are you?

(2) If I send myself an email to test how my email is working if I delete the received email from the inbox it deletes itself from the sent box. If I delete the email from the sent box it deletes the email in the inbox.....

(3) and nothing is being saved on the Gmail server although my settings indicated "never" remove the email.

Any thoughts? It's drviing me crazy & I'm afraid I'm going to lose valuable emails....

Thanks in advance....

Jim


MacBook Pro, Mac OS X (10.5.7)
Reply by dianeoforegon on Dec 27, 2013 5:20 PM Helpful

The outgoing mail saved as drafts issue, results when you are composing a message, Mail saves it to drafts folder on the server. You can select to save draft messages to On My Mac. You won't have access to your drafts on other devices with this option, but no more multiple drafts or a draft of a sent message.

 

In Gmail > Settings > Labels in your browser, select to sync the All Mail folder. In the past, many users selected not to sync this folder, but in Mavericks Mail, it needs to be enabled. Remember even sent messages are included in the All Mail folder.

 

Your problems are very similar to the ones in this discussion.

 

https://discussions.apple.com/message/24275822#24275822

Reply by Donald Morgan on Dec 28, 2013 12:20 AM Helpful

All replies

  • dianeoforegon Level 5 Level 5

    The outgoing mail saved as drafts issue, results when you are composing a message, Mail saves it to drafts folder on the server. You can select to save draft messages to On My Mac. You won't have access to your drafts on other devices with this option, but no more multiple drafts or a draft of a sent message.

     

    In Gmail > Settings > Labels in your browser, select to sync the All Mail folder. In the past, many users selected not to sync this folder, but in Mavericks Mail, it needs to be enabled. Remember even sent messages are included in the All Mail folder.

     

    Your problems are very similar to the ones in this discussion.

     

    https://discussions.apple.com/message/24275822#24275822

  • jimpascale Level 1 Level 1

    Thanks Diane & All, I have now been able to successfully stop the multiple drafts - yipee!

    However, Apple Mail/Gmail problems persist.

    The biggest one is that my emails are not being archived, even though under mailbox behaviors for Gmail I have checked save for 30 days.

    Any thoughts on this one?

  • Donald Morgan Level 6 Level 6
  • jimpascale Level 1 Level 1

    I'm trying to archive from Apple Mail to Gmail

    I founnd this on the internet but I must be doing soething wrong because it didn't work:

     

    In Gmail’s settings, under the Forwarding and POP/IMAP tab, change the setting. When I mark a message in IMAP as deleted to Auto-Expunge off. Then, just below that option, change the setting. When a message is marked as deleted and expunged to Archive the message. Click Save at the bottom of the page. Once you tweak settings in Mail in a later step, using the Delete key on a message will tell Gmail to archive it in All Mail. If you truly want to delete a message, you can drag and drop it to the [Gmail]/Trash folder.

  • dianeoforegon Level 5 Level 5

    I decided to test Mavericks Mail with a new Gmail account today to see what the new default settings in Mail works with Gmail. It seems that all the workarounds we used prior to Mavericks are no longer needed. No root folder required. No prefix [Gmail]/ for folders.

     

    I no longer had to use "Use this folder for Drafts, Sent, Junk, Trash". When I delete a message it actually goes to Trash not to All Mail. Yipeee!

     

    IMAP-settings.png

     

    Be sure to select All Mail folder.

     

    labels.png

  • dianeoforegon Level 5 Level 5

    These are not the images I uploaded. You can view the settings here;

     

    http://www.needhelp4mac.com/2013/12/use-gmail-with-mavericks-mail/