3 Replies Latest reply: Dec 29, 2013 3:09 PM by BDAqua
Peter WP Level 1 Level 1 (0 points)

My iMac all of a sudden started going to sleep very slowly when Sleep was invoked. Usually it would take about 5 seconds, now it takes well over 30 seconds.

It appeared to start after I loaded some diagnostic software which came bundled with my Seagate external drive. My iMac ran fine with the external drive connected; only after a few weeks' ownership did I load the diagnostic software, then the sleep problems began. I dragged the program to the trash but the problem persists. I'm assuming the 2 events are related; maybe they're not.

 

Any suggestions?

 

Thanks!


iMac 2.6GHz, Mac OS X (10.5.8)
  • BDAqua Level 10 Level 10 (120,375 points)

    Hi Peter,

     

    See if the Disk is issuing any S.M.A.R.T errors in Disk Utility...

     

    http://support.apple.com/kb/PH7029

     

     

    Open Activity Monitor in Applications>Utilities, select All Processes & sort on CPU%, any indications there?

     

    How much RAM & free Disk space do you have also, click on the Memory & Disk Usage Tabs.

     

    Open Console in Utilities & see if there are any clues or repeating messages when this happens.

     

    In the Memory tab of Activity Monitor, are there a lot of Pageouts?

     

    One way to test is to Safe Boot from the HD, (holding Shift key down at bootup), run Disk Utility in Applications>Utilities, then highlight your drive, click on Repair Permissions, Test for problem in Safe Mode...

     

    PS. Safe boot may stay on the gray radian for a long time, let it go, it's trying to repair the Hard Drive

     

    Reboot, test again.

     

    If it only does it in Regular Boot, then it could be some hardware problem like Video card, (Quartz is turned off in Safe Mode), or Airport, or some USB or Firewire device, or 3rd party add-on, Check System Preferences>Accounts (Users & Groups in later OSX versions)>Login Items window to see if it or something relevant is listed.

     

    Check the System Preferences>Other Row, for 3rd party Pref Panes.

     

    Also look in these if they exist, some are invisible...

     

    /private/var/run/StartupItems

     

    /Library/StartupItems

     

    /System/Library/StartupItems

     

    /System/Library/LaunchDaemons

     

    /Library/LaunchDaemons

  • Peter WP Level 1 Level 1 (0 points)

    Thanks for the detailed reply. Let's see if I can go through your checklist in order.

     

    I ran Disk Utility S.M.A.R.T. for both the internal drive and the Time Machine external drive. When I view the Disk Utility log in Console I see some files that "have been modified and will not be repaired."

     

    It says the internal drive is "Verified". It says the external drive is "not supported".

     

    I opened Activity Monitor and sorted by CPU. Safari consumes roughly 8% maximum CPU. Activity Monitor is next at about 1% maximum CPU. All other processes consume 0% CPU.

     

    I have 2.5Gb available of 4Gb of memory.

     

    I have roughly 250Gb available on a 300Gb drive.

     

    When I open Console and view the Log Database Queries, I see THOUSANDS of messages at the "Warning" level referring to "Solar Service". For some reason I can't cut and paste the messages, but they say "Event =1, device index = 1, input data callback for device 0x19a310". I'm guessing it has something to do with my Logitech wireless keyboard. The messages are accruing even while I'm not home and the iMac is in Sleep Mode.

     

    When I view the Log Files system.log I see similar messages regarding Solar Services but some are different depending on whether the computer is running vs. Sleep.

     

    There are TONS of Google Software Update Agent messages in Console.

     

    My iMac goes to sleep nice and fast in Safe Mode. I ran the Repair Permissions and rebooted; no change under normal operation-it still goes to sleep after at least 30 seconds.

     

    I'm not sure what to check with regard to System Preferences>Other Row. The only Preferences I have there are my Logitech Control Center (for wired mouse and wireless keyboard), DivX, Flash Player, Flip4Mac, and Perian.

     

    I can't find /private/var/run/StartupItems.

     

    I go to /Library/StartupItems; the folder is empty.

     

    I go to /System/Library/StartupItems; the folder is empty.

     

    I go to /System/Library/LaunchDaemons; there are a lot of .plists in there which don't mean much to me-nothing shows a date which might correspond to the recently introduced Sleep problem. I do know that sometimes trashing a .plist file can fix problems. Is it worth trashing some of them?

     

    I go to /Library/LaunchDaemons; the folder is empty.

     

    Edit: IT'S FIXED!

     

    The only changes I made were to the System Preferences>Other Row. I changed some of the Preferences in the Logitech Control Center and immediately changed them back. I updated Flash and Flip4Mac. There were no updates for Perian. I then rebooted.

     

    Now if you could explain to me WHY this worked, I'd be thrilled. On the otherhand, had you not suggested I check the System Preferences>Other Row I'd still be stuck, so either way I'm thrilled. Thanks for your time and effort.

     

    Message was edited by: Peter WP

  • BDAqua Level 10 Level 10 (120,375 points)

    OK, great news, did we get it fixed yet, we found the problems.