1 2 Previous Next 27 Replies Latest reply: Apr 14, 2014 11:09 AM by Rentoc
kabfoto Level 1 Level 1 (0 points)

I recently purchased two movies from iTunes using a gift card I got for Christmas. I started the download and once the first movie got too about 3.2 GB of 6.2' it stopped and started over for no apparent reason. I tried multiple times to download both movies with no luck the first 24 hours. Was hoping to have it for my flight for my vacation. Over the course of the next three days I have tried downloading the first movie at least 15 times on various WiFi networks, It always begins the download and then either restarts it on it's own or now gives me an error message saying the movie cannot be downloaded at this time, please try again later. I finally got the second movie to download after 10 attempts, but still no luck with the first. I know for certain I had a continuous WiFi connection every time. I am EXTREMELY frustrated at this point. I still have remaining dollars to spend from my gift card, but figure why even bother? I really hope someone can give me an idea which works. So far I have deleted the beginning download on multiple occasions and also tried restarting after this 4 times and nothing seems to work.


MobileMe and iTunes, Mac OS X (10.7.1)
  • 1. Re: Movie Won't Download from iTunes on iPad
    Alfred DeRose Level 5 Level 5 (5,795 points)

    If it's an HD movie, you may not have enough space on your iPad. Have you checked to be sure?

  • 2. Re: Movie Won't Download from iTunes on iPad
    kabfoto Level 1 Level 1 (0 points)

    Thanks for replying Alfred, but yes I have checked and double checked. I have about 7.5 GB of available space for a 6.2 GB movie. I once again deleted it and restarted the download and it is back to downloading about 3.5 GB and then starts over for no reason with no explanation. This is getting REALLY frustrating.

  • 3. Re: Movie Won't Download from iTunes on iPad
    Texas Mac Man Level 8 Level 8 (45,805 points)

    Not sure if this applies to movies also.

     

     

    The GB size of the download app file is the compressed size (like .zip or .dmg). When the file is installed/uncompressed it can be 2-3 times larger.

     

     Cheers, Tom

  • 4. Re: Movie Won't Download from iTunes on iPad
    Alfred DeRose Level 5 Level 5 (5,795 points)

    Even if this isn't the case, I think an extra 1.3 GB isn't enough overhead for a well running iPad - even for the 16 GB model.

  • 5. Re: Movie Won't Download from iTunes on iPad
    Alfred DeRose Level 5 Level 5 (5,795 points)

    You're welcome, but please see my note below in response to Texas Mac Man.

  • 6. Re: Movie Won't Download from iTunes on iPad
    kabfoto Level 1 Level 1 (0 points)

    Thanks again, but I honestly don't see how the file size is the issue. First, I have a hard time believing it is a compressed file. Sorry Texas Mac, but that just doesn't seem correct. So you're saying the HD movie is 12-18 GB? Never seen one even close ot that large. This is already a large HD movie at 6.2GB. If the room is an issue, which I have had in the past, I would normally get a download message saying I don't have enough room on this iPad to download this movie. Seen it before many times. So, again, I don't see how file size is the issue. Yes, I can see how it may slow my machine and not make it as efficient, but I should still be able to downoad the movie.Since I wrote this, I have tried downoading another 5 times. At this point, I am really about to give up and never buy another movie or really anything more from Apple. This should not be this hard. Especially feeling ripped off since this itunes card was my main Christmas present.

  • 7. Re: Movie Won't Download from iTunes on iPad
    JoseDelPescador Level 1 Level 1 (0 points)

    This exact thing happened to me (iOS 7.0.4).  iTunes video rental/purchase downloads kept failing and automatically restarting and I assumed it was an internet problem.  But after creating more than 2x enough space for the downloaded movie, it was finally able to complete the download without incident.  To me, this reads like a memory use error that does not generate an error message.  I don't agree with TexasMan that the final file size is 2-3x larger than the compressed download size because then the Usage panel would show really large file sizes.  Instead, at some point in the video download process, there is a REALLY inefficient use of storage memory.   In any case, I think this problem can be cured by clearing 2-3x more storage space than is needed for the video.

  • 8. Re: Movie Won't Download from iTunes on iPad
    kabfoto Level 1 Level 1 (0 points)

    I think this is something going on with my iPad. I am now having the same issue with another movie which is 4.2GB and I have over 11GB available. So, I tried downloading to my computer and then backing up my iPad and selecting the same movie to be copied to my iPad and was successful. Obviously. Not a storage issue.

  • 9. Re: Movie Won't Download from iTunes on iPad
    chitty73 Level 1 Level 1 (0 points)

    Oh my god I am sooooooo annoyed and frustrated, enough to throw my ipad out the window!!  Tried everything suggested and none of it works.  Rented movie and part way through download it stopped and now it goes straight to download error.  I have 15g of space for a 4g movie.  Cannot put into words how angry I am, especially when I see posts in 2010 with similar issue.  Don't even know where I go to get my money back. 

  • 10. Re: Movie Won't Download from iTunes on iPad
    CXK Level 1 Level 1 (0 points)

    I have been having this problem since iOS 7 released.  I have a 32gb 3rd gen iPad.  I seem to have some artificial cap of 7 items from iTunes on my iPad at once.  Even with 6 movies I have 5.8gb left.  I only download the SD versions. 

     

    As soon as I hit 7 movies/tv shows on my iPad downloads fail almost 100% of the time.  They get near the end, freeze and then loop.  Ocassionally I'll get a "Unable to download" error but most times it just keeps going over and over.  Not only do I have this extremely annoying issue, but during this problem my iPad becomes nearly unusable.  While downloading, my iPad runs so poorly I'll open my cover or press the wake button and the screen will remain off.  I can press both buttons, open/close the cover and NOTHING.  It will stay like that for a minute sometimes.  IF it becomes usable apps will take 30 seconds just to open/close, scrolling is unresponsive for many seconds at a time and then scrolls all at once.  It almost as if the download is using all of the CPU's power. 

     

    I have 253 movies I've bought in iTunes.  I own 6 Apple TV's, 2 Retina Macbooks, 1 iMac, 2 iPads and 2 iPhones.  iTunes works great on all of those devices minus my iPad.  My wife's, which is the same model minus a cell connection is fine.  I am extremely annoyed with this problem.  I've started to loathe using my iPad and thats just rediculous. 

     

    If anyone has suggestions I'm all ears, I've tried these fixes:

    Erased all content/settings and restored from iCloud Back up

    Erased all content/settings and restored but DID NOT use iCloud back up. (I did notice downloads worked great for the first few weeks, then went to crap.)

    Tried force restarting the iPad when its acting up

    Used my Time Capsule's Wifi - No change

    Used my guest network from my Netgear router - No Change

    Used my parent's wifi today - No change.

     

    This doesnt seem to be a widespread problem, I've had trouble finding help on these forums.  Apple is constantly silent and most other users never reply with the same problem.  I'm close to giving up and getting a replacement from Square Trade.  I will not buy a new iPad less than two years after getting that one, mainly out of protest.  I have little confidence in the Air doing much better or lasting longer than this current one.

  • 11. Re: Movie Won't Download from iTunes on iPad
    CXK Level 1 Level 1 (0 points)

    I figured i'd keep trying to find a solution to the problem, I was interested in the lack of space for the iPad to operate.  When I check my usage section i had 4.7gb free yet the "Videos" portion shows "No data" when I have 6 movies downloaded.  The no data thing has been going on for a month now. 

     

    I deleted two apps at 2.6gb leaving me 7.3gb free.  I tried to download an SD movies that was 1.4gb, it got to 1.2GB and just restarted without any notification, it got to 1.2GB again and crapped out.  I stopped the download.

     

    Does anyone else have the problem of the iPad not showing how much space the "Videos" section is using?

  • 12. Re: Movie Won't Download from iTunes on iPad
    FergiDotCom42 Level 1 Level 1 (0 points)

    I have had the same problem downloading rentals for months, trying everything suggested here until I cleared 16 Gb of free space on my iPad for a 3.2 Gb movie, which worked! It didn't work with only 12 Gb free and now everything works. There must be some REALLY inefficient storage management going on the iTunes download process. Try making massive overkill space available and try it aging. Bummer dude!

  • 13. Re: Movie Won't Download from iTunes on iPad
    cirrus Level 1 Level 1 (0 points)

    Same issue for me. Sometimes the downloads eventually work, but often it just keeps restating over and over, running down the battery over time even if plugged in. Plenty of space on the iPad. I have tried turning off the autolock, thinking maybe it was going to sleep. But there doesn't seem to be a rhyme or reason to the failure... So annoying. Does Apple ever actually step in with a suggestion? Has anyone tried to get help from them?

  • 14. Re: Movie Won't Download from iTunes on iPad
    r3dsh1rt Level 1 Level 1 (0 points)

    Yes, I to would like an answer. There was 5+ GB available space on my iPad 4, try to download a 4.2 GB movie, download would process to about 2+ GB, then stop. The download would not pick up from where it left off, the available space went down, I freed more space to 7+ GB available, then went to download again. Have no idea what consumed the 2+ GB available space. Same thing happen. Movie never downloaded. Available space is 1.2 GB. No idea what is using this space. No app has increased in usage.

    Tried forced restart, backup, disconnect from wifi… looks like previous suggestions aren't working either.

    Any help would be appreciated.

1 2 Previous Next