3 Replies Latest reply: Dec 29, 2013 1:34 PM by Linc Davis
LeBalladeer Level 1 (0 points)

I've a HP Deskjet J380 All-in-One.


I have never used any printer on my MacBook Air before.


This is what I did:


  • I connected printer to  a power source and then I connected to my MBA using USB.
  • I receveid a software update prompt telling me "2.39GB update required"
    • My softwares were up-to-date, checked just before connected
      • Why would a printer driver take 2.39GB on my machine? (I am ready to install it anyway, I just want this printer/scanner to work)
    • It didn't proceed further as I had only 1.39GB free at that time, so I cancelled it and freed some space.
    • After that I never saw that software update prompt again. I didn't see it even after manually checking for udates.
  • Nothing happened after that. No software update pop-up. It seems there's no communication between MBA and Printer
    • I tried connecting, disconnecting, swtiching off power; MBA restart.
    • Even deleted /Library/Printers/hp; /Library/Printers/PPDs doesn't have a single file anyway.
  • Tried manually adding it but it didn't work
    • When I try to add it manually, I can see this in the device list. But that's it.
      • When I connect the printer to MBA the light goes green and when I disconnect it goes red (so at least some communication is present)
      • In Image Capture or any app I can't see a thing.
  • It was working fine at my friend's place.
    • In fact this is what I see on the printer
  • Even after I added the device manually the print comamnd didn't make anything happen in the printer; Somtimes I am not at all able to see the manually added printer in print dialog box.


So I am stuck here with my printer/scanner. It will be fine even if I am able to use just the scanner. Please sugegst a fix/workaround.

MacBook Air, OS X Mavericks (10.9)