13 Replies Latest reply: Feb 4, 2016 9:34 AM by tnbriggs
GrazerF16 Level 1 (0 points)

Upgraded to Mavericks earlier this year.  Was using Cox as my internet provider at the time then switched to Centurylink in August.  With Cox, I could send/receive all of my Gmail messages just fine.  But now I can only receive Gmail messages but cannot send.  Have set up incoming mail with imap.gmail.com and outgoing with smtp.gmail.com (per several online videos and suggestions).  No luck.  If I default back to the Cox.net server, I can send and receive from Gmail but at some point Cox will shutdown my ability to continue using their server.  So, how can I send Gmail messages from Mail???


MacBook Air (13-inch Mid 2012), OS X Mavericks (10.9.1)
  • Level 5 (4,015 points)

    Hey GrazerF16,

     

     

    Thanks for the question. I understand you are experiencing issues with Mail in Mavericks. To isolate the issue, you can utilize the steps in this resource along with the Connection Doctor:

     

    OS X Mail: Troubleshooting sending and receiving email messages

    http://support.apple.com/kb/TS3276

     

    You may also wish to double check your mail settings are correct:

     

    Apple - Support - Mail Settings Lookup

    http://www.apple.com/support/mail-settings-lookup/

     

     

    Thanks,

     

    Matt M.

  • apple_cgn Level 1 (0 points)

    enter as additional DNS Server in your TCP/IP connection the Google DNS servers:

    8.8.8.8

    8.8.8.4

     

    worked for me. (confirmed by deleting DNS entries again and getting the same connections problems again)

    Looks like Google has an issue with its DNS for smtp.gmail.com which needs its own DNS server to point to the correct server.

  • quisait21 Level 1 (0 points)

    This one has been driving me crazy too...   Long story short, I discovered that during the initial set up process OS X mail "simplifies" that Gmail user name login credentials to just your "username" (versus the full username@domain.com login name). 

     

    It does not force you to specify the server port (I'm assuming it tries all of the permitted ports).

     

    In the SMTP settings for the Gmail account in question I changed the user name to my fully specfied login user name ("username@domain.com") AND (not sure this was necessary, but I did it anyway) I changed the "server port" to one specified by Google for my Gmail account (587 in my case).

     

    I can now send mail through the Gmail SMTP server from OS X mail.

     

    Hope this helps.

  • Versatran Level 1 (0 points)

    Thank you so much, This is exactly what was wrong with my Mail set up as well.

    It's terrible that this isn't set by default...

  • kinostone Level 1 (0 points)

    quisait21 wrote:

     

    This one has been driving me crazy too...   Long story short, I discovered that during the initial set up process OS X mail "simplifies" that Gmail user name login credentials to just your "username" (versus the full username@domain.com login name). 

     

    It does not force you to specify the server port (I'm assuming it tries all of the permitted ports).

     

    In the SMTP settings for the Gmail account in question I changed the user name to my fully specfied login user name ("username@domain.com") AND (not sure this was necessary, but I did it anyway) I changed the "server port" to one specified by Google for my Gmail account (587 in my case).

     

    I can now send mail through the Gmail SMTP server from OS X mail.

     

    Hope this helps.

     

    This works!!!!!   thank you!

     

    I left port on auto, and still worked.

  • tagrant60 Level 1 (0 points)

    FYI all..... I had the very same issue... This solved it for me:

     

    Went into Mail preferences - accounts... and Apple mail auto set the outgoing smtp server as "GMAIL OFFLINE". I changed it to jus plain "GMAIL" and that was it. Works fine now.

     

    Thanks!

  • BJB_CPFC Level 1 (0 points)

    How did you go from Gmail (Offline) to just plain "Gmail"? I don't see an option to change it.

  • sparkino Level 1 (0 points)

    Had the same problem after a Mavericks upgrade this morning from 10.9.3 to 10.9.4.

    To expand on quisait21's post (which helped me out hugely, thank you), to get to the entry field and go from Gmail (Offline) to Gmail:

     

    Starting from Mail / Preferences / Accounts / <select the gmail account > / Account Information / Outgoing Mail Server (SMTP):

    click on the Gmail (Offline) and you should get a drop down with the last option being "Edit SMTP Server List..."

    In lower panel, choose "Advanced" tab and then double check that the domain name is part of the User Name: field.

    This was the only change I needed to make for it to work again.

  • hincapie19 Level 1 (0 points)

    Had the same issue....tried everything in this post and nothing worked.  I went into my Google Account profile and had to revoke Mac Mail from my 2 factor authentication. I reissued a password for Mac Mail and - poof - everything is working again.

     

    Of course, I had to copy and paste the new app password from Google into the IMAP/SMTP password fields in Mac Mail....

  • Jimmy5 Level 1 (0 points)

    Yes, this worked for me too. In SMTP settings for the Gmail account I added @gmail.com to my user name and I changed the "server port" to 587. Make sure to check this also in System Preferences / Internet Accounts / Google

     

    I can now receive and send Gmail from the Mac mail client. (Before I could just receive after upgrading to Mavericks)

  • mikejb01 Level 1 (0 points)

    Just thought I would add my tuppence worth having experienced a similar issue with Mac mail client/gmail.

     

    In my case I had migrated settings and files from one macbook to a macbook pro. Though I had issues doing the migrate, after the migrate was finally complete everything, including mail worked well.

     

    A month or so later mac mail started to show issues in that it could send and receive hotmail but could only receive gmail, not send. There is no explanation for this as I had not altered any settings in either the mac client or gmail. Observation on the preferences showed my incoming mail was imap (this s stated was working well) but my outgoing smtp was showing as Gmail offline.

     

    No amount of my attempting to edit this out would work. I could edit and for some moments it did show as Gmail and not Gmail offline yet the problem persisted in not sending mail which would remain in my outbox.

     

    My eventual solution was to delete the mac client gmail account on the preferences then add a gmail account (same account).

     

    Seems daft I know but once I had done that everything was back to normal.

     

    I hope this helps others who experience similar issues.

     

    Maybe someone with far more knowledge than I can account for why the OS X managed to play with my mail settings?

  • Hilary1967 Level 1 (0 points)

    I have had this problem for a while and managed to sort it out today!.

    I enabled google mail 2 step verification in November 2015 and haven't been able to send emails recently. I didn't make the connection until I read an article. I just sent emails from my iphone instead. Mailbox keeps asking for my password and does not accept it even though I know it is correct. I turned off my 2 step verification on gmail and lo-and-behold, my email sent straight away. No argument from mail or google! I hope this helps.

  • tnbriggs Level 1 (10 points)

    Fixed it for me, in Lion, too. So the problem was not necessarily Mavericks, more likely it's Google's 2 step. I also used the full email address for gmail.com & the server port suggested above.