13 Replies Latest reply: Dec 21, 2014 11:32 AM by gboser
Jonnygewehr Level 1 Level 1 (0 points)

Hey guys,

 

since updateing to 3.0.2, i get a system overload and a CPU spike no matter what i play. The mouse freezes for a second then it goes back to normal. If i hit a note it starts the overload again.. the only fix is for me to go back to 3.0.1, which i did via time machine.

 

I tried chaning lanetcy, plugins, new concert, reinstall, delete .plist, etc but nothing worked.

 

anyone else having this?

  • snakem Level 1 Level 1 (0 points)

    Yep,

     

    3.0.2 is not useable for me, too. Even after creating a "minimal" concert from scratch and deleting the sole patch, leaving mainstage running completely "empty" creates CPU spikes including mouse freezing. Trying different audio / CPU settings does not help, too. Using any patch just leads to immediate audio "stutter" and an overload message.

     

    Currently running on an old 2009 iMac 2,66 GHz Intel Core 2 Duo, 8 GB RAM, Mavericks 10.9.1, NI Komplete Audio 6. But everthing worked nice and smooth on the same Setup with Mainstage 3.0.1. Unfortunately I do not have a time machine backup to go back to 3.0.1. Using Logic Pro X as host for the time being, that works, but it is not Mainstage of course.

  • cronbg Level 1 Level 1 (10 points)

    Same here. Seems like a lot of users are having issues since updating to 3.0.2. I'm just glad I don't have any gigs coming up this month. Hopefully there will be a solution soon.

  • dhicks10 Level 1 Level 1 (0 points)

    Likewise.... in addition, I also had crashes on previously working concerts.  Went back to 3.01.

  • Mua25 Level 1 Level 1 (0 points)

    Excuse me guys, Im having the same increase in cpu usage since 3.0.2. How did you go back to 3.0.1, without time machine?

  • gygaabor Level 1 Level 1 (0 points)

    Yes I have the same question: How can I get the 3.0.1 legally if I don't have time machine? Somebody wrote somewhere that new MBPros with i5, i7 CPUs can work properly with the latest update. Can someone confirm it? If yes then Apple tries to push their users to get new computers. It's a shame that my 2009 MBP worked really fine with 3.0.1 and with this "update" I simply cannot use my stuff AT ALL. Apple guys, *** is going on?

  • dhicks10 Level 1 Level 1 (0 points)

    I recovered 3.01 from my Time Machine - I don't know of any other way.  I'm running on a late 2011 i7 with multitimbral Omnisphere, but I don't know if that's a factor or not...  I just gave up trying to figure it out.

  • cronbg Level 1 Level 1 (10 points)

    gygaabor wrote:

     

    Yes I have the same question: How can I get the 3.0.1 legally if I don't have time machine?

    I'd also be interested to know. I've tried to manually replace 3.0.2 with a copy of 3.0.1 which I had backed up to an external drive via SuperDuper. That didn't work. Seems to not be that easy with apps from the App Store.

     

     

    gygaabor wrote:

     

    Somebody wrote somewhere that new MBPros with i5, i7 CPUs can work properly with the latest update. Can someone confirm it?

     

    Yes. I have two machines: one MacBookPro5,1 which has a Core2Duo and one MacBookPro8,2 which has a Core i7.

    The latter runs 3.0.2 without any issues, no changes whatsoever compared to 3.0.1. The older machine (C2D) however is practically unusable since 3.0.2 although it used to run 3.0.1 perfectly fine.


    gygaabor wrote:

     

    If yes then Apple tries to push their users to get new computers.

    I am certain that is not the case. I have sent feedback to Apple about this and they did respond. I am sure they are looking into this.

    Maybe you should also leave feedback for Apple and provide them with as much information as possible. It might help them to investigate this issue.

    http://www.apple.com/feedback/mainstage.html

  • JavaJ Level 1 Level 1 (60 points)

    2009 2.53 c2d as we'll.  had to give up on Mainstage until Apple fixes it.  I thought it was channel EQ that was the issue but it appears it's just a bad update that Apple let get away.  Using Logic instead now and am running smoothly.  Hopefully Apple can track this down and fix it for good.

  • snakem Level 1 Level 1 (0 points)

    Just updated to Mainstage 3.0.3 and the issue seems fixed.

     

    Not done a lot yet, but a quick first test shows no more spikes and even a quite relaxed CPU.

     

    Thanks Apple for fixing this.

  • papajuice Level 1 Level 1 (0 points)

    Late to this discussion I have MS 3.0.3 with a MBP 2.2 i7 processor with 16 GB Ram and i still get overload and warnigs saying it using 600% of the cpu. I have even made my concerts where I have one patch going and it still does it. Has anybody figured out a fix. I may have to go back to Mainstage 2 or just give up on MS and go Ableton.

  • aerol Level 3 Level 3 (525 points)

    If you're using any multi-threaded plugs, Kontakt being the prime candidate but there are plenty of others, try disabling the multi-threaded support in the Options dialog within Kontakt.

     

    This setting seems to be on in Kontakt by default and when you add the plug-in you don't get any warning. But if it's off and you turn it on then Kontakt throws up a dialog indicating issues having the plug-in and host both being multi-threaded. Something to try.

  • papajuice Level 1 Level 1 (0 points)

    I do have Kompete 9 and Omnisphere. I can have one patch with one channel with one plugin of either Omnisphere or Kontact and then add a second patch or song. And I get the overload warnings and it freezes for a second. I have been using MS for a the past 4 plus years and have had multible patches in a concert and never had this problem. And now since the 3.0.02 and this contuinially happens. I will look at the settings you mentioned and see if that helps.

  • gboser Level 1 Level 1 (0 points)

    I would love to hear if anyone is still having this issue with 3.0.4. I recently picked up an early 2011 MBP with a 2.3 i7 and wiped it and did a fresh install of MS and logic. There is absolutely nothing else installed on this machine.

     

    Logic runs great, but when I open MS (even using a single instrument template) CPU usage jumps up to 50+%. If I start playing the single internal instrument for a bit, CPU climbs up over 100% the temperatures start climbing and the fans peg out at over 6k. I have tried multiple things like resetting SMC/PRAM, but nothing seems to help.

     

    Based on the other posts in this thread, it sounds like the problem is tied to the generation of the processor. And the fact that 3.0.4 seems to run fine on my i7 retina MBP seems to confirm that.

     

    Does anyone know of a workaround?