Skip navigation

Canadian holidays in Mac Calendar?

651 Views 12 Replies Latest reply: Jan 11, 2014 7:06 AM by Subbu44 RSS
Subbu44 Level 1 Level 1 (0 points)
Currently Being Moderated
Jan 3, 2014 6:42 AM

Hi! My Mac Calendar is displaying US holidays. Not sure where it is getting it from, considering my location under Date/Time does show the Canadian city where I live. How do I get my Calendar to display Canadian holidays instead?

 

I am using OS X Mavericks 10.9.1 on a Macbook Pro.

 

Thanks.

 

Subbu

Macbook Pro and Mac Pro quad, Two 23" monitors
  • Barry Wilbraham1 Level 2 Level 2 (235 points)
    Currently Being Moderated
    Jan 3, 2014 6:52 AM (in response to Subbu44)

    Silly question but does your Mac know that its being used in Canada?  It could be that it's configured for the USA.  I'm only guessing as I'm in the UK.  

  • Barry Wilbraham1 Level 2 Level 2 (235 points)
    Currently Being Moderated
    Jan 5, 2014 6:34 AM (in response to Subbu44)

    A Gipsy's Glass Ball is always good! 

  • Barry Wilbraham1 Level 2 Level 2 (235 points)
    Currently Being Moderated
    Jan 5, 2014 6:40 AM (in response to Barry Wilbraham1)

    Found it.  The glass ball - that is.....

     

      Calendar > Advanced >  Turn on Tiime Zone Support - Calendar opens and top right shows your regional area.  Underneath is the word OTHER click on that and enter your country. 

  • Barry Wilbraham1 Level 2 Level 2 (235 points)
    Currently Being Moderated
    Jan 6, 2014 11:18 AM (in response to Subbu44)

    Just a thought, I've looked at my own settings > System Preferences > Language > Region >

     

    Mine shows Region as USA  Interesting?   Maybe this is your problem solved.......

     

    Particularly when I'm a resident of the UK  

  • Eustace Mendis Level 7 Level 7 (24,590 points)
    Currently Being Moderated
    Jan 6, 2014 12:05 PM (in response to Subbu44)

    The first thing to do if a simple setting does not "take" is to reset PRAM. Have you tried that? Do it after you have entered the correct settings.

     

    (see http://support.apple.com/kb/ht1379)

     

    1. Shut down your Mac.
    2. Locate the following keys on the keyboard: Command (⌘), Option, P, and R. You will need to hold these keys down simultaneously in step 4.
    3. Turn on the computer.
    4. Press and hold the Command-Option-P-R keys before the gray screen appears.
    5. Hold the keys down until the computer restarts and you hear the startup sound for the second time.
    6. Release the keys.

    Calendar has no problems on my computer in Toronto. Here's Family day in February:

    Screen Shot 2014-01-06 at 3.00.03 PM.png

    My settings in System Preferences / Langague and Region:

    Screen Shot 2014-01-06 at 3.00.48 PM.png

  • Eric Root Level 6 Level 6 (13,850 points)
    Currently Being Moderated
    Jan 6, 2014 1:31 PM (in response to Subbu44)

    If you can't sort it out, you can go to the link below, page 7 at the bottom and subscribe to to the Canadian Holidays Calendar by hitting the download button.

     

    http://www.apple.com/downloads/macosx/calendars/index6.html

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.