12 Replies Latest reply: Jun 28, 2014 10:34 AM by g_mac_man
Jill Mcalester Level 1 Level 1 (0 points)

The first time using Pages in Maverick and since the 5.0.1 update and I can't select text and edit it any more.  Tried clicking on it, right clicking, double clicking. The mentioned actions select the box which I can move, resize etc. but not edit the enclosed text. If I try just typing it deletes all the text and starts over with the new text.  What am I missing?


iMac, iOS 5
  • VikingOSX Level 6 Level 6 (8,920 points)

    Interesting. Have Pages v5.0.1 on OS X 10.9.1.

     

    A single click in the Text Box selects the box. A double-click inside the box sets text editing focus. A triple-click inside the box will select all text. Any selected text will be whacked with new typing or a space bar.

     

    The only way I can duplicate this is to change the highlight color to white in System Preferences > General. You can perform the above double and triple clicks with no highlight result showing. Then when you type a character, the invisible block of selected text is wiped out.

  • Jill Mcalester Level 1 Level 1 (0 points)

    No amount of clicking inside the box selects anything and as soon as I type it erases all of the previous text.  I have gone back to using the previous release of Pages and that works just fine but the latest release is useless to me. Thanks for trying to help though.

  • VikingOSX Level 6 Level 6 (8,920 points)

    There is so much missing from Pages v5.0.1 that returning to Pages ’09 v4.3 is nearly euphoric.

  • whippety Level 1 Level 1 (0 points)

    I am having the exact same problem as Jill. In frustration I decided to go back to edit the document in my old pages version but it will not open either. The icon is there but when I click it, I am taken straight to the new pages version. How can I edit my document?

  • PeterBreis0807 Level 7 Level 7 (32,430 points)

    1. Drag the file icon onto the Pages '09 icon

     

    2. right click on the file icon > open with > Pages '09

     

    3. Open Pages '09 > Open > browse to the document

     

    The Apple Stores have introductory classes to using your Mac, they can be quite valuable and let you ask questions.

     

    Peter

  • whippety Level 1 Level 1 (0 points)

    Thank you Peter. I have signed up for the classes but I could do with the tutor sitting at my side 24/7!

  • PeterBreis0807 Level 7 Level 7 (32,430 points)

    If you come from Windows there are similarities, which you can build on.

     

    A few quick classes will certainly get you on your way.

     

    The best tip I can offer, is that you read the Menu titles in Pages.

     

    They mean what they say and, along with the Inspectors in Pages '09, sensibly work from the overall document down to the details from left to right in natural reading order.

     

    Peter

  • Daniel Sass Level 1 Level 1 (15 points)

    It's amazing that there has been no resolution to this problem by Apple yet.  In previous versions of pages, when I encountered a similar problem, I was able to click "Make Background Objects Selectable" and then I was able to access the text.  That option is now gone.

     

    After spending the morning fiddling around, I discovered the culprit and a fix, BUT NOT A SOLUTION.

     

    It appears (at least for me) that somehow the margin box obstructs the ability to select anything behind the margin box.  I know what a margin setting is, but I'm not sure if it is working the way it should in Pages 5.  Typically the page margins shape the page setup.  However in Pages it doesn't do that at all.  The way I was able to gain acees to my text was to move the page margins completely off to one side, freeing up the text behind it.  I set the Right & Bottom margins to 0 and the Left and Top margins to the largest number it would accept.  In the normal world, this would destroy the page formatting.  In the new Pages 5.1 world, it returns the ability to edit text and does not affect the formatting on the page.

  • Albert P Level 1 Level 1 (0 points)

    Unbelievable. Few months further and still no solution. Way to go Apple. If you only want to change a few words you are able to drag a box around the text starting outside the actual page. Does not work for all text boxes. But how difficult can it be to fix this bug and make the text clickable and editable??? For now, I went back to Pages 4.3 (I also abandoned Numbers and switched back to Excel, this is a hopeless version of iWorks)

  • g_mac_man Level 1 Level 1 (0 points)

    I'm having the same problem, with a brand new document.

     

    Here's what I'm doing.

     

    1. Create a new blank doc, using the default template.

    2. Insert a shape, in this case I tried both a filled and an outlined shape.

    3. The shape with no filling, is not selectable.  The shape with the filled interior can be selected.

     

    So here's the workaround (and yep, I hate workarounds, but also I don't want to downgrade).

    1. Insert a shape, filled.

    2. Select the shape, turn off the fill, give it the border you like, turn off the shado.

     

    You now have a working box that you can work with.

     

    Where do we file a bug report - this seems kind of ridiculous.

  • Jeff Shenk Level 4 Level 4 (2,500 points)

    Of course, a shape with no fill is selectable. You can select it by clicking on it, or by clicking outside it and dragging over it.

     

    But if you want to select it by clicking on it, you actually have to do that. An outline with no fill is just that: an outline. The only "it" on which to click is the outline. Clicking inside an unfilled outline is actually clicking on whatever is behind the shape (if something is). (Actually, when I tried it in word processing mode, even clicking inside the shape worked, but I suspect that was some kind of interplay with the wrap setting, which I did not explore, since layout mode matched your described behavior better.)

  • g_mac_man Level 1 Level 1 (0 points)

    Sure, if you click exactly, precisely, on the border.  (And thanks for that!)

     

    Compared to Pages 09 - which actually works without mucking about, this feature is very close to broken.  Also, if you're mouse sensitivity is turned up for two screens - it's almost impossible to see the cursor change unless you *know* it's there.

     

    Quite frustrating, and definitely a bug.

     

    Frankly I used to love Pages but keep running into silly things like this that clearly haven't passed the QA smell test (aka - missing two page view) that makes me think Apple has icloud rose coloured kool aid that I don't feel like drinking.