10 Replies Latest reply: Aug 12, 2014 12:00 PM by SJwithaneye
Thomas Schaller Level 1 Level 1 (105 points)

For some reason my iTunes and iPhoto libraries don't show up in iMovie anymore. The area where one can access songs or photos is empty - seems like the link is broken between the iLife apps.

I have searched the web and followed others' suggestions, but no luck.

I have deleted all sort of preferences in my user account as well as on the hard disk.

I have created another admin account - same problem there - doesn't see the one iTunes song I downloaded.

I have reinstalled all iLife apps and updated them - no go. Same issue (even when in iMovie version 8 (when I update I use version 9).

I have made sur eonly 1 iMovie app is present (deleted version 8)

 

I have iLife '11 running in Mountain Lion (10.8.5).

 

Any ideas?


Mac mini (Mid 2010), OS X Mountain Lion (10.8.5)
  • GeeD Level 4 Level 4 (3,700 points)

    See post by JeffMark77 at:

    https://discussions.apple.com/thread/2622147?start=60&tstart=0

     

    on how to relink iPhoto library.  A similar approach may work for iTunes.

     

    Just emptying iPhoto trash may be sufficient according to:

     

    https://discussions.apple.com/message/15810478#15810478

     

    Geoff.

  • Thomas Schaller Level 1 Level 1 (105 points)

    Thanks Geoff.

    The problem I'm having is not with items missing in the Event or Project library, but when trying to add music (or photos) - see screenshot. The window where one is supposed to place a piece of music from one's iTunes library (or iPhoto library) is empty.

    My iTunes library holds many songs and is in my correct user folder.

    I repaired permissions. Also no go.

     

    Of course I can manually place songs in an iMovie project, but it was so much nicer within iMovie.

     

    Screen Shot 2014-01-05 at 12.15.55 PM.png

     

    Screen Shot 2014-01-05 at 12.16.10 PM.png

  • GeeD Level 4 Level 4 (3,700 points)

    This is what I understood - your iPhoto and iTunes libraries appear empty when selected from the iMovie 9 - the link to their location is broken.  Apparently this can be restored in the case of iPhoto by the procedures described in the articles I referenced.  iPhoto must be sending the wrong information to iMovie when it requests the iPhoto library.

     

    Geoff.

  • Thomas Schaller Level 1 Level 1 (105 points)

    I tried both suggesionts from the links above.

    Didn't change anything.

    Both windows stay empty in iMovie.

     

    Thanks anyway.

  • GeeD Level 4 Level 4 (3,700 points)

    Same after shutting down and rebooting?

     

    Geoff.

  • Thomas Schaller Level 1 Level 1 (105 points)

    Afraid so.

    I option-clicked iPhoto, created a new iPhoto folder, stuck a photo in.

    Closed it, rebooted.

    Opened iMovie - still nothing showed up - that one added photo was not there.

     

    Thanks for trying.

  • Thomas Schaller Level 1 Level 1 (105 points)

    OK, now something is weird.

    When I try to link iPhoto to my old (real) folder, I can see 2 versions of it (that wasn't there before).

    Looking in the finder though I only see one.

    Might there be a hidden one?

     

    I opened Terminal and went to that directory, but Terminal also only sees 1 folder called iPhoto Library.

     

    Strange though.

  • GeeD Level 4 Level 4 (3,700 points)

    It seems like there is something wrong with the configuration of iPhoto.  There is an Apple article on troubleshooting at  http://support.apple.com/kb/HT2638?viewlocale=en_US&locale=en_US

     

    There is evidently only one copy of the action photo originals but there may be more than one file that describes its contents and location.   The problem with these iLife application libraries is that I've never seen any detailed technical description of exacly how they work.  (I don't use iPhoto myself and don't have it installed -  I just keep my photos and videos in my own directory and use the Finder for everyhting).

     

    Its the same with iTunes (which I do use) - there is an iTunes Music Library .xml file which if opened with Property List Editor seems to contain all the information about the music items but not the music files themselves which reside in the  iTunes Music folder.  

     

    I don'tthink I can help any further.

     

    Geoff

  • Thomas Schaller Level 1 Level 1 (105 points)

    Thanks Geoff.

    Tried the First Aid options for iPhoto - no change.

    It seems to me the problem is somewhere higher in the hierarchy of the iLife structure, since neither iPhoto nor iTunes files can be seen from iMovie.

    And since I trashed all iLife apps and their supporting library files and reinstalled everything I'm not sure why this issue is still there.

     

    Thanks again.

  • SJwithaneye Level 1 Level 1 (0 points)

    So annoying, so it seems that no one has ever been able to figure out how to link their iTunes with their iMovie when they encounter this problem. Not that the "help" menu has ever really been helpful, but this makes me question the allegiance to Apple products, when every time I encounter a problem, it is NEVER discussed in the menu, instead all the OBVIOUS processes are described in Big Bird Cookie Monster language, like we're morons. I found this issue dating back as far as 2009 and am still brainstorming different keyword searches in hopes of a good solution, but Apple never got the memo? I guess it doesn't matter if everyone's so devoted to a technology monster just for appearance purposes anyway, I just wish the products and customer service were as cool as they perpetrate!