2 Replies Latest reply: Jan 6, 2014 9:44 AM by JimLockyer
JimLockyer Level 1 Level 1 (0 points)

I've got an iPhone with ios7, set up with 2 mail accounts, one of which is an Exchange account.

It was working well until about 3-4 days ago, but for some reason the phone has suddenly stopped accessing my exchange account and the message comes up "cannot connect to server".

There does not seem to be a problem at our server end and I can get my emails using a laptop, etc.

I've tried everything I can think of, including deleting and adding the exchange account (which was a pity as I've lost my contacts, etc) but it still does not connect.

I've tried looking on forums but can't find anything that helps.

Any ideas?

JimLockyer


iPhone 5, iOS 7.0.4
  • Templeton Peck Level 9 Level 9 (59,280 points)

    JimLockyer wrote:

     

     

    There does not seem to be a problem at our server end and I can get my emails using a laptop, etc.

     

    That doesn't necessarily mean anything as the server addresses and protocols used between the phone's activesync and your laptop connection are most likely different.

     

    I would contact your Exchange admins and verify the activesync settings.

  • JimLockyer Level 1 Level 1 (0 points)

    Thank you Templeton,

    It pointed me in the right direction and whilst active sync and the server all seemed to be fine, I reverted to the sadly tried and trusted technique of shutting down and restarting our server, and guess what? I found I was able to connect to exchange from my iPhone - computers eh!