6 Replies Latest reply: Jan 28, 2014 2:45 PM by Grant Lenahan
Octofunk Level 1 Level 1 (0 points)

After updating to 10.9.1 None of my mail accounts can connect. When I open connection doctor it says:

 

"Could not connect to this iCloud IMAP server. Check your network connection and that you entered the correct information in teh Accounts preferences. Also verfiy that your server supports SSL. If it does not, deselect "Use SSl" checkbox in the advanced tab of Account preferences."

 

All of the accounts worked fine BEFORE i updated. Also, iMessage accounts can no longer connect either.

 

When i check SOftware update it says it installed 10.9.1 OSX update TWICE yesterday. My guess is that is the culprit. I tried resetting mail like suggested in a different post, but still no connection.

 

Is there any way to un-install an OSX update or to install a previous version? Unfortunately i do not have a system backup....


iMac, Mac OS X (10.5.2)
  • Grant Lenahan Level 4 Level 4 (1,190 points)

    simpler to just go in and manually fix the account configurations in mail.

     

    Mail --> preferences --> accounts

     

    You could also delete the accounts and re-do them, let mail re-"find" the server settings. As long as they are IMAP you wont lose mail messages (it may have to re-synch for a while)

     

    Grant

  • Octofunk Level 1 Level 1 (0 points)

    Tried both - still will not connect.

  • Eric Root Level 7 Level 7 (29,020 points)

    Mail Server Information

     

    Reference last line about password - you may have to select Apple Token instead of your password.

  • v1nsai Level 1 Level 1 (0 points)

    Bumping for interest, same thing started happening to me today.  Been on Mavericks almost since day one with no problems, and I didn't install, delete or modify anything between yesterday and today that would cause this to happen.  It appears that it's offline or the address is wrong, but I've been using Mail for years with the same settings, haven't touched it.  Here's some relevant log entries, it simply appears to be the wrong address or offline.....

     

     

    1/27/14 8:36:40.850 PM Mail[744]: Metadata.framework [Error]: couldn't get the client port

    1/27/14 8:28:51.240 PM Mail[744]: [LogSocketErrors] Connecting failed for socket: 0x6000004cfab0, error: Error Domain=NSPOSIXErrorDomain Code=65 "The operation couldn’t be completed. No route to host"

    1/27/14 8:28:38.117 PM icbaccountsd[824]: -[ICBLocalDictionary discoverLocalIAAccounts]: Unknown high level account: com.apple.account.mail - F39B13FD-F33F-4EB9-A780-B6495A4C8E94

    1/27/14 8:26:36.426 PM com.apple.preferences.internetaccounts.remoteservice[763]: An instance 0x7fcc4c45cfb0 of class IMAPMailbox was deallocated while key value observers were still registered with it. Observation info was leaked, and may even become mistakenly attached to some other object. Set a breakpoint on NSKVODeallocateBreak to stop here in the debugger. Here's the current observation info:

    <NSKeyValueObservationInfo 0x7fcc4c45d0d0> (

    <NSKeyValueObservance 0x7fcc4c45d060: Observer: 0x7fcc4c45c8c0, Key path: uidNext, Options: <New: NO, Old: NO, Prior: NO> Context: 0x7fff89c8f44b, Property: 0x7fcc49f947f0>

    )

    1/27/14 8:13:50.225 PM sandboxd[429]: ([744]) Mail(744) deny file-issue-extension /Applications/System Preferences.app

    1/27/14 8:13:11.434 PM WindowServer[195]: common_reenable_update: UI updates were finally reenabled by application "Mail" after 4.08 seconds (server forcibly re-enabled them after 1.00 seconds)

    1/27/14 8:13:11.248 PM Mail[744]: Metadata.framework [Error]: _MDAccessCopyClientPort failed retrying

    1/27/14 8:13:07.846 PM Mail[744]: Metadata.framework [Error]: MDPlistContainerRef _MDCopyCompleteFlatSchema(int): couldn't fetch complete schema from server ((ipc/send) invalid destination port)

    1/27/14 8:13:07.287 PM Mail[744]: No more available unread queries. Unread query not created for <MFMailbox:0x7fec2252bce0 (relative path=Gray, attributes=0, displayName=Gray uuid=flag-6)>. Setting unread count to 0.

    1/27/14 8:13:07.286 PM Mail[744]: Metadata.framework [Error]: Failed to get task count with error (null)

    1/27/14 8:13:02.143 PM sandboxd[429]: ([744]) Mail(744) deny file-write-create /Library/Mail/Bundles (Disabled)

     

     

    I also disabled Little Snitch and the built in OSX firewall, tried pinging all the smtp and imap servers (they're up), rebooting, hitting the computer while swearing loudly....no dice.

  • v1nsai Level 1 Level 1 (0 points)

    Restarting solved my problem.  I spent HOURS trying to fix this and all I had to do was "turn it off and on again".  Sigh.

     

    Also worth noting that I restarted once before to reset PRAM and that didn't fix it, but a regular restart did.

  • Grant Lenahan Level 4 Level 4 (1,190 points)

    As annoying as it is, that shoudl always be trouble resolution step #1.

     

    Grant