Previous 1 2 Next 28 Replies Latest reply: Aug 12, 2015 10:56 AM by Fay Kelley
arko2 Level 1 (0 points)

Hi, I’m writing because on two Macs we have running Mavericks 10.9.1 (an iMac and a MacBook Pro), we are having a slightly frustrating problem with two Gmail accounts in Mail, where Mail will just stop downloading new messages from one or both of our accounts, until we restart Mail. I was just wondering if anyone else is experiencing this issue and if anyone might know any possible fixes for it? Thanks so much!


MacBook Pro (13-inch Mid 2009), OS X Mavericks (10.9.1)
  • Alex Moliviatis Level 1 (0 points)

    I am having this problem, too. Only happens occasionally, but it is frustrating and I hope they fix the bug.

  • foxer2000 Level 1 (0 points)

    Same problem.  Very frustrating.  Also won't update "unread" mail messages that I have been read and deleted on my iPhone.

  • Eric Root Level 9 (50,388 points)

    The next time it stops downloading go to Mail/Window/Connection Doctor and see if the accounts are connected to the servers. If not, select each server and go to the Show Detail button.

     

    Troubleshooting sending and receiving email messages

  • arko2 Level 1 (0 points)

    Thanks, it’s good to know that others are having this issue too!

  • Bryan Clair Level 1 (5 points)

    I'm having this issue as well.  I've got a Gmail account that's working fine from home (mid 2011 iMac running 10.9.1) and from an iPad I use, but my mid-2009 iMac running 10.9.1 fails to download mail unless I quit and restart Mail.  I tried the Connection Doctor, and it was able to connect to the server, green light, no details.

  • thedug Level 1 (0 points)

    I'm have the same problem. Mail periodically just stops downloading new mail. It's 10:18 PM and hte last emai in osx Mail is at 5:11, while my phone shows 20 emails that have come in since 5:11.

     

    I've tried restarting osx Mail and I've used connection doctor to verify the accounts are connected.

  • William Lloyd Level 7 (21,040 points)

    Have you tried updating to 10.9.2? This was a known issue in 10.9.1; Apple even had a knowledge base article on it.

  • thedug Level 1 (0 points)

    10.9.2 here....

  • Alex Moliviatis Level 1 (0 points)

    After install and restart things seem to be working again without quitting and starting mail app.

  • almost_superman Level 1 (0 points)

    I am having the same issue. The only thing that works is for me to restart or log out and then log back in. All was working fine until I upgraded to Mavericks. And I'm running 10.9.2. This is very frustrating, and is, frankly, unacceptable, but I don't see any solutions here.

  • Jeff 8v7 Level 1 (5 points)

    I'm having the same problem, also running 10.9.2.  I can see new mail message on my iPhone, but my iMac and MacBook Air don't show new messages.  "Get All New Mail", "Syncyronize All Accounts", and "Rebuild" and "Connection Doctor" don't do the trick. Only restarting Mail does it. 

     

    And, each time I restart Mail, I get the "Mail Upgrade" popup, like it's the first time I ran Mail.  So, this could be the problem.

     

    Any one have more ideas on how to fix this?

  • thedug Level 1 (0 points)

    After screwing with this for WAY too long. I found a solution that works!

     

    1. Right click on OSX Mail on the Doc
    2. Click Options
    3. Un-check Keep In Doc
    4. Open Chrome
    5. Go to http://www.gmail.com
    6. Read your email
  • lsal Level 1 (5 points)

    This happens to me in 10.9.2 as well.

     

    I like the suggestion above to throw Mail.app away and use Gmail.com, but sadly I sometimes need a local copy of my messages!

  • Gramps Level 1 (5 points)

    Me too! The funny thing is it only happens with my iMac running Mavericks. I am forced to use only my iPad for sending and receiving email since this bug does not seem to affect iOS devices.

     

    I sent a bug report to Apple yesterday, but have not heard back from them.

Previous 1 2 Next