8 Replies Latest reply: Jan 12, 2014 9:16 PM by nbar
FunBoo Level 1 Level 1 (5 points)

i have an imac OS X Lion 10.7.5  desktop..

 

someone suggested omnidisksweeper..

 

but the site says requires

OS X v10.8+

 

so this is useless for me or ...should i try it.


iMac (21.5-inch Mid 2011), iOS 5.1