4 Replies Latest reply: Jul 29, 2006 8:16 AM by Karl Petersen
sunilpunjabi Level 1 Level 1 (0 points)
I have a strange problem. I just got a new Intel iMac. I moved all my files over tot he new system, no problem. On my old system, I kept some files out side of the users folder so my wife and I can both access them (iTunes, iDVD, iMove, etc)
I have been running like this years with out issue. But the new system seems to have problems with this arrangement. The problem is limited to iMovie, and limited to my wife account (not scoring any point here ).

I keep these “shared” project files in users folder, but outside of any home folder. So the folders look like this.
~\users\iMove
~\users\iDVD
~\users\iTunes

Also under users are our individual home folders
~\users\sunil
~users\tish

When my wife tries to open a iMove file she gets an error that the disk is full or she does not have permission to write to this folder. This only happens with iMovie files, the others open fine. From my login I can open iMovie files, as well as other files.
I have checked the permission on the users folder, the iMovie folder and she seems to have rights to read and write to them. Additionally we are both Admins on the system.

Here is what I have tried already (none resolved the issue)
• Repaired permissions on the volume
• Verified permission, she has read/write to the folder as well are the files she is trying to open, she is also an admin.
• Optimized the system (onyx)
• Reapplied permission, including subfolders.
• Moved files to another location.
• Moved files into her home folder
• Moved files into the shared folder.

My Config
Intel iMac 1.5GB
250GB HDD (125GB) free
OSX 10.4.7
iLife 06


Any ideas?

Intel iMac, Mac OS X (10.4.7)
  • Karl Petersen Level 6 Level 6 (15,170 points)
    Sorry, I don't have any firm answers for this situation, but I can offer some guesses.

    iMovie seems particularly sensitive to permission issues. Problems can occur when moving projects from startup disk to startup disk, as you've apparently done.

    The issues are complicated by the fact that an iMovie 5/iMovie 6 project is a package, a special kind of file that behaves like a folder. The package contains other files and folders.

    When you use the Get Info window to assign permissions to the package, the new permissions aren't necessarily applied to the contents of the package. Those items retain their old permission settings, which I suspect is what causes the problem for iMovie. (The Get Info window lets us apply new permissions to the CONTENTS of a folder, but that doesn't work on a package.)

    To change permissions inside the package, try this:

    • In the Finder, create a duplicate of the project. Work on the copy.

    • Select the name of copy and remove the suffix ".iMovieProject" from the name. Tell the dialog window that opens to accept the change. The iMovie project icon will disappear, replaced by the normal Finder folder icon. The project will now behave like a folder.

    • Select the folder and use the Get Info window to set permissions for the folder, then press the "Apply to enclosed items" button to apply those permissions to the items it contains.

    • Re-select the name of the folder and add back the suffix ".iMovieProject". When you accept the change, the folder icon will change back into an iMovie project icon.

    • Try opening the project in iMovie. With luck, everything will now work.

    When using an external disk to store projects, another solution is to use the Get Info window (for the disk) to set the disk to ignore permissions.

    Karl
  • sunilpunjabi Level 1 Level 1 (0 points)
    AWESOME!
    It worked thank you so much!
  • sunilpunjabi Level 1 Level 1 (0 points)
    AWESOME, it worked!
  • Karl Petersen Level 6 Level 6 (15,170 points)
    AWESOME!
    It worked thank you so much!


    Great! Thanks for letting us know.

    Karl