0 Replies Latest reply: Jan 14, 2014 7:57 PM by jellesk
jellesk Level 1 Level 1 (0 points)

Actually I was just a second away from posting this as a question, then I had success! I found my solution! so thought I'd post anyway in case it can help anyone, because it was hard answer for me to find.

 

I run a MacPro, v 10.5.8. I backup with timemachine. My computer crashed last June the day before a presentation deadline; I had to do an archive and install, then I also did all my upgrades - however not sure if these upgrades were all done before the crash - this may be useful info. I don't always keep up to date on my upgrades.

 

Ever since I got my computer back up and running, most applications had problems. itunes and iphoto I had a lot of trouble with, I was able to get them both running from my backups after going through a lot of trial and error. Aperture I was able to get running after deleting the preferences, then the app, then the receipts, and then restoring the app from my backup. I reset PRAM and did a bunch of other things I don't remember anymore. I should have documented. but it worked in the end (yeah!)

 

I just resolved my iMovie - which was giving me a message that the quicktime component could not be found and to reinstall. I reinstalled and still nothing. I took the quicktime framework from by backup and restored it - voila! solved.

 

Final Cut was a big challenge and I got an error similar to one I found on apple discussions that was posted a few years ago found here: https://discussions.apple.com/thread/2623111?start=0&tstart=0. Whoever helped him seemed to know a lot about this.

 

this was the first part of my log:

 

 

FCP log:


Process: Final Cut Pro [16747]

Path: /Applications/Final Cut Pro.app/Contents/MacOS/Final Cut Pro

Identifier: com.apple.FinalCutPro

Version: 7.0.3 (7.0.3)

Code Type: X86 (Native)

Parent Process: launchd [611]


Interval Since Last Report: 74769 sec

Crashes Since Last Report: 52

Per-App Interval Since Last Report: 2 sec

Per-App Crashes Since Last Report: 1

 

OS Version: Mac OS X 10.5.8 (9L31a)

Report Version: 6


Exception Type: EXC_BREAKPOINT (SIGTRAP)

Exception Codes: 0x0000000000000002, 0x0000000000000000

Crashed Thread: 0


Application Specific Information:

* Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '*** +[ProKit changeToLook:]: unrecognized selector sent to class 0x11010860'


Thread 0 Crashed:

0 com.apple.CoreFoundation 0x91608e94__TERMINATING_DUE_TO_UNCAUGHT_EXCEPTION__ + 4

1 libobjc.A.dylib 0x945cae3b objc_exception_throw + 40

2 com.apple.CoreFoundation 0x916102aa +[NSObject doesNotRecognizeSelector:] + 186

 

 

The solution to the similar problem posted by someone on here a few years ago, was to update their proKit framework. They also said they have /Library/Frameworks/ProKit.framework and /System/Library/PrivateFrameworks/ProKit.framework. However, I don't find ProKit anything anywhere. I've looked in my timemachine backup frameworks and also can't find anything that says proKit. Is ProKit part of an update that I did now that I didn't have before? - making upgraded programs to be looking for this, yet it doesn't exist? If I go to download proKit from Apple, it says it's only for 10.6.6 or later.

 

I tried deleting preferences, deleting application support and then restoring app from backup. I've tried logging into another account; tried deleting preferences-repair permissions-restart;

 

>>>Last but not least! I downloaded ProKit 5.0 for OS 10.5.8, which I did not have at all, (and never had this software before), and my issue was solved! PTL!!

 

 

 



Final Cut Pro 7, Mac OS X (10.5.8)