2 Replies Latest reply: Jan 16, 2014 2:46 AM by lllaass
ChicKitty_ Level 1 Level 1 (0 points)

My iPod 5th generation won't charge anymore, it's new it was bought in August of 2013. It said "the charger is not compatible with this device" I ignored t for a while until I plugged it in again then it didn't want to charge. It died ten I went to my friends place to use her charger. Surprisingly it worked! I am not friends with her anyone so I can't find out what she uses. My iPod was dead since September of 2013. My iPod hasn't been damaged or been wet.  I used new chargers and it didn't work, but worked on my brothers iPad mini he had the same problem.


iPod touch, iOS 7.0.4
  • JEM24 Level 4 Level 4 (1,995 points)

    Have you been using the same cable or a different one with the different charges. If the same cable try a new one, there have been issues with defective cables. Try the cable first. If still no joy, have you tried resetting your iPod? Press and hold both the power and home buttons together until the Apple logo appears (about 15 second) then release both. Or go into Settings>General>Reset>Reset All Settings. (Could also try letting your iPod drain down to zero, then attempt to charge, but you have already done that.)  If all else, you can contact Apple Genius Bar about it, your under warranty, why not use it. Hope this helps, Good luck.

  • lllaass Level 10 Level 10 (163,105 points)

    Not Charge

    - See:      

    iPod touch: Hardware troubleshooting

    iPhone and iPod touch: Charging the battery

    - Try another cable. Some 5G iPods were shipped with Lightning cable that were either initially defective or failed after short use. I suspect a bad cable

    - Try another charging source

    - Inspect the dock connector on the iPod for bent or missing contacts, foreign material, corroded contacts, broken, missing or cracked plastic.

    - Make an appointment at the Genius Bar of an Apple store. The cable as well as the iPod is covered by the one-year warranty.

      Apple Retail Store - Genius Bar