8 Replies Latest reply: Oct 29, 2014 8:33 AM by Ralph Daily
harapeko Level 1 Level 1 (0 points)

Hi everyone. I know there are a lot of questions about this already, but I am still having issues with the size of my .mobilebackups.trash. I disabled local backups through terminal using the command that is floating around then enabled it again to have a clean mobilebackups folder. My mobilebackups folder is clean now at only 8mb in size, but the issue is the .mobilebackups.trash which is at 154gb. I tried to be patient, as some posts said that it would take a while for my mac to delete the old files, but it's been over 24 hours and not only is it still there, it went up by 1 gig (it was 153gig yesterday).

 

I understand the automatic deletions based on threshold stuff, but honestly, I don't want to wait until my computer is less than 20 or 10 per cent until something starts getting deleted. Even if I do wait until it falls below the threshold, it's just going to delete x amount until the freed space meets the threshold limit rather than deleting it all forever, right?

 

Before, my backups took up the large proportion of my storage but now it's changed to yellow (other), which I am assuming is because of .mobilebackups.trash.

 

So, the only thing I want to know is - will .mobilebackups.trash be deleted automatically without my disk space having to fall below those thresholds? If this can be confirmed, then I will leave my mac alone and just wait until it does so.

 

But if I have to wait until my disk space falls below those thresholds for it to be deleted, is there a solution to manually delete this folder without using third party software? (I haven't tried the Tinker Tool yet). I saw the thread on the termnial command to delete it, but I'm not an experienced mac user, so I have my reservations about using it given some of the replies in that thread.

 

Any advice advice appreciated.

 

Details:

Macbook Pro

OS X Lion 10.7.5


Mac Pro, Mac OS X (10.7.5)
  • Linc Davis Level 10 Level 10 (172,905 points)

    I disabled local backups through terminal using the command that is floating around

     

    There is a lot of bad advice floating around, and that's near the bottom of the heap.

     

    Turn Time Machine OFF in its preference pane, then turn it back ON.

  • harapeko Level 1 Level 1 (0 points)

    Thanks, but turning time machine off and on doesn't seem to work. I turned it off in its preference pane and left it off for two hours before turning it back on again.

     

    My problem is still there:

    4.2G/.com.apple.NetBootX
    180K/.DocumentRevisions-V100
    1.6M/.fseventsd
    760K/.MobileBackups
    154G/.MobileBackups.trash

     

    I just want to know when will the 154g be automatically deleted? As I mentioned in my original post, if I need to wait for my disk space to fall below the thresholds then is there another solution to get rid of this data/folder?!

     

    Help please. This is starting to stress me out

  • Linc Davis Level 10 Level 10 (172,905 points)

    Back up all data.

     

    If you have more than one user account, you must be logged in as an administrator to carry out these instructions.

     

    Please triple-click anywhere in the line below on this page to select it:

    sudo mv /.MobileBackups.trash /Trashme

     

    Copy the selected text to the Clipboard by pressing the key combination command-C.

     

    Launch the built-in Terminal application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

     

    Paste into the Terminal window by pressing the key combination command-V. I've tested these instructions only with the Safari web browser. If you use another browser, you may have to press the return key after pasting. You'll be prompted for your login password. Nothing will be displayed when you type it. If you don’t have a login password, you’ll need to set one before you can run the command. You may get a one-time warning to be careful. Confirm. You don't need to post the warning.

     

    If you see a message that your username "is not in the sudoers file," then you're not logged in as an administrator. Log in as one and start over.

    Wait for a new line ending in a dollar sign ($) to appear below what you entered. You can then quit Terminal.

    There will now be a folder called "Trashme" at the top level of the startup volume. Drag it to the Trash and empty. You may be prompted again for your password. If the Trash won't empty, reboot and try again.

  • harapeko Level 1 Level 1 (0 points)

    Linc Davis - thank you so much for your patience and help with this!!! Your detailed explanation was really easy to understand too! I finally got my 154g of disk space back!! I am hesitant with turning time machine on again, but I did so anyway. If this issue comes up again, I'll just turn it off and on again and hope that it just disappears without me having to go into terminal again.

     

    Thank you again!!

  • richrossi Level 1 Level 1 (0 points)

    I gave this a try as I have been experience the same issue.  It somewhat worked for me.  I had about 199 gb of "other" that was mostly my mobilebackups.trash folder.  When emptying the trash, I'm prompted with "The operation can't be completed because a required item is in use".  This happend for multiple files.  I rebooted but am still getting the same prompt.  Now it did free up about 40 gb of space but I'm still stuck with 153 gb of "other". Should I follow through with the steps again and see if that works?  If not, what do a do with the trashme folder in the trash that cannot be emptied?

  • Alan Flanary Level 1 Level 1 (10 points)

    Try using the app Trashit to force empty the trash. That worked for me when Ihad this issue.

     

    http://www.nonamescriptware.com

  • MarkLUK Level 1 Level 1 (0 points)

    Hi Linc Davis,

     

    I followed your steps but no Trashme file appeared. BUT.... I think the mobile backups are now in 'Other' not 'Backups'

     

    Let me explain why....

     

    I had noticed my 750Gb HD fill up very quick - didnt understand where all the content was? Info on HD says I have used 500Gb. When I looked into it via the About my Mac panel I noticed about 200Gb in 'Backups' and about 100Gb in 'Other'

     

    I folowed you steps above and didnt see any Trashme file?

     

    After restarting I noticed the About mu mac panel that the 'Backups' were completly gone but 'Other' is now 300Gb - as if the 200Gb and backups had moved into 'Other'

     

    Very Odd, either way I think theres 200Gb of backups somewhere on my mac and I cant delete them - spent ALL day trying to sort this with no luck ;-(

     

    See this screen shot - I did a Omnidisk sweep (using sudo) and it tells me my HD had 300Gb of files yet the finder tells me im using 500Gb?!?!

     

    Where is that 200GB!!!!???

     

    hd.png

  • Ralph Daily Level 1 Level 1 (45 points)

    I used your method successfully to remove 200GB of stuck .mobilebackups.trash files in 10.9.5. However, new trash files don't seem to go away unless I repeat the procedure every few weeks. This works, but wonder if there's a more permanent solution. Thanks.