4 Replies Latest reply: Jan 19, 2014 3:49 PM by Linc Davis
Alan Williams Level 2 Level 2 (400 points)

For some time now my i7 iMac is experiencing wifi disconnection when new mail arrives in my Inbox. I have turned off Notifications and tried alternative user accounts without success. The radio waves icon remains at full strength display requiring a toggle off and on again to get Safari working once more. Safari is not the problem though because software updates get stopped too by incoming mail when Safari is not running.

 

My other devices retain the wifi connection. Its only the iMac that has the problem.

 

All my devices are running Mavericks or iOS7 as appropriate. Any ideas anyone?

 

AW.

  • Alan Williams Level 2 Level 2 (400 points)

    Having investigated further the wifi drops out of its own accord after tem minutes or so. Incoming email kills it too as described above. Maybe this is a hardware issue?

     

    AW

  • Eric Root Level 7 Level 7 (32,750 points)
  • Alan Williams Level 2 Level 2 (400 points)

    Hi Eric,

     

    Kind of you to suggest so many possible routes to obtaining a fix. I will try those tomorrow.

     

    It was faster for me to indicate an i7 iMac running Mavericks in the question text than update my profile.

     

    AW.

  • Linc Davis Level 10 Level 10 (159,530 points)
    Back up all data before making any changes.
         
    Step 1
      

    Take all the applicable steps in this support article. If you're running OS X 10.8.4 or later, run Wireless Diagnostics and take the remedial steps suggested in the summary that appears, if any. The program also generates a large file of information about your system, which would be used by Apple Engineering in case of a support incident. Don't post the contents here.

      
    Step 2
       
    Run Software Update and install all available updates for OS X or your computer's firmware.

    Step 3

    If you're not using a wireless keyboard or trackpad, disable Bluetooth by selecting Turn Bluetooth Off from the menu with the Bluetooth icon. If you don't have that menu, open the Bluetooth preference pane in System Preferences and check the box marked Show Bluetooth in menu bar. Test. Continue if you find that Wi-Fi is faster with Bluetooth disabled.

    From that same menu, select Open Bluetooth Preferences. If the box labeled Discoverable is checked, uncheck it. Click the Advanced button, and in the sheet that opens, uncheck the top three boxes, if any are checked. Click OK. Enable Bluetooth and test again.

    If the application called "Bluetooth Setup Assistant" is running, quit it. Note: this is not applicable to OS X 10.9 or later.

      
    Step 4

    This step will erase some of your settings in the Network preference pane. Make a note of them before you begin, and recreate them afterwards. It may be helpful to take screenshots of the preference pane.

    Triple-click the line below on this page to select it:

    /Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist

    Right-click or control-click the highlighted line and select

    Services Reveal

    from the contextual menu.* A folder should open with "com.apple.airport.preferences.plist" selected. Move the selected item to the Trash. You may be prompted for your administrator password. Recreate your settings for Wi-Fi in the Network preference pane.

    *If you don't see the contextual menu item, copy the selected text to the Clipboard by pressing the key combination command-C. In the Finder, select

    Go Go to Folder...

    from the menu bar, paste into the box that opens (command-V). You won't see what you pasted because a line break is included. Press return.

    Step 5

     

    Reset the System Management Controller.

    Step 6

    Make a "Genius" appointment at an Apple Store, or go to another authorized service center.