Previous 1 2 3 4 Next 284 Replies Latest reply: Mar 19, 2015 6:13 AM by Craxdk Go to original post
  • Heptite Level 1 Level 1 (0 points)

    Thank you otacon72. This worked for me.

     

    I have learned to manually uninstall iTunes and then install the new version, and never let it try to upgrade.  Even so, better than half the time it fails to install properly and I have to go through hours of troubleshooting to fix it.

     

    At this point every time there's an iTunes update I feel like I'm inviting a monkey wearing a shirt with "Genius" printed on it to come and smear his excrement all over my computer so I can spend hours cleaning it up.

  • surefire81 Level 1 Level 1 (0 points)

    This actually works, thanks for the help mspanner. its now working and i didnt lose my music and my movies.

  • cjla Level 1 Level 1 (10 points)
  • faroult Level 1 Level 1 (0 points)

    Un Grand Merci

     

    Tout refonctionne ici

  • juggalozen Level 1 Level 1 (0 points)

    Thank you so much!  This worked for me!

  • DrSchmenge Level 1 Level 1 (0 points)

    This worked for me in Windows 7 x64.  Uninstall ALL Apple applications, support and updates. Then restart the computer and reinstall the latest version of itunes. Working now.  My libraries, playlists and everything were still there.

     

    "Go into Programs and Features and uninstall:

     

    iTunes

    Apple Application Support

    Apple Mobile Device Support

    Apple Software Update

    Bonjour

     

    Reboot. Download a fresh copy of iTunes. Right click on the exe file and select Run as Administrator. Should fix the issue."

  • sultantr Level 1 Level 1 (0 points)

    Same problem.

     

    ?

  • HillaryT Level 1 Level 1 (0 points)

    I am nervous to reinstall a fresh copy of iTunes. I have some mp3s which I have manually chosen cover art for and I have unchecked a lot of songs I don't want on ipod... May sound stupid but when I download a new version will everything be the same?

     

    So annoyed this happened. I should have listened to my dad when he said to never update iTunes because usually something bad happens.

  • orbitaljoe Level 1 Level 1 (0 points)

    Well, I did all that and now it won't open because it can't read the iTunes library, because it was "created with a newer version of iTunes". Really?... Now what?

  • iscanut Level 1 Level 1 (0 points)

    I too have lost MSVCR80.dll during an attempt to upgrade to 11.1.4 and thus have a corrupted I Tunes. Used System restiore to wind things back a week. This took enough time and I am not happy to waste any more time by unistalling EVERYTHING and then reinstalling. Am happy to use an oler version that works !

  • t1mes Level 1 Level 1 (0 points)

    HillaryT, I was worried about the same thing. What I did was what was recommended (uninstalled all Apple products and iTunes then installed a fresh copy of the latest iTunes). All my play counts, artwork, and unchecked songs were maintained.

  • david_m_f Level 1 Level 1 (0 points)

    I had the same problem and followed an earlier posting advice to uninstall all Apple applications via Control Panel, rebooted and then reinstalled the latest iTunes. This has worked perfectly and I have lost nothing. The whole process took no more than 20 minutes.

  • emoush Level 1 Level 1 (0 points)

    I too started with the missing .dll and I attempted to uninstall all the Apple programs in the correct order.   Got as far as Apple Mobile Device Support and it wouldn't uninstall.   After 4 tries, did the others after it but cannot kill Apple Mobile Device Support.   Tried "change" instead of "uninstall'" and it gave the option to remove it, which I did and it LOOKED like it was uninstalling, then reversed and finally said it wasn't on the computer at all and no changes were made to my computer.

  • jn3631 Level 1 Level 1 (0 points)

    I called Apple Support (1-800-275-2273) and they walked me throught the entire process. My mobile device support wouldn't uninstall either. You can simply ignore that one and leave it. Delete the others, reboot and reinstall from the apple.com website. Hope this helps.

  • dennyz69 Level 1 Level 1 (0 points)

    I received this messgae when I tried to update last night. I did a system restore today and restored it back to the last day a change was made and it solved the problem WITHOUT unistalling iTunes. I run Windows 7!

Previous 1 2 3 4 Next