Previous 1 2 3 4 5 Next 211 Replies Latest reply: Mar 2, 2014 9:59 AM by turingtest2 Go to original post
  • JimAB Level 1 Level 1 (0 points)

    Frustrated too dcingram. Multi device family. I've spent a lot of time trying to fix on my laptop... am sure NOT going to have everyone else downloading an update after the time I spent on first device (without having any success).

     

    And of course I won't be buying anything from Itunes until it works on this machine.

  • candace273 Level 1 Level 1 (0 points)

    looks we are all having the same problem no msvcr80.dll file missing........apple better come up with answer fast...no updating with the new update.........!!!!

  • nbpeters Level 1 Level 1 (0 points)

    I had same itunes upgrade problem. Apple support told me it was Microsoft system software problem and could not help. Also said thye had no way to provide backoff to previous itunes versions. Real disappointed in that situation and with Apple support if there has been this many issues with same situation.  will be trying tt2's resolution stated by unistalling the Apple products then reinstall new itunes  upgrade.  thx

  • Miggy MiggZ Level 1 Level 1 (0 points)

    This is exactly what i had to do to fix the problem!!!! Thanks for your help!!!! What drama.... **** Itunes....

     

    MiggZ

  • theresafromedgewater Level 1 Level 1 (0 points)

    You have got to be kidding me!!  An hour spent fixing this??  Who has an hour to spend fixing their mistake?  I'm very upset by this! 

  • turingtest2 Level 9 Level 9 (54,595 points)

    This process shouldn't take as long as an hour. Yes, it is dull to have to redo what should have been a simple installation, but it isn't unheard of, nor has it been done to deliberately inconvenience you. If you don't fancy working through the repair process you could try using system restore to access a pre-upgrade recovery point. That might be slightly faster.

     

    (As I understand it if you roll back using system restore you should have the previous version.)

     

    tt2

     

    Message was edited by: turingtest2

  • theresafromedgewater Level 1 Level 1 (0 points)

    But Apple's lack of support is clearly done to inconvenience us.  And several people commented it took an hour or longer to resolve.

  • turingtest2 Level 9 Level 9 (54,595 points)

    Your milage may vary. Took me about 20 minutes. It obviously takes longer if you head off down blind alleys before finding a process that works.

     

    tt2

     

    Message was edited by: turingtest2

  • Tolga42 Level 1 Level 1 (0 points)

    LoL.  The solution of uninstall (in order provided) and reinstall works.  But what a horrible thing to put customers through and think of all the customers who are not going to find the answer here.

     

    The installer should be smart enough to detect and fix the issue.  This is just poor design.

     

    Apple, please QA your bits before destroying everyones installs please.

  • jn3631 Level 1 Level 1 (0 points)

    The answer is here. Simply follow the steps. It did take about an hour but that's not bad. It wasn't hard, just waiting for programs to uninstall, rebooting and reinstalling. Some computers might be faster. I have a lot of stuff on mine. For those saying Apple wanted to charge them, I don't understand that. Mine was totally free. He was very helpful, friendly, extremely couteous and patient. They answered the phone right away, no being on hold forever. Walked me through every step as I was afraid I might mess something up haha. After the new install, everything works perfect and I didn't lose any music or anything.

    You can't cry over spilled milk. Yes, their update had a bug in it. Just fix it and move on.

  • otacon72 Level 1 Level 1 (40 points)

    The solution is in these threads just look for it. If you run into a road block uninstalling Apple Mobile Device. Start up Task Manager and if it's in there end the process. You can go into Services and stop and or disable the process in there too.

     

    If after uninstalling all Apple programs, rebooting and installing a fresh copy it still doesn't work then you might want to look into use System Restore. Vast majority should be able to fix the issue without using it.

  • theresafromedgewater Level 1 Level 1 (0 points)

    Sigh, tried all of the above.  Uninstalled all i could.  Then did a system restore.  iTunes still doesn't work.  Complete waste of an evening. I'd been thinking of switching away from iTunes anyway.   Off to Media Monkey.

  • otacon72 Level 1 Level 1 (40 points)

    What error are you getting? You said all you could.. did everything not uninstall?

  • theresafromedgewater Level 1 Level 1 (0 points)

    When it first happened, I tried to repair iTunes, then tried to uninstall iTunes.  After coming here, I uninstalled all the Apple products that would uninstall - Apple Mobile Device Support and iCloud wouldn't uninstall though I tried them several times.  I didn't try to uninstall the Airport as right now my Sonos with Airport Express and my Apple TV are working fine.  I can live without iTunes on my PC but not the rest of my Apple network.

     

    As iTunes still wouldn't install (after a reboot), I then restored back to the earliest system restore point which was unfortunately yesterday right before the last Windows Update occurred.  Trying to start iTunes at the point just gave me a generic 'iTunes cannot run because some of it's required files are missing.' 

     

    I could go back to uninstalling things but not sure it's worth it. 

  • DogFishHeadCase Level 1 Level 1 (0 points)

    Thank you!  I worked on this till 1am!! Your posted was dead on.  Thanks!!!!!!

Previous 1 2 3 4 5 Next