8 Replies Latest reply: Nov 26, 2014 6:26 PM by turingtest2
rhamil Level 1 Level 1 (0 points)

iTunes did an update to new software and I now receive following message: "The procedure entry point_objc_load_image could not be located in the dynamic link library objc.dll". I have deleted iTunes, iCloud, Apple Software Update, Apple mobile Device Support, Bonjour, Apple Application Support then rebooted and reinstalled iTunes 3 different times. I still get the Entry Point not Found pop up and no devices are shown as connected. I have a new iPhone5C and an iPad Air that were purchased at Christmas that I can not update with iTunes. Is there an Apple iTunes cleaner file that will get rid of the offending file? I have tried additional uninstalls with Revo Uninstaller Pro as well as Windows 7 Manager uninstaller with no results? I have also used System Restore to a date prior to the update 11.1.4.62 to no avail.


iPhone 5c, iOS 7.0.4, windows 7 Pro
  • turingtest2 Level 9 Level 9 (56,300 points)

    Search the computer for files with the name objc.dll - it may be that for some reason you have multiple copies in different folders where a single up-to-date version in the "correct" place would work best. I don't offhand know what the correct place is, but it may be readily apparent when the alternatives are presented.

     

    If you started to install iTunes 11.1.4.62 and then attempted to roll back I'd recommend that you reinstall it as this may be the reason things aren't working now.

     

    tt2

  • cn12 Level 1 Level 1 (0 points)

    At first I was having problems with getting iTunes to open or reinstall correctly because of the Apple Mobile Device Service. iTunes works now but my phone isn't being read correctly. I restarted AMDS and the "The procedure entry point_objc_load_image could not be located in the dynamic link library objc.dll" message hasn't been popping up anymore but it's still not being read correctly. It comes up as "Apple iPhone" but not the actual name (which is my first name and it would pop up with the actual name instead of Apple iPhone). The iPhone isn't showing up in iTune either.

    BUT I did search my computer for objc.dll and came up with two results which seems to be in different folders. One was last modified in 2013 and the other was last modified a few days ago. Would the most recent be the correct one and if so what do I do with the other?

  • rhamil Level 1 Level 1 (0 points)

    After a couple more sets of un-install re-install all Apple programs, I used an app called "Autoruns" which identified left overs from a trial "Tune-Up" program I had used with my previous iTunes before the upgrade. After I deleted these registry entries, and rebooted..............iTunes installed, updated twice, and ran fine. Someone at Apple needs to get on the problems with updates if they are going to keep iTunes as a working model to configure its products! I lost 3 days of productivity and over 10 hours of configuring their product to run on Window7 64bit,

  • skaleske Level 1 Level 1 (0 points)

    I am having the same issue. I did a search of my programs and files which could not find any with the "objc.dll" result. I am at a loss.

  • turingtest2 Level 9 Level 9 (56,300 points)
  • Mustapha Ziade Level 1 Level 1 (0 points)

    I have had the same problem.. I searched the web for any idea how to solve it. I tried all what people said to fix. and it did it work. I read all the disscission concerning the problem and nothing worked.

    But finaly, this helped me and fixed my problem:follow my steps:
    1- go to this link www.ursoftware.com/

    2- download your-uninstaller (you can have a free trial version)

    3- uninstall itunes with this program

    4- install it again

     

    Note: removing itunes form add/remove program (control panel) will not work. This program can remove the core files in itunes.

     

  • Rich_in_NFPA Level 1 Level 1 (0 points)

    Tried going to www.ursoftware.com/ -- got error msg when I tried to download.

     

    Warning: mysql_connect(): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) in /srv/www/ursoftware.com/public_html/sc/sa/mysql.class.php on line 20

     

    Doesn't give me any faith in the product if the website is hosed.

  • turingtest2 Level 9 Level 9 (56,300 points)

    You should find all you need in my troubleshooting tip.

     

    tt2