5 Replies Latest reply: Feb 10, 2014 1:14 PM by davebesag
MiaHavero Level 1 (0 points)

I recently installed Mavericks and Mail 7.  Ever since then, my system insists on checking mail automatically, even though:

1. The general preferences in Mail are set to check for new messages manually.

2. The only enabled account (a POP account) has "Include when automatically checking for new messages" unchecked.

 

Despite these settings, if I pick up the computer after it's been asleep for a while, I find that it's downloaded a bunch of new mail.

 

How can I stop this?  If I had wanted the mail to be downloaded automatically, I would have set the preferences to do so.


Mail, OS X Mavericks (10.9.1)
  • Peter Sealy1 Level 2 (175 points)

    Please let us know if you find a solution. Same problem for me.

  • MiaHavero Level 1 (0 points)

    I think I figured out a workaround at least.  It appears that the "Power Nap" feature is doing the mail checking.  Although the concise descriptions of Power Nap say it "allows your Mac to do things like periodically check for new mail, calendar, and other iCloud updates" (http://support.apple.com/kb/HT5394?viewlocale=en_US&locale=en_US), it apparently doesn't just allow these actions, it does them -- regardless of your mail settings.  I suspect this is a bug.

     

    Turning off Power Nap (in the Energy Saver panel in System Preferences) stopped the unwanted mail fetching, but unfortunately that also means that I don't get the benefit of the other activities it does, like Spotlight indexing. There are two places to turn it off, one for the "Battery" tab and one for the "Power Adapter" tab.

     

    Since Power Nap was introduced with Mountain Lion, but I never had the problem until Mavericks, I assume that either (1) Power Nap was off by default in Mountain Lion but is on by default in Mavericks, or (2) this is another of several Mail problems introduced by Mavericks.

  • Peter Sealy1 Level 2 (175 points)

    Thank you for that. I have turned off the Power Nap and turned on the Manually check for messages. Seems to work so far, but a few days will tell. I will post a further response.

  • Peter Sealy1 Level 2 (175 points)

    Sorry to have taken so long to reply.

    That solution has worked for me. Good detective work.

    Thanks

  • davebesag Level 1 (0 points)

    I'll look it this. I'm absolutely furious that this has happened as I'd delierately left some of my messages unread in my webmail inbox. I now have to go back through a total of 362 messages which are now all undread.