2 Replies Latest reply: Jan 25, 2014 12:20 PM by Gregory Frost
Gregory Frost Level 1 (50 points)

I just recently upgraded to Mavericks and was hoping that would resolve a long-time issue with Safari: Specifically, when I click on URL link to a PDF file, what I get is a black screen. If I right-click on the screen, I can download the "invisible" PDF file I am supposed to be seeing; so clearly the PDF is there, the link works, etc.  Only, Safari will not display the PDF.

 

If I switch to Chrome and go to the same link, the PDF shows right up, no problem. And, yes, the easy answer is, use Chrome instead. But I noticed in putting in this question that it seems to be a recurring phenomenon for lots of users, with "PDF not displaying" issues going back at least as far as OSX 10.6. Curious if there is a simple fix.

 

Thanks for any feedback,

-gf


MacBook Pro with Retina display, OS X Mavericks (10.9.1)
  • Linc Davis Level 10 (192,897 points)

    Back up all data before making any changes. Please take each of the following steps until the problem is resolved.

      

    Step 1

      

    If Adobe Reader or Acrobat is installed, and the problem is just that you can't print PDF's displayed in Safari, you may be able to print by moving the cursor to the the bottom edge of the page, somewhere near the middle. A black toolbar may appear under the cursor. Click the printer icon.

      

    Step 2

      

    There should be a setting in its preferences of the Adobe application such as Display PDF in Browser. I don't use those applications myself, so I can't be more precise. Deselect that setting, if it's selected.

      

    Step 3

       

    Triple-click anywhere in the line of text below on this page to select it, the copy the selected text to the Clipboard by pressing the key combination command-C:

    /Library/Internet Plug-ins

     

    In the Finder, select

      

    Go Go to Folder

      

    from the menu bar, or press the key combination shift-command-G. Paste into the text box that opens (command-V), then press return.

      

    From the folder that opens, move to the Trash any items that have "Adobe" or “PDF” in the name. You may be prompted for your login password. Then quit and relaunch Safari.

       

    Step 4

      

    The "Silverlight" web plugin distributed by Microsoft can interfere with PDF display in Safari, so you may need to remove it, if it's present. The same goes for a plugin called "iGetter," and perhaps others — I don't have a complete list. Don't remove Silverlight if you use the "Netflix" video-streaming service.

      

    Step 5

     

    Do as in Step 3 with this line:

    ~/Library/Internet Plug-ins

     

    If you don’t like the results of this procedure, restore the items from the backup you made before you started. Relaunch Safari.

  • Gregory Frost Level 1 (50 points)

    Thanks, Linc.

    While in Acrobat Pro, the "Display PDF in Browser" option remains greyed out, it seems to have been the "PDF-Browser plug-in" in the Internet Plug-ins folder that was blocking/interfering with Safari's displaying of PDFs. After moving that to the trash and restarting Safari, the previously invisible PDF now shows up along with a toolbar of controls and options.

     

    Many thanks,

    gf