4 Replies Latest reply: Jun 29, 2014 8:47 PM by alittlepatience
alittlepatience Level 1 Level 1

My sister's laptop broke and she needs it for her homework. We tried safe boot and RAM rest, neither worked. Finally we tried the disk utility repair, but we cannot click on the buttons. It's a MacBook Pro from the summer of 2011 that runs Mountain Lion.

 

 

Q1: We're stuck at repairing the Mac OS X Base System with Disk Utility because the buttons for both "Verify Disk" and "Repair Disk" are unclickable. 

What should we do?

 

Q2: Is it possible to take a Time Machine backup or any backup at this stage in case we have to wipe the disk?

 

P1050985_small.jpg

---------------------

 

Background information:

 

  1. My sister notices that the computer is very slow when she was typing an email to her friend on a browser while listening to music and having lots of tabs open.
  2. The computer gets slower and slower each time she restarts the computer (force shutting down many times). She restarted 3 or 4 times, once with a 2 hour shut down, once with 10 minutes of being off.
  3. During one of the restarts she gets into the desktop to find all the desktop icons were missing.
  4. The last time she tries to turn it on, she gets the circle with diagonal line startup problem and she left the computer on like that for 3 hours until I tell her to force shut it down.
    P1050978_small.JPG

 

What I tried to do so far, roughly following the gray screen help and a disk0s2: I/O error help:


  1. Unplug the MacBook Pro from the charger. Nothing is plugged into the laptop. Btw, we did not modify the insides of the laptop at all.
  2. Performed a verbose safe boot by Shift-Command-V during startup. Outputs of note:
    1. "incorrect number of thread records"
    2. "repairing volume" (this took a few minutes)
    3. "volumn Macintosh HD was repaired successfully"
    4. "file system was modified"
    5. "disk0s2: I/O error", rows and rows of it!
      P1050982_small.JPG
    6. After 10 minutes of no change (just disk0s2: I/O error), I told her to force shut down the computer.
  3. After the laptop was shut down for a few minutes, I told my sister to reset the NVRAM/PRAM by holding down the Command-Option-P-R keys during startup.
    1. We heard the apple boot sound, she released the keys, then we heard the apple boot sound again. (This is as expected.)
    2. Apple icon and loading circle and this went on for 20 minutes until I told her to force shut down the computer. (This is unexpected as the load after a RAM reset should only be a few seconds before the login screen appears. Our login screen never appeared.)
  4. I tried to use Disk Utility to repair by pressing Command+R during startup.
    1. On the Utility menu, I told her to choose the "Disk Utility"
    2. In select disk volume or image, I told her to choose "Mac OS X Base System"
    3. Wanted to click "Verify Disk" or "Repair Disk", but both options are unavailable (see first picture on top).
    4. I ran out of options from my Googling, so I told her to force shut down the computer.

 

Thanks in advance for helping us.


MacBook Pro, OS X Mountain Lion (10.8), Bought 2011 summer as snow leopard
  • macbig Level 4 Level 4

    Your trying to repair the wrong disk. Select the Macintosh HD. You can verify the disk while it's mounted, but you cannot repair it. You have to run Disk Repair from Recovery. See this http://osxdaily.com/2012/02/08/repair-boot-disk-mac-os-x-disk-utilit/. While your in recovery, and after running Disk Repair, run ACT (Apple Hardware Test). Come back with the results.

  • alittlepatience Level 1 Level 1

    Thanks macbig. I have a few follow up questions:

     

    1. Would running Disk Repair on Macintosh HD destroy the files on it?
    2. How do you know that Macintosh HD is the disk to repair?
    3. Is it possible to take a Time Machine backup or any backup at this stage?

     

    Thank you so much!

  • macbig Level 4 Level 4

    No, Disk repair will no destroy anything.

    I know Macintosh HD is the right disk because I've been fixing Macs for 25 years.

    Re backup: with the condition your system is in I doubt that you can.

    Run disk repair and AHT first then come back.

  • alittlepatience Level 1 Level 1

    Hi macbig,

     

    I finally got to look at my sister's computer. The HDD "Repair Disk" found missing threads, missing directory records, etc. and ended with:

     

    Error: Disk Utility can't repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed-

    up files.

     

    Then, I tried "Verify Disk" and it found invalid volume file count and ended with:

    The volume Macintosh HD was found corrupted and needs to be repaired.

    Error: This disk needs to be repaired. Click Repair Disk

     

     

    I guess running Apple Hardware Test is not going to happen. :/

     

    I've ordered online a new 2.5 disk, make a Maverick boot USB, and start from scratch. Do you have any other suggestions?

     

    As for the corrupted old hard drive, do you have any suggestions of how to get out the data somehow?

     

    Thank you so much!