2 Replies Latest reply: May 13, 2014 3:59 AM by david_alex
QuincyWabash Level 1 Level 1 (0 points)

They keep turning on after I've turned them off and are just annoying at this point..is there anyway to turn them off for good?  You think they would've fixed this problem with the last huge update, right?


Logic Pro X, OS X Mavericks (10.9.1), Alignment Guides
  • jeremy_v Community Specialists Community Specialists (2,990 points)

    Hi QuincyWabash,

     

    Thanks for visiting Apple Support Communities.

     

    If alignment guides are behaving unexpectedly, try this troubleshooting step first:

    Delete the user preferences


    You can resolve many issues by restoring Logic Pro X back to its original settings. This will not impact your media files. To reset your Logic Pro X user preference settings to their original state, do the following:


    1. In the Finder, choose Go to Folder from the Go menu.

    2. Type ~/Library/Preferences in the "Go to the folder" field.

    3. Press the Go button.

    4. Remove the com.apple.logic10.plist file from the Preferences folder. Note that if you have programmed any custom key commands, this will reset them to the defaults. You may wish to export your custom key command as a preset before performing this step. See the Logic Pro X User Manual for details on how to do this. If you are having trouble with a control surface in Logic Pro X, then you may also wish to delete the com.apple.logic.pro.cs file from the preferences folder.

    5. If you have upgraded from an earlier version of Logic Pro, you should also remove~/Library/Preferences/Logic/com.apple.logic.pro.

    6. Restart the computer.

    You can find this method and other troubleshooting steps here:

     

    Logic Pro X: Troubleshooting basics

    http://support.apple.com/kb/HT5859

     

    Regards,

     

    Jeremy

  • david_alex Level 1 Level 1 (0 points)

    Hi Jeremy

     

    I have this problem too, I have found that clicking on the disclosure triangle on the track inspector for the 'Track' part of the inspector panel also strangely toggles the 'alignment guides' setting! Very strange bug! causes me lots of trouble..

     

    I have reported through the apple feedback website, but as this hasn't been fixed in last update perhaps you can submit it?

     

    thanks

     

    David