10 Replies Latest reply: Jul 20, 2014 12:31 AM by jedlh
jedlh Level 1 Level 1 (0 points)

It was fine initially IIRC, but lately if I go away & the display/machine goes to sleep & I come back & start using it, the wifi client won't be connected or connecting until I go to the menu & select the AP it's paired with.


Any ideas? Thank-you.

  • jedlh Level 1 Level 1 (0 points)

    Sometimes it'll just sit there as though it's constantly searching...

    I have to go into network preferences, turn off wifi, turn it on, & only then does it happily connect with the AP.

    It's very annoying, there's no way I'm doing a fresh install of OSX, this is a relatively new/clean env.

  • Linc Davis Level 10 Level 10 (147,605 points)

    Test after taking each of the following steps that you haven't already tried. Back up all data before making any changes.

    1. Make sure the network is on the preferred list by following these instructions. It's important to read the article carefully, as it's the starting point for any further efforts to solve the problem. If you skip any of the steps, the problem may not be solved. Make sure the box marked

    Remember networks this computer has joined

    is checked.

    2. Follow the instructions in this support article under the heading "Symptom: The network connection drops unexpectedly."

    3. Make a note of all your settings for Wi-Fi in the Network preference pane, then delete the connection from the connection list and recreate it with the same settings. You do this by clicking the plus-sign icon below the connection list, and selecting Wi-Fi as the interface in the sheet that opens. Select Join other network from the Network Name menu, then select your network. Enter the password when prompted and save it in the keychain.

    4. From the Location menu at the top of the Network preference pane, select Edit Locations. A sheet will drop down. Click the plus-sign button to create a new location. Give it any name you want. In the new location, set up the Wi-Fi service with the same settings you used before. Click Apply and test.

    5. Launch the Keychain Access application. Search for and delete all AirPort network password items that refer to the network. Make a note of the password first.

    6. Repair permissions on the startup volume.

    7. Turn off Bluetooth and test.

    8. Reset the System Management Controller.

    9. Reset the PRAM.

    10. Reinstall OS X.

  • jedlh Level 1 Level 1 (0 points)

    I tried it again 1st thing this morn & it seems to be working again, very weird.

    Once I go away, I'll see if it's still playing nicely when I come back...

    Only thing I did before went to bed, was delete a AP in my preferred network list that shouldn't really have been there.

  • jedlh Level 1 Level 1 (0 points)

    Sigh... this is still being a freaking PIA....

    If it gets to the point where I have to type my pwd in before I can get back onto my machine, it seems to be fine.

    But if it doesn't get to that point & I try to start using my machine again...

    The AP will be sitting there in plain site, but the rMPB won't attempt to connect until I manually select it from the menu!

    I haven't yet tried ALL the things listed, I definitely won't be doing number 10, even if all the others don't work!

  • jedlh Level 1 Level 1 (0 points)

    1. Of course, done.

    2. They're not my symptoms all, there's no issue with all my other devices that use Wifi.

    3. Done.

    4. Didn't have time to do that before the Apple care guy called, but we did something more comprehensive, he got me to go to /Library/Preferences & rename "SystemConfiguration" to "SystemConfiguration1" & then restart my rMBP.

    5. We did something like this in Key Access, IIRC we searched for the SSID, nothing came up.

    6. I'd already done this ages ago, there's a handful of permission issues IIRC that a repair won't fix, but none of them relate to Wifi settings.

    7. Done.

    8. Done with Apple care.

    9. Done with Apple care.

    10. Done.


    I'm pretty ****** right about now, having spent so much time just to be sure it's a hardware issue >.>

  • jedlh Level 1 Level 1 (0 points)

    To clarify, after turning-off BT it now seems to behave.

    I wish it was one of the 1st things I did instead of the last!

    I'll test for a bit longer before being 100% certain...

  • jedlh Level 1 Level 1 (0 points)

    Yeah sooo... Anyone else had to deal with an issue like this on their rMBP?

    (mine's mid-2012, received it approx. new yrs 2013)

    Not really happy about having to hand over my rMBP for days or weeks.

  • jedlh Level 1 Level 1 (0 points)

    I've since found that even a complete reformat & reinstall doesn't get rid of it completely... >.>

    For a long period it definitely worked without issue, but now some sort of hw fault's creeped into the laptop, the AP, or there's more Wifi noise in the area than before.

    I doubt it's the AP, as none of my other devices have had the same (or similar) issue, not that I've seen yet anyway.

    First I'll rule out interference, I have some tools that'll help me devise a wifi config. that results in the least amt of interference for my AP/clients.

    If there's still problems, I'll swap out my current modem/AP/router for a spare modem + AP/router I have.

    If there's still problems, well, I think we've exhausted everything & can pretty confidently say my rMBP's Wifi client is sub-par, & must be placed on the service/support merry-go-round.

  • jedlh Level 1 Level 1 (0 points)

    Still have this issue since I last posted, I've learned to live with it by having BT turned-off all the time.

    Only when I need  BT do I turn it on...

    Sometimes I forget to turn BT off after I've finished using it & the problem comes back, so it's def. some kind of hw issue.

    I could've gotten Apple Care to look at it ages ago, but I just can't afford to be machineless for more than 24hrs.

    It's really not acceptable for such an expensive machine...


    If anyone's observed this issue on other mid-2012 rMBP's & know how to fix or worked-around it, please share.

    I hope to have a completely upgraded W/LAN infrastructure by the new yr, so maybe that'll improve the situation.

    And I still haven't done everything I said I'd do in my prior post, time permitting I'll get round to that too.

  • jedlh Level 1 Level 1 (0 points)

    So, it turns out that all along this really was just an issue with the OS!!!

    I had an update come through about a wk or so back (10.9.4), & it's been completely fine since!

    http://support.apple.com/kb/HT6281 (see the list of fixes)

    Grrr so much time wasted on all this Oh well, at least it wasn't a hw issue or an issue with my WLAN.