7 Replies Latest reply: May 23, 2014 10:50 PM by lalabear0509
MarlsNZ-London Level 1 Level 1 (0 points)

Mac Air works fine at home on wifi but when I go out it no longer connects to wifi hotspots. Ditto with my husband's Mac Pro.


MacBook Air, Mac OS X (10.6.8), also mac pro
  • mario49 Community Specialists Community Specialists (3,345 points)

    Hello MarlsNZ-London,

     

    Thanks for using Apple Support Communities.

    For more information on this, take a look at:

     

    Wi-Fi: How to troubleshoot Wi-Fi connectivity

    http://support.apple.com/kb/HT4628?viewlocale=en_US

     

    Best of luck,

    Mario

  • MarlsNZ-London Level 1 Level 1 (0 points)

    Hi Mario,

    Thanks for your reply. Had gone through the Troubleshooting pages but to no avail.  Sorry its taken so long to get back as I have been away and needed to test drive the Mac Air in town for WiFi Hotspot connections, as it works fine in our house. Went to a cafe with -The Cloud WiFi. Great signal but no Safari not working. Checked Network Diagnostics all the left hand column of Airport Settings, Network settings etc were on green light  - no problem but still Safari not connecting. Tried sending out emails on WiFi and they worked. Then tried several times Network Setup assistant. Didnt change anything and then  after a handful of attempts of really just going through the same process on Network Assistant Safari kicked in and is fine now. Really don't know what was wrong or what to do in the future to just tap in once and get the connection. Don't fancy endless attempts on Network Assistant again but at least its up and running. Appreciate your help. Thank you. I am a bit of a forever learning (and enjoying it!) novice!

    Once again thanks for your feedback.

    Marls

  • Tom R UK Level 1 Level 1 (10 points)

    For others getting stuck with this, check that you haven't got static DNS servers or search domains defined in your Network properties. Go to System Preferences -> Network -> Advanced... (button on bottom right) -> choose the DNS tab and clear any entries that aren't greyed out in both the DNS Servers and Search Domains panels (select an entry then click on the "-" below the panel). New greyed out DNS entries should appear. Finally click OK.

     

    This worked for us on a Macbook that was previously having nothing to do with The Cloud.

  • MarlsNZ-London Level 1 Level 1 (0 points)

    Thanks for your help. Went to Network - Advanced...DNS and cleared out servers that weren't greyed out - and it solved the problem. Brill!.

    Does mean when I'm back home and some other places that I have to re-enter the DNS servers for protection against adult sites but that's OK. Easy enough to type in the relevant DNS numbers.

    Thanks again.

  • Tom R UK Level 1 Level 1 (10 points)

    You should be able to save the settings for each place as a Location (dropdown at the top of the Network control panel). Sort of thing I ought to do but have never got round to, so I can't be sure that it works.

     

    Glad you got online.

  • MarlsNZ-London Level 1 Level 1 (0 points)

    You're a star. Just tried that and yes it works! Brill!

    Problem solved.

  • lalabear0509 Level 1 Level 1 (0 points)

    Hi! I have the same problem. But I only have one entry in my DNS tab and it's greyed out. What else can I do?