Previous 1 2 Next 16 Replies Latest reply: Mar 6, 2014 1:24 PM by Wesley Miyazaki
Randall White Level 1 Level 1 (5 points)

Since upgrading to iOS7 my iPhone 4S will often return the error "No Results Found" for even the most basic search request.

 

What is even more annoying is it will AutoFill a location and still refuse to find the location it just suggested.

 

Even worse, I have to spend considerable time finding a work-around to get it to give some sort of results so I can actually get to where I was going. It seems that Maps worked best when it was first introduced and "somebody" is introducing issues.

 

For example: I entered the term "newport" and the Maps app offered several results around the World including "Newport, RI, United States"

 

One would reasonably assume that if the app was aware of the state and country it would easily return the results (good luck with that unreasonable expectation). If I remove " , United States" from the search field it easily finds Newport, RI

 

Often when I'm looking for a location and I just put in the numbers, it will find the location and several others around the world even though I only entered the numbers. But since iOS7 there's a bug where — most of the time — I select the suggested address. It will return "No Results Found" and I will have to stop and find some sort of workaround to get to the location.


iPhone 4S, iOS 7.0.4, x2
  • chattphotos Level 4 Level 4 (2,090 points)

    Simple solution, use Google Maps

     

    Otherwise, do you have good network access? Same issue on both wifi and 3G?

     

    Does it happen on other iPhones?

  • Randall White Level 1 Level 1 (5 points)

    Google had a nice collaborative relationship with Apple for years, but they resorted to the most unethical business practices when they released their own smartphone. It's likely that they have also interferred with location services to exacerbate the performance of Maps.

     

    That a Level 3 member of the ASC would start trolling the Discussions is a bit on the questionable side.

     

    As I said, Maps actually worked better — for me — when it first came out. This is a bug, and they should be able to fix it.

     

    I remember the buzz more than 10 years ago when the most reliable analysts were saying AAPL could barely last another year. Many folks were unhappy with FCPX and they're still providing misinformation from 2011. Change is inevitable and you can either undermine progress or swim your way through…

  • Joejoem Level 1 Level 1 (15 points)

    Do a reset, erase all content and settings. setup as new iphone. DO NOT TURN ON ICLOUD, try a map search.

    Mine works fine until I setup icloud. something in my icloud is causing this problem.

  • AKRBTN Level 4 Level 4 (1,355 points)

    I don't suppose chattphotos will be back if that's your response to his/her attempts to help you.

  • chattphotos Level 4 Level 4 (2,090 points)

    AKRBTN, thank you for the kind words. I'm back and a little fluff never hurt anyone.

     

    There's more than one way to slice an Apple... If there's an issue that makes an app unusable, you may want to look at more reliable alternates.

     

    I haven't run across your issue directly, I just get inaccurate results when I use Apple's Maps. Which is why I stick with Google's mapping platform.

     

    But calling my first reply trolling? Really? Don't be so quick to judge such actions.

     

    My mantra, offer a reliable alternate when the other apps don't work or have strange issues.

  • Randall White Level 1 Level 1 (5 points)

    chattphotos

     

    "trolling" was a bit on the strident side, but intended to make a point. Google is simply being a bad citizen here.

     

    Even Joejoem's helpful suggestion misses the point. It's obvious here that there is a bug. One would reasonably assume that when members of the ASC find those bugs, some of those members are Apple Seeders working on new iOS releases and can report those "bugs" directly. When the members of Apple Software Engineering get some spare time (what's that? ) they will check the ASC discussions for outstanding issues.

     

    Yes, you suggested checking networks (this issue happens all over Northern California) and your "points" show that you're more inclined to be an Apple apologist. But I was hoping to develop suggestions that would isolate and fix a bug — which is a "regression" from previous versions. Joejoem may have isolated the issue to be associated with iCloud.

     

    Going through the reset process and not turning on iCloud would be a reasonable test. Once I did that and verified the results — when I have the time — then Joejoem would get some "helpful" points. Leaving iCloud turned off is not a solution.

     

    Today I had to visit a couple folks in two different convalescent facilities that I never visited or searched for with Maps. When I put in the first two words of a three word name Maps came up with the exact street address I was looking for, then returned "no results found" when I requested the location.

     

    As for "inaccurate results" I rarely get that issue, when I do, I try to make an effort to report it so that it can be fixed. My overly paranoid side is telling me that some of those types of issues are related to certain malicious entities who would like to deprecate the standing of Maps…

  • chattphotos Level 4 Level 4 (2,090 points)

    Google, a bad citizen? How? What brought you to that conclusion?

     

    You keep spouting nonsense but calling your issue a bug and then wanting Apple Engineering to talk to you?

     

    Not all of us can replicate your issue, so it's harder to help when we're trying to pin down what could cause it and you're shooting at us for not knowing how to fix it.

     

    Your feisty and brash response has reduced the motivation for helping you further.

     

    Goto: Apple.com/feedback

    Use accordingly

  • ckuan Level 7 Level 7 (26,540 points)

    chattphotos wrote:

     

    Google, a bad citizen? How? What brought you to that conclusion?

    ...

    Yes, see below:

    http://www.macrumors.com/2013/11/18/google-to-pay-17-million-settlement-to-state s-in-safari-privacy-circumvention-case/

  • chattphotos Level 4 Level 4 (2,090 points)

    Ah, I haven't heard anything about that incident until that article.

    Plus, I don't use Safari (the horror) so it really doesn't affect me directly.

     

    But black-marking Google for that is like saying this one restaurant in NYC made bad cheesecake, therefore all cheesecake is terrible.

     

    So, lighten up, try Gmaps as a service, it may make a world of a difference (as it has for my travels around the world)

  • ckuan Level 7 Level 7 (26,540 points)

    If you like to use GMaps, it's your choice.  Google has more than 8 years headstart but till today it has problems. I travel a lot myself and 95% using Apple Maps is reliable. I have other navigation apps as well for the other 5%.

    But no matter how you turn it around, Google as a big company and these kinds of practises is a sign of bad citizen. Remembered Google collecting data while doing Street view?

     

    Maybe you don't know, you are not Google customers, Google needs you to sell ads.

  • Randall White Level 1 Level 1 (5 points)

    chattphotos wrote:

     

    Google, a bad citizen? How? What brought you to that conclusion?

     

    You keep spouting nonsense but calling your issue a bug and then wanting Apple Engineering to talk to you?

     

    Not all of us can replicate your issue, so it's harder to help when we're trying to pin down what could cause it and you're shooting at us for not knowing how to fix it.

     

    I stated that Joejoem might have isolated the issue, I just wanted to point out that, while turning off iCloud might help with isolating the cause, it's only a workaround and not a solution. If that obvious point is "hostile" then "The Kitchen will get hotter…"

     

    With all of your activism on ASC it's hard to believe that you're unaware of the Apple and Google’s Maps rift on iOS 6 and the issues surrounding that one particular betrayal of good faith by Google — which has logged many over the last 10 years. Obviously, Steve Jobs thought that there was a collaborative atmosphere when he made the mistake of putting Eric Schmidt on the Board. iPhone users were primary contributors to the Google Maps data set through their use. Introducing a competing phone may be annoying, but the "hostile" acquisition of key iOS features and denying access to turn-by-turn — which does work fairly well on Maps, BTW — allows me to make the "bad citizenship" charge.

     

    While I took the original statement of using Google Maps as an attempt at humor, your continued apologetic stance against the iPhone Maps application makes your participation "questionable," once again…

     

    Is it really unreasonable for me to assume that participating in the Apple Support Communities discussions is intended to be for the long term goal of improving Apple products?

  • Joejoem Level 1 Level 1 (15 points)

    I managed to fix the problem on my phone. I went in and erased all of my bookmarks, and recents on all of my devices in maps. Problem solved. works fine now. Write down any saved places you want to put back in. I had bookmarks from earlier ios when google was default maps. I suspect the google maps bookmarks from the old ios may have been the problem. I am still having an issue with geofence. My location reminders only seem to work when they feel like it. they work intermittently. not reliably. any suggestions?

  • Randall White Level 1 Level 1 (5 points)

    Thanks Joejoem!

     

    Looks like that may have worked. Yesterday I couldn't even put "burger" in without getting "No Results Found" today I can.

     

    That was quite a bug

     

    Looked all over for a method to export data — which should always be an option — but I had no luck. I might try reimporting with Time Machine backup to see if bug reappears.

     

    Enjoy

Previous 1 2 Next