10 Replies Latest reply: Jul 21, 2014 6:20 AM by badri1124
slferris Level 1 Level 1 (0 points)

When I try to disable IPv6 in Network Systems Preferences under Advanced, TCP/IP the only options I am presented with are "Automatic", "Manually", and "Link-local only".  Shouldn't there be an option "Off" also?  Is there some other way to turn off IPv6 in Mavericks?


iMac, OS X Mavericks (10.9.1), 40 Mbps Internet
  • Grant Lenahan Level 4 Level 4 (1,190 points)

    Why? What are you trying to accomplish?

     

    Grant

  • slferris Level 1 Level 1 (0 points)

    I'm having a problem with DNS server addresses in Network Preferences.  They won't "stick", meaning that they disappear when I reboot and I have to reenter them again.  I was told by somebody else that turning off IPv6 would solve the problem.

     

    Anyway, since I wrote, I have learned to turn off IPv6 using a unix command, viz.,

     

    networksetup -setv6off Ethernet

    However, it didn't help with the problem I'm having with DNS settings and, obviously, turning off IPv6 probably isn't a great long-term solution anyway.  Must be a bug that Apple needs to address.

  • Grant Lenahan Level 4 Level 4 (1,190 points)

    I'm not having that problem - it would appear that either you have a setting wrong or something is corrupted.

     

    When did this begin?

     

    Grant

  • Grant Lenahan Level 4 Level 4 (1,190 points)

    Why not copy the DNS addresses, and enter them manually as "additional" DNS addresses

     

    How do you have the machine configured? DHCP?  Manually?  Static address with DHCP?

     

    Grant

  • slferris Level 1 Level 1 (0 points)

    Problem began when I installed Mavericks.

     

    I'm not quite sure about your suggestion about copying DNS addresses manually as "additional" addresses.  That's exactly what I have to do each time I reboot, which is the problem.  The only address that will persist between reboots is a 127.0.. address.  I'm not sure where that comes from.  Assigned by the OS, I guess.  The others that I enter manually simply disappear when I reboot.

     

    The Configure IPv4 field in Network Preferences is set to "Using DHCP".  Do you think it would help to set it to a different option?

     

    Thanks for your responses.

  • Grant Lenahan Level 4 Level 4 (1,190 points)

    The problem appears to be some breakdown between your mac and the DNS server/DHCP server that gives you your IP address, your gateway and your DNS.

     

    If you go to network CP —> advanced —> DNS and click + you should be able to add addresses. This allows you to add addresses besides the automatically assigned ones - for example for a corporate LAN. Put the ISP ones in that way and see if it persists - this way they are not coming from the ISP.

     

    I would call the ISP. 10.6.8 has not changed in ages.

     

    Grant

  • Grant Lenahan Level 4 Level 4 (1,190 points)

    Whoa, Mavericks?  This is the snow leopard discussion. Sorry, but that caught me by surprise.

    Nonetheless, i have 10.9 on 3 machines and it works fine with various ISP and VPN configurations, DHCP or manual

     

    Grant

  • slferris Level 1 Level 1 (0 points)

    Sorry, I guess I haven't made myself clear and the heading for Snow Leopard was something I hadn't noticed.  The problem we're discussing is indeed a new problem for me with Mavericks. 

     

    Anyway.  I've done exactly what you last suggested - added DNS addresses the way you outlined.  Everything works fine until I reboot, then the DNS addresses simply disappear and I have to reenter them.

  • carpii Level 1 Level 1 (0 points)

    You can disable it on Mavericks using

     

    networksetup -setv6off wi-fi

    networksetup -setv6off ethernet

     

    At this point the 'Off' item will start appearing in the IPv6 drop down list, in network prefs (like it did in SL)

  • badri1124 Level 1 Level 1 (0 points)

    HI Carpil,

     

    to continue the same discussion i  found following things on my Mavericks,

    $ networksetup -listallnetworkservices

    An asterisk (*) denotes that a network service is disabled.

    Ethernet Adaptor (en3)

    Wi-Fi

    Bluetooth PAN

    Thunderbolt Bridge

    Ethernet Adaptor (en1)

    Bluetooth DUN

    $ networksetup -setv6off "Thunderbolt Bridge"

    $ networksetup -setv6off "Bluetooth DUN"

    $ networksetup -setv6off "Ethernet Adaptor (en1)"

    $ networksetup -setv6off "Ethernet Adaptor (en3)"

    $ networksetup -setv6off "Bluetooth PAN"

    $ networksetup -setv6off "WI-Fi"

    $ networksetup -listallnetworkservices

    An asterisk (*) denotes that a network service is disabled.

    Ethernet Adaptor (en3)

    Wi-Fi

    Bluetooth PAN

    Thunderbolt Bridge

    Ethernet Adaptor (en1)

    Bluetooth DUN

     

    why it is not switching it off

     

    and also i can see ipv6 address ::1 and fe80:1::1 being present

     

    and also when i run $ netstat -i ipv6 -gps

     

    Name  Mtu   Network       Address            Ipkts Ierrs    Opkts Oerrs  Coll

    lo0   16384 <Link#1>                          1155     0     1155     0     0

    lo0   16384 localhost   ::1                   1155     -     1155     -     -

    lo0   16384 127           localhost           1155     -     1155     -     -

    lo0   16384 nikhils-mac fe80:1::1             1155     -     1155     -     -

     

    so I Was curious how to disable it, and why this command not executing after i give admin user password.