Previous 1 2 3 4 Next 45 Replies Latest reply: Sep 19, 2014 12:42 AM by swoo007
alexandrefromfrance Level 1 Level 1

Hello,

 

My config is OSX 10.9.1 new macbook pro 13 retina (2014).

The wifi does not reconnect automatically when waking up from sleep mode since I have a Bluetooth apple magicmouse.

It was not the case before I bought the BT mouse.

Is this problem between Wifi and bluetooth coming from the OS?

Is there a fix already available or scheduled?

 

Thanks


MacBook Pro with Retina display, OS X Mavericks (10.9.1)
  • alexandrefromfrance Level 1 Level 1

    Hello again,

     

    Does anybody have this problem?

     

    Thanks

     

    Regards

     

    Alex

  • norm123 Community Specialists Community Specialists

    Hello alexandrefromfrance

     

    Check the Symptom: The network connection drops unexpectedly section for steps on what to do when your MacBook Pro does not connect after waking from sleep. I have also quoted the section on troubleshooting the issue as well.

     

    Wi-Fi: How to troubleshoot Wi-Fi connectivity

    http://support.apple.com/kb/HT4628

     

    Symptom: After restarting or waking from sleep, my computer might not connect to the Internet

    • After waking from sleep or starting up, your computer may not show that it is connected to a Wi-Fi network.
    • After start or wake, your computer may indicate that it is connected to a network, but does not connect to the Internet.

     

    Solution

    Use these steps if your computer does not automatically connect to your desired Wi-Fi network.

    1. Check your TCP/IP settings in the Network pane of the System Preferences. Click the "Renew DHCP lease" button
      1. Choose System Preferences from the Apple menu.
      2. Choose Network from the View menu.
      3. Select Wi-Fi, then click the Advanced button in the lower-left hand corner of the screen.
      4. Click the TCP/IP tab from the top of the screen.
      5. Click the "Renew DHCP lease" button.
    2. Select the Wi-Fi tab and view your Preferred Networks list.
      1. Select each network and click the minus sign to remove those networks from your Preferred Networks list.
      2. Click OK and close the Network preferences.
    3. Remove your stored network passwords using the Keychain Access Utility.
      1. Open Keychain Access from /Applications/Utilities. Your window will look like this:
      2. Remove your AirPort network passwords from the login keychain: Select the "login" keychain from the Keychain sidebar. Click the "Kind" column to order the list of keychain items by their type. Remove all entries of the kind: "AirPort network password".
      3. Remove your AirPort network passwords from the System keychain: Select the "System" keychain from the Keychain sidebar. Click the "Kind" column to order the list of keychain items by their type. Remove all entries of the kind: "AirPort network password".

Note: The above steps will remove your Wi-Fi network passwords. If you do not know them, or if your network does not use passwords to restrict access, you should contact your network administrator.
      4. Restart your computer.
      5. Join your Wi-Fi network. You will need to enter your password for your network again if it requires one.

     

    Regards,

    -Norm G.

  • Barry Hemphill Level 8 Level 8
    expertise.peripherals
    Peripherals

    This article may help:

     

    http://support.apple.com/kb/HT1365

     

    FYI, Bluetooth devices and routers frequently share the same frequency.

     

    Barry

  • alexandrefromfrance Level 1 Level 1

    Hello Norm G,

     

    Thank you. I did what you proposed but this did not solve the issue.

     

    I would like to know if other apple customer with MB pro retina + magicmouse have the issue.

    I find this is not normal for a so expensive computer + apple mouse!!!

     

    Thanks

  • MBPRUser Level 1 Level 1

    I am having the same issue with this. It has been going on for a while with my 2012 MacBook Pro 15 Retina. I am wondering now if it is an issue with the Magic Mouse but I cant remember if it was happening before I got the mouse. I am going to be doing some testing on this. So you are saying that this issue was not present before you got the mouse?

  • alexandrefromfrance Level 1 Level 1

    In my case, when I switch the bluetooh off, it works perfectly... (But I can not use the magic mouse...)

    Maybe try this to confirm the issue.

     

    That is why I say there is a problem beetween BT magicmouse and Wifi management after sleep mode.

    At first boot, everything works fine even with BT. The problem comes only when it comes back from sleep mode.

  • alexandrefromfrance Level 1 Level 1

    Hi everybody,

     

    I switched my wifi to 5GHZ and now it works.

    So in my opinion this is clearly a bug.

    At 2,4 GHZ there are problems with apple bluetooth magicmouse.

    At bootime everything works perfectly but it does not after wake up of the computer... No more automatic connection to WIFI.

    I strongly hope that Apple is doing something to fix it in their Mavericks OS.

     

    I do not want to keep my router in wifi dual mode. (2,4 GHZ + 5 GHZ)

     

    Hope this helps

  • thehuhman Level 1 Level 1

    Norm G, I did all of the steps you listed in:

     

    Wi-Fi: How to troubleshoot Wi-Fi connectivity

    http://support.apple.com/kb/HT4628

     

    Still does not help. I ran thru the steps again, just to make sure I didn't miss something. Stil does not work. And by the way, I am NOT using Bluetooth.  Any help would definitely be appreciated.

     

    Thanks,

    thehuhman

  • kencanuck Level 1 Level 1

    I am having the exact same problem. Mid 2013 Retina Display Macbook Pro 15". When Bluetooth is turned on, my Wifi will not automatically reconnect after waking from sleep. Tried the steps above which did not solve my problem. Unlike another person posting above, I have the problem with 5GHz mode.

     

    Only good thing is this thread helped me to discover that it's related to Bluetooth so I've now turned it off and my Wifi connect normally again. Lucky that I'm not using a Bluetooth mouse!

     

    Definitely a bug and hope it gets fixed!

  • Adrian G. Level 1 Level 1

    Ok I was having the same problem and I stumbled upon this thread for help and ended up figuring out my issue.

     

    1. Open Keychain Access from /Applications/Utilities.
    2. Copy your AirPort network password from the iCloud keychain to your Login keychain: I did this by click and drag (while holding the option/alt key) and dropping it in the Login Keychain

    Solution.png

  • Adrian G. Level 1 Level 1

    nevermind.........it still doesn't work.

  • João Nunes Level 1 Level 1

    Any news on this?

     

    I have the same problem on my macbook pro retina 13" late 2013 . 10.9.2 Mavericks

     

    I kept the BT on, but I will try to turn it off to see if it helps!

     

    My problem:

     

    When the computer awakes from sleep it doesnt reconnect to my wifi and sometimes it doesn't show any other networks, sometimes it shows random networks other times it shows them all. In any case it doesnt reconnect!

    I have to turn off/on the wifi or just press my wifi if it was listed there.

  • Ricc83 Level 1 Level 1

    I do have the same issue and i think it still is open with an apple employee. i will write him and email and forward on this thread.

     

    Though its surprising why not many people report this issue. Problem is also you dont always have 5ghz networks.

  • klemensz Level 1 Level 1

    Same problem here with MacBook 15" 2013. Nothing has helped so far... The problem exists only with some networks, not with all. With an older MackBook 13" there are no issues.

Previous 1 2 3 4 Next