9 Replies Latest reply: Feb 4, 2014 1:19 PM by Linc Davis
faraz614 Level 1 Level 1 (0 points)

I am using a mac book pro with latest OSX Maverick 10.9.1. In last 2 weeks my internet has slowed down to almost being non-exsistent. i checked my ping rate and it is currently 1536m. i am using a 9.3mbs internet connection and getting a download speed of 2.2mbs and upload of .56. Please help me!


MacBook Pro, OS X Mavericks (10.9.1)
  • 2. Re: my internet speed has slowed and ping rate increased substantially. I am using a wireless connection. what do i do?
    GlennPJ Level 1 Level 1 (0 points)

    I have run into a similar problem recently.  I am using speedtest.net to check my ping/download/upload speeds.  I noticed that the other apps didn't seem to be suffering from poor download speeds, yet speedtest showed I was getting about 1.5Mb/s upload and 350ms ping.  I tested my macbooks - download speed 20Mb/s+, iPads - download speed 20Mb/s+, iPhonse - 1.5Mb/s.

     

    Someone posted on another thread about which server was being used.  For some reason here in Austin, MacBook speedtest picks DoubleHorn, iPad picks DoubleHorn, and iPhone picks Grande.   Guess what happened when I chose DoubleHorn as the server for speedtest on the iPhone - 20Mb/s download, 46ms ping.

     

    Not sure why iPhone defaults to Grande Communications, but it's sloooowwww right now.

     

    Maybe this is the cause of your findings?

  • 3. Re: my internet speed has slowed and ping rate increased substantially. I am using a wireless connection. what do i do?
    Linc Davis Level 10 Level 10 (118,475 points)

    Please answer as many of the following questions as you can. You may already have answered some of them; in that case, there's no need to repeat the answers.

     

    • Restart your router and your broadband device, if they're separate. Any change?
    • Run Software Update and install all available updates for OS X or your computer's firmware. Any change?
    • If possible, connect to your router with an Ethernet cable and turn off Wi-Fi. Any difference?
    • Are any other devices on the network, and if so, are they the same?
    • If you can connect to more than one network, are they all the same?
    • Are all network applications affected, or only some? If only some, which ones?
    • Is networking always the same, or is the problem intermittent?
    • Disconnect all other devices from the network. Any change?
    • Boot in safe mode and test. Any difference?
    • Boot into Recovery mode. From the OS X Utilities screen, select Get Help Online. A clean copy of Safari will launch. No plugins, such as Flash, will be available. Any difference?
    • If possible, turn off Bluetooth and disconnect any USB 3 devices. Any difference?
  • 4. Re: my internet speed has slowed and ping rate increased substantially. I am using a wireless connection. what do i do?
    faraz614 Level 1 Level 1 (0 points)

    Thank you for your response @linc davis. I will try to answer all the questions to the best of my knowldge but i appologize in the start for i am not very good with technology.

     

    • I restarted my device (its seprate) and no change.
    • My software is currently upto date.
    • I turned off the wifi and tried it thorugh the ethernet cable, no change.
    • no other device on the network.
    • Networking has always been the same. there has been no hardware change since last 3 months ( and things were working fine few weeks ago)
    • I restarted in safe mode, and it worked. the speed was back up
    • I dont know how to boot in recovery ( Sorry for that)
    • i turned off the bluetooth and disconnected all other usb devices, No chnage.
  • 5. Re: my internet speed has slowed and ping rate increased substantially. I am using a wireless connection. what do i do?
    Linc Davis Level 10 Level 10 (118,475 points)
    1. This procedure is a diagnostic test. It changes nothing, for better or worse, and therefore will not, in itself, solve your problem.
        
    2. If you don't already have a current backup, back up all data before doing anything else. The backup is necessary on general principle, not because of anything in the test procedure. There are ways to back up a computer that isn't fully functional. Ask if you need guidance.
       
    3. Below are instructions to run a UNIX shell script, a type of program. All it does is to gather information about the state of your computer. That information goes nowhere unless you choose to share it on this page. However, you should be cautious about running any kind of program (not just a shell script) at the request of a stranger on a public message board. If you have doubts, search this site for other discussions in which this procedure has been followed without any report of ill effects. If you can't satisfy yourself that the instructions are safe, don't follow them.

    Here's a summary of what you need to do: Copy a line of text from this web page into the window of another application. Wait for the script to run. It usually takes a couple of minutes. Then paste the results, which will have been copied automatically, back into a reply on this page. The sequence is: copy, paste, wait, paste again. Details follow.

    4. You may have started the computer in "safe" mode. Preferably, these steps should be taken in “normal” mode. If the system is now in safe mode and works well enough in normal mode to run the test, restart as usual. If you can only test in safe mode, do that.

    5. If you have more than one user, and the one affected by the problem is not an administrator, then please run the test twice: once while logged in as the affected user, and once as an administrator. The results may be different. The user that is created automatically on a new computer when you start it for the first time is an administrator. If you can't log in as an administrator, test as the affected user. Most personal Macs have only one user, and in that case this section doesn’t apply.

    6. The script is a single long line, all of which must be selected. You can accomplish this easily by triple-clicking  anywhere in the line. The whole line will highlight, though you may not see all of it in your browser, and you can then copy it. If you try to select the line by dragging across the part you can see, you won't get all of it.

    Triple-click anywhere in the line of text below on this page to select it:

    PATH=/usr/bin:/bin:/usr/sbin:/sbin; clear; Fb='%s\n\t(%s)\n'; Fm='\n%s:\n\n%s\n'; Fr='\nRAM details:\n%s\n'; Fs='\n%s: %s\n'; Fu='user %s%%, system %s%%'; PB="/usr/libexec/PlistBuddy -c Print"; A () { [[ a -eq 0 ]]; }; M () { find -L "$d" -type f | while read f; do file -b "$f" | egrep -q XML\|exec && echo $f; done; }; Pc () { o=`grep -v '^ *#' "$2"`; Pm "$1"; }; Pm () { [[ "$o" ]] && o=`sed '/^ *$/d; s/^ */   /' <<< "$o"` && printf "$Fm" "$1" "$o"; }; Pp () { o=`$PB "$2" | awk -F'= ' \/$3'/{print $2}'`; Pm "$1"; }; Ps () { o=`echo $o`; [[ ! "$o" =~ ^0?$ ]] && printf "$Fs" "$1" "$o"; }; R () { o=; [[ r -eq 0 ]]; }; SP () { system_profiler SP${1}DataType; }; id | grep -qw '80(admin)'; a=$?; A && sudo true; r=$?; t=`date +%s`; clear; { A || echo $'No admin access\n'; A && ! R && echo $'No root access\n'; SP Software | sed '8!d;s/^ *//'; o=`SP Hardware | awk '/Mem/{print $2}'`; o=$((o<4?o:0)); Ps "Total RAM (GB)"; o=`SP Memory | sed '1,5d; /[my].*:/d'`; [[ "$o" =~ s:\ [^O]|x([^08]||0[^2]8[^0]) ]] && printf "$Fr" "$o"; o=`SP Diagnostics | sed '5,6!d'`; [[ "$o" =~ Pass ]] || Pm "POST"; o=`SP USB | sed -n '1d; /:$/{s/ *:$//;x;s/\n//p;}; /V.*[(]/{s/^[^(]*/ /;H;}; /Apple/{s/.//g;h;}'`; Pm "USB"; o=`pmset -g therm | sed 's/^.*C/C/'`; [[ "$o" =~ No\ th|pms ]] && o=; Pm "Thermal conditions"; o=`pmset -g sysload | grep -v :`; [[ "$o" =~ =\ [^GO] ]] || o=; Pm "System load advisory"; o=`nvram boot-args | awk '{$1=""; print}'`; Ps "boot-args"; d=(/ ""); D=(System User); for i in 0 1; do o=`cd ${d[$i]}L*/L*/Dia* && ls | awk -F_ '!/ag$/{$NF=a[split($NF,a,".")]; print}' | tail`; Pm "${D[$i]} diagnostics"; done; o=`syslog -F bsd -k Sender kernel -k Message CReq 'GPU |hfs: Ru|I/O e|n Cause: -|NVDA\(|pagin|SATA W|ssert|timed? ?o' | tail -n25 | awk '/:/{$4=""; $5=""};1'`; Pm "Kernel messages"; o=`df -m / | awk 'NR==2 {print $4}'`; o=$((o<5120?o:0)); Ps "Free space (MiB)"; o=$(($(vm_stat | awk '/eo/{sub("\\.",""); print $2}')/256)); o=$((o>=1024?o:0)); Ps "Pageouts (MiB)"; s=( `sar -u 1 10 | sed '$!d'` ); [[ s[4] -lt 85 ]] && o=`printf "$Fu" ${s[1]} ${s[3]}` || o=; Ps "Total CPU usage" && { s=(`ps acrx -o comm,ruid,%cpu | sed '2!d'`); o=${s[2]}%; Ps "CPU usage by process \"$s\" with UID ${s[1]}"; }; s=(`top -R -l1 -n1 -o prt -stats command,uid,prt | sed '$!d'`); s[2]=${s[2]%[+-]}; o=$((s[2]>=25000?s[2]:0)); Ps "Mach ports used by process \"$s\" with UID ${s[1]}"; o=`kextstat -kl | grep -v com\\.apple | cut -c53- | cut -d\< -f1`; Pm "Loaded extrinsic kernel extensions"; R && o=`sudo launchctl list | sed 1d | awk '!/0x|com\.(apple|openssh|vix\.cron)|org\.(amav|apac|calendarse|cups|dove|isc|ntp|post[fg]|x)/{print $3}'`; Pm "Extrinsic system jobs"; o=`launchctl list | sed 1d | awk '!/0x|com\.apple|org\.(x|openbsd)|\.[0-9]+$/{print $3}'`; Pm "Extrinsic agents"; o=`for d in {/,}L*/Lau*; do M; done | grep -v com\.apple\.CSConfig | while read f; do ID=$($PB\ :Label "$f") || ID="No job label"; printf "$Fb" "$f" "$ID"; done`; Pm "launchd items"; o=`for d in /{S*/,}L*/Star*; do M; done`; Pm "Startup items"; o=`find -L /S*/L*/E* {/,}L*/{A*d,Compon,Ex,In,Keyb,Mail/B,P*P,Qu*T,Scripti,Servi,Spo}* -type d -name Contents -prune | while read d; do ID=$($PB\ :CFBundleIdentifier "$d/Info.plist") || ID="No bundle ID"; [[ "$ID" =~ ^com\.apple\.[^x]|Accusys|ArcMSR|ATTO|HDPro|HighPoint|driver\.stex|hp-fax|\.hpio|JMicron|microsoft\.MDI|print|SoftRAID ]] || printf "$Fb" "${d%/Contents}" "$ID"; done`; Pm "Extrinsic loadable bundles"; o=`find -L /u*/{,*/}lib -type f | while read f; do file -b "$f" | grep -qw shared && ! codesign -v "$f" && echo $f; done`; Pm "Unsigned shared libraries"; o=`launchctl getenv DYLD_INSERT_LIBRARIES`; Pm "Inserted libraries"; o=`find -L {,/u*/lo*}/e*/periodic -type f -mtime -10d`; Pm "Modified periodic scripts"; o=`scutil --proxy | grep Prox`; Pm "Proxies"; o=`scutil --dns | awk '/r\[0\] /{if ($NF !~ /^1(0|72\.(1[6-9]|2[0-9]|3[0-1])|92\.168)\./) print $NF; exit}'`; Ps "DNS"; R && o=`sudo profiles -P | grep : | wc -l`; Ps "Profiles"; f=auto_master; [[ `md5 -q /etc/$f` =~ ^b166 ]] || Pc $f /etc/$f; for f in fstab sysctl.conf crontab launchd.conf; do Pc $f /etc/$f; done; Pc "hosts" <(grep -v 'host *$' /etc/hosts); Pc "User launchd" ~/.launchd*; R && Pc "Root crontab" <(sudo crontab -l); Pc "User crontab" <(crontab -l); R && o=`sudo defaults read com.apple.loginwindow LoginHook`; Pm "Login hook"; Pp "Global login items" /L*/P*/loginw* Path; Pp "User login items" L*/P*/*loginit* Name; Pp "Safari extensions" L*/Saf*/*/E*.plist Bundle | sed 's/\..*$//;s/-[1-9]$//'; o=`find ~ $TMPDIR.. \( -flags +sappnd,schg,uappnd,uchg -o ! -user $UID -o ! -perm -600 \) | wc -l`; Ps "Restricted user files"; cd; o=`SP Fonts | egrep "Valid: N|Duplicate: Y" | wc -l`; Ps "Font problems"; o=`find L*/{Con,Pref}* -type f ! -size 0 -name *.plist | while read f; do plutil -s "$f" >&- || echo $f; done`; Pm "Bad plists"; d=(Desktop L*/Keyc*); n=(20 7); for i in 0 1; do o=`find "${d[$i]}" -type f -maxdepth 1 | wc -l`; o=$((o<=n[$i]?0:o)); Ps "${d[$i]##*/} file count"; done; o=$((`date +%s`-t)); Ps "Elapsed time (s)"; } 2>/dev/null | pbcopy; exit 2>&-
       
    Copy the selected text to the Clipboard by pressing the key combination command-C.

    7. Launch the built-in Terminal application in any of the following ways:

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

    ☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

    When you launch Terminal, a text window will open with a line already in it, ending either in a dollar sign ($) or a percent sign (%). If you get the percent sign, enter

    exec sh

    in the window and press return. You should then get a new line ending in a dollar sign.

    Click anywhere in the Terminal window and paste (command-V). The text you pasted should vanish immediately. If it doesn't, press the return key.

     

    If you're logged in as an administrator, you'll be prompted for your login password. Nothing will be displayed when you type it. You will not see the usual dots in place of typed characters. Make sure caps lock is off. Type carefully and then press return. You may get a one-time warning to be careful. If you make three failed attempts to enter the password, the test will run anyway, but it will produce less information. In most cases, the difference is not important. If you don't know your password, or if you prefer not to enter it, just press return three times at the password prompt.

    If you're not logged in as an administrator, you won't be prompted for a password. The test will still run. It just won't do anything that takes administrator privileges.

    The test may take up to a few minutes to run, depending on how many files you have and the speed of the computer. A computer that's abnormally slow may take longer to run the test. While it's running, there will be nothing in the Terminal window and no indication of progress. Wait for the line "[Process completed]" to appear. If you don't see it within half an hour or so, the test probably won't complete in a reasonable time. In that case, close the Terminal window and report your results. No harm will be done.

    8. When the test is complete, quit Terminal. The results will have been copied to the Clipboard automatically. They are not shown in the Terminal window. Please don't copy anything from there. All you have to do is start a reply to this comment and then paste by pressing command-V again.

    If any private information, such as your name or email address, appears in the results, anonymize it before posting. Usually that won't be necessary.

    When you post the results, you might see the message, "You have included content in your post that is not permitted." It means that the forum software has misidentified something in the post as a violation of the rules. If it happens, please post the test results on Pastebin, then post a link here to the page you created.

    Note: This is a public forum, and others may give you advice based on the results of the test. They speak only for themselves, and I don't necessarily agree with them.

     

    ________________________________

      
    Copyright © 2014 Linc Davis. As the sole author of this work, I reserve all rights to it except as provided in the Terms of Use of Apple Support Communities ("ASC"). Readers of ASC may copy it for their own personal use. Neither the whole nor any part may be redistributed.
  • 6. Re: my internet speed has slowed and ping rate increased substantially. I am using a wireless connection. what do i do?
    Baby Boomer (USofA) Level 9 Level 9 (55,575 points)

    I dont know how to boot in recovery ( Sorry for that)

    No need to apologize.  CLICKY CLICK---> http://support.apple.com/kb/HT4718 and do the necessary.

     

    =================

     

    If you are still having problems after the recovery, check out the following:

    Try the basics first:

       Change your router channel number.  Most times this works & is all you have to do.

     

    Disconnect & reconnect your modem.  unplug it for about 10 seconds.  Plug it back in.  Do the same for Apple’s routers.  Wait for everything to reboot.

     

    System Preferences>Network

    Click the Assist Me button.

    In the next window that pops up, click the Diagnostic button & do the necessary.

     

    Research Knowledge Base for network problems that pertain to the OS that is currently installed on your computer.   See these basic networking KB Articles:  http://support.apple.com/kb/HT1401 AirPort troubleshooting guide

     

    http://support.apple.com/kb/HT4628  Wi-Fi: How to troubleshoot Wi-Fi connectivity

     

    http://support.apple.com/kb/HT2712 Using network locations in Mac OS X

     

    Manually provided DNS server addresses are higher priority than DHCP's

     

    http://support.apple.com/kb/HT1714 Solutions for connecting to the Internet, setting up a small network, and troubleshooting

     

    ============================

     

    What to do when you can't connect to the Internet

     

    Also, run the Airport Utility app which is located inside the Utilities folder.

     

    =====================

     

    If using a  Linksys router, contact LinkSys Customer Support and/or post in their forums.

     

    If using Apple's Airport, please re-post over in one of the AirPort Forums.

  • 7. Re: my internet speed has slowed and ping rate increased substantially. I am using a wireless connection. what do i do?
    faraz614 Level 1 Level 1 (0 points)

    i followed your instructions. once the terminal said the process is completed i closed it. But i cant seem to find the clipboard. what do i do?

  • 8. Re: my internet speed has slowed and ping rate increased substantially. I am using a wireless connection. what do i do?
    faraz614 Level 1 Level 1 (0 points)

    here is the data:

     

    Boot Mode: Normal

     

    USB:

     

       Hub (SMSC)

       HUAWEI Mobile (Huawei Technologies Co., Ltd.)

       Hub (SMSC)

     

    System diagnostics:

     

    CVMServer,diskarbitrationd,launchd,locationd,mbbservice,ubd 2014-02-03-013143 shutdownStall

       af proxy,af proxy,af proxy,af proxy,af proxy,af proxy,diskarbitr 2014-01-22-223723 shutdownStall

       af proxy,af proxy,af proxy,diskarbitrationd,mbbservice 2014-02-01-072536 shutdownStall

       af proxy,diskarbitrationd,mbbservice 2014-01-10-010108 shutdownStall

       af proxy 2014-01-29-163423 crash

    coresymbolicatio,CVMCompiler,CVMServer,diskarbitrationd,diskimag 2014-01-08-123617 shutdownStall

     

    User diagnostics:

     

       AdobeReader 2014-01-24-223325 crash

       VLC 2014-01-20-005630 crash

       VLC 2014-01-28-024913 crash

       VLC 2014-01-28-235917 crash

       VLC 2014-01-31-235038 crash

     

    Kernel messages:

     

       Jan 30 13:06:19 MacAuthEvent en1 Auth result for: a0:f3:c1:49:e7:cc Auth timed out

       --- last message repeated 2 times ---

       Jan 30 19:29:00 MacAuthEvent en1 Auth result for: 34:6b:d3:41:13:64 Auth timed out

       --- last message repeated 9 times ---

       Feb 3 00:31:17   Previous Shutdown Cause: -60

       --- last message repeated 1 time ---

       Feb 3 01:47:15   Previous Shutdown Cause: -60

     

    Loaded extrinsic kernel extensions:

     

       com.astrill.macproxy.kext (2.0.8)

     

    Extrinsic system jobs:

     

    com.microsoft.office.licensing.helper

       com.anchorfree.ajaxserver

     

    Extrinsic agents:

     

       com.divx.update.agent

       com.divx.dms.agent

       com.google.keystone.user.agent

       com.adobe.ARM.202f4087f2bbde52e3ac2df389f53a4f123223c9cc56a8fd83a6f7ae

     

    launchd items:

     

    /Library/LaunchAgents/com.divx.dms.agent.plist

        (com.divx.dms.agent)

    /Library/LaunchAgents/com.divx.update.agent.plist

        (com.divx.update.agent)

       /Library/LaunchDaemons/com.anchorfree.ajaxserver.plist

        (com.anchorfree.ajaxserver)

    /Library/LaunchDaemons/com.microsoft.office.licensing.helper.plist

    (com.microsoft.office.licensing.helper)

    Library/LaunchAgents/com.adobe.ARM.202f4087f2bbde52e3ac2df389f53a4f123223c9cc56 a8fd83a6f7ae.plist

    (com.adobe.ARM.202f4087f2bbde52e3ac2df389f53a4f123223c9cc56a8fd83a6f7ae)

    Library/LaunchAgents/com.google.keystone.agent.plist

        (com.google.keystone.user.agent)

     

    Startup items:

     

       /Library/StartupItems/MobileBrServ/mbbservice

    /Library/StartupItems/MobileBrServ/mbbserviceopen.app/Contents/Info.plist

    /Library/StartupItems/MobileBrServ/mbbserviceopen.app/Contents/MacOS/mbbservice open

    /Library/StartupItems/MobileBrServ/mbbserviceopen.app/Contents/Resources/Englis h.lproj/main.nib/objects.xib

    /Library/StartupItems/MobileBrServ/MobileBrServ

    /Library/StartupItems/MobileBrServ/runmbbserviceopen

    /Library/StartupItems/MobileBrServ/Uninstall.app/Contents/Info.plist

       /Library/StartupItems/MobileBrServ/Uninstall.app/Contents/MacOS/applet

     

    Extrinsic loadable bundles:

     

       /Library/Internet Plug-Ins/AdobePDFViewer.plugin

        (com.adobe.acrobat.pdfviewer)

       /Library/Internet Plug-Ins/AdobePDFViewerNPAPI.plugin

    (com.adobe.acrobat.pdfviewerNPAPI)

       /Library/Internet Plug-Ins/DivX Web Player.plugin

        (com.divx.DivXWebPlayer)

       /Library/Internet Plug-Ins/OVSHelper.plugin

        (com.divx.OVSHelper)

       /Library/Internet Plug-Ins/SharePointBrowserPlugin.plugin

    (com.microsoft.sharepoint.browserplugin)

       /Library/Internet Plug-Ins/SharePointWebKitPlugin.webplugin

    (com.microsoft.sharepoint.webkitplugin)

       /Library/QuickTime/DivX Decoder.component

        (com.DivXInc.DivXDecoder)

       /Library/QuickTime/DivX Encoder.component

        (com.DivXInc.DivXCodec)

       Library/Address Book Plug-Ins/SkypeABDialer.bundle

        (com.skype.skypeabdialer)

       Library/Address Book Plug-Ins/SkypeABSMS.bundle

        (com.skype.skypeabsms)

       Library/Internet Plug-Ins/ConduitNPAPIPlugin.plugin

        (com.conduit.ConduitNPAPIPlugin)

     

    Unsigned shared libraries:

     

       /usr/lib/libtcl.dylib

       /usr/lib/libtcl8.5.dylib

       /usr/lib/libtk.dylib

       /usr/lib/libtk8.5.dylib

     

    User login items:

     

       iTunesHelper

       uTorrent

       Remote Mouse

       AdobeResourceSynchronizer

     

    Restricted user files: 524

     

    Font problems: 21

     

    Elapsed time (s): 259

  • 9. Re: my internet speed has slowed and ping rate increased substantially. I am using a wireless connection. what do i do?
    Linc Davis Level 10 Level 10 (118,475 points)

    Start by removing "Astrill VPN" and "HotSpot Shield." If there's no improvement, also remove "Mobile BroadBand" (which may disable the USB modem.)

    Any third-party software that doesn't install by drag-and-drop into the Applications folder, and uninstall by drag-and-drop to the Trash, is a system modification.

    Whenever you remove system modifications, they must be removed completely, and the only way to do that is to use the uninstallation tool, if any, provided by the developers, or to follow their instructions. If the software has been incompletely removed, you may have to re-download or even reinstall it in order to finish the job.

    I never install system modifications myself, and I don't know how to uninstall them. You'll have to do your own research to find that information.

    Here are some general guidelines to get you started. Suppose you want to remove something called “BrickMyMac” (a hypothetical example.) First, consult the product's Help menu, if there is one, for instructions. Finding none there, look on the developer's website, say www.brickmymac.com. (That may not be the actual name of the site; if necessary, search the Web for the product name.) If you don’t find anything on the website or in your search, contact the developer. While you're waiting for a response, download BrickMyMac.dmg and open it. There may be an application in there such as “Uninstall BrickMyMac.” If not, open “BrickMyMac.pkg” and look for an Uninstall button.

    Back up all data before making any changes.

    You will generally have to reboot in order to complete an uninstallation. Until you do that, the uninstallation may have no effect, or unpredictable effects.

    If you can’t remove software in any other way, you’ll have to erase and install OS X. Never install any third-party software unless you're sure you know how to uninstall it; otherwise you may create problems that are very hard to solve.

    WARNING: Trying to remove complex system modifications by hunting for files by name often will not work and may make the problem worse. The same goes for "utilities" such as "AppCleaner" and the like that purport to remove software.