4 Replies Latest reply: Feb 12, 2014 7:13 PM by MagesGuild
MagesGuild Level 1 (0 points)

After doing a server restore, the Netboot pane in Server Admin (on 10.5.8) no longer displays *any* checkboxes, either for ports, or for locations.


What config files can Imodify to repair this?


Some config file must be corrupt, and if I knew what to change, I could fix it, but I cannot find this problem elsewhere.


Ethernet is working everywhere else, so it isn't that.

My Other 10.5 server displays Eth0, Eth1, and FireWire.

Xserve, Mac OS X (10.5.8)
  • Brian Nesse Level 4 (2,925 points)

    The service data for NetBoot is stored in /etc/bootpd.plist. But NetBoot scans for active interfaces to populate those lists.


    I'd try deleting, and recreating, the interfaces in System Preferences -> Network.

  • MagesGuild Level 1 (0 points)

    That was one of the first things that I tried to do. I tried it again today, just to be certain, and all it did was entirely frag my network.


    I have tried three different boot volumes, removed the PCI-X FC card (as apple sayd 'Do Not Use' for Intel XServes: I'm not sure why), tried installing Server Admin v10.5.7 (individual download), which only caused SA to crash constantly, re-applied the 10.5.8 v1.1 update, that seemingly fragged other prefs, and now am re-cloning the main boot volume from the backup I made prior to messing with it today, as I can now no longer even load localhost. :/


    Thank goodness for routine system imaging.


    **None of this did anything.**


    My PPC G5 XServe Netboot works, but the Netboot optipons on the 2008 Intel are still MIA.


    I also tried to rempte view the server via SA on the G5, and the ports aren't visible from there either.


    I ran a drive with a much older backup, from when I am certain that NetBoot was working. I zapped the Pram six more times, and I'm at a loss here to explain the cause. I thought it could have been due to instal;ling the PCI-X FC card, but that doesn't seem to be true. For the record, I think that the FC card (PCI-X version) *was* working, although I can't prove that, and I don't know why Apple says not to use it on Intel models with a PCI-X slot.


    No install that I have, current or backup, will shpw any ports or discs for Netboot, at all. My last resort wi;ll be to try a cleanm install on anopther volume, after I finish restoring this disc image, and see if that shpws the ports. If a clean install does not show ports for NB, than I am totally lost on what else I could do, as it will have to be some kind of bizarre HW problem.


    I will have to verify if I have any FW devices plugged into the system. I believe I unplugged them, but I've done so much on this one problem that it's making my head spin.

  • Brian Nesse Level 4 (2,925 points)

    From what I can tell, the Intel Xserve's have PCI-Express, not PCI-X, risers (not an expert, just reading.)




  • MagesGuild Level 1 (0 points)

    The 2008 XServe has two risers. One is, by default, PCIe, and the other is by default, PCI-X. You can change the PCI-X riser to a PCIe riser---this was a build option---easily enough.