2 Replies Latest reply: Jul 3, 2014 4:02 PM by unsubscriber
anthonyfrombakersfield Level 1 Level 1 (0 points)

I keep getting this problem, can't connect to the internet because self assigned ip address. help!


MacBook Pro (15-inch Mid 2010), OS X Mavericks (10.9.1)
  • sheila_m. Community Specialists Community Specialists (3,280 points)

    Hello Anthony,

     

    Thank you for the details of the issue you are experiencing with your MacBook Pro.  I recommend the following steps when getting a self-assigned IP address:

     

    Resolution

    • Make sure your Your Mac, iOS device, or Apple TV is properly connected to your home Wi-Fi network (or via Ethernet if your Mac or Apple TV uses an Ethernet cable).
    • Make sure your router (such as an AirPort base station in default configuration) is working properly and is assigning IP addresses to your devices via DHCP.  See this article for details.
    • If your ISP is assigning your Internet facing router, Mac, or iOS device an IP address of 169.254.xxx.xxx, contact the ISP support staff and ask for a proper IP address to access the Internet.
    • If the DHCP server has been configured to issue an IP address of 169.254.xxx.xxx, contact the administrator of the DHCP server and ask that they issue a proper IP address to access the Internet, such as what is issued by an AirPort base station in default configuration (10.0.1.25 or similar). A DHCP server should not be issuing an IP address of 169.254.xxx.xxx.
    • If you have manually configured your Mac or device with an IP address of 169.254.xxx.xxx, reconfigure your device to use a proper IP address to access the Internet.

     

    Internet connection does not work with an IP address space of 169.254.xxx.xxx from ISP, router, or manual configuration

    http://support.apple.com/kb/TS3798

     

    If you are still not able to access the Internet after following those steps, I recommend the following articles:

     

    Wi-Fi: How to troubleshoot Wi-Fi connectivity

    http://support.apple.com/kb/HT4628

     

    Mac OS X: Troubleshooting a cable modem, DSL, or LAN Internet connection

    http://support.apple.com/kb/ts1317

     

    Thank you for using Apple Support Communities.

     

    Best,

    Sheila M.

  • unsubscriber Level 1 Level 1 (0 points)

    OK, so I hit this problem yesterday and I thought it was just one friend's mac. This morning I found that several macs were having the same problem on wifi. (Ethernet was OK, but not wifi.) I have SOLVED it for me - so here's the info in case it helps!

     

    NB - I have tried most of the solutions on most of the help threads. (Once, years ago, I had the same problem, and one of the fixes I found back then did work. I think it was either deleting the  wifi setting from Network Preferences or fixing the keychain or both. But this time, those fixes were achieving nothing.)

     

    Anyway, the solution was simple! My modem-router included a setting for its DHCP server that was limited to 20 addresses. In other words, it was offering addresses from 192.168.1.1 to 192.168.1.20.  At first I dismissed that possibility, since you'd think 20 would be plenty for one house! However, I was very wrong. Here's why.

     

    1. Yes, we do own several Macs, and some of these are connected by ethernet AND wifi, so those ones use two addresses each.

    2. Yes, we own several iPhones, iPods, an AppleTV etc.

    3. Yes, we had visitors in the house. My daughter's friend had brought her iPad; my parents had brought their laptops and their phones!

    4. I have an Airport Extreme and a Time Capsule, both connected (in Bridge Mode) to the modem-router, so that's two more addresses.

    5. Remember that DHCP leases last for 24 hours (or whatever your router is set to), so even when visitors are gone or machines are turned off, those addresses might not become free.

     

    SOLUTION? I changed the router's setting to offer all addresses up to 192.168.1.40. (I might even go back and offer even more than 40 - no reason why not).

     

    My wifi macs had no trouble from that point. Hope this helps!

     

    [NB - The reason my ethernet was always OK was that those connections had been running a long time. But if an Ethernet connection had gone down, and I had reconnected it at a time when its address had been stolen by another device, then I likely would have hit the same "self-assigned IP" error. In other words, in my case I don't believe the issue made any real distinction between wireless and wired connections.]