Previous 1 2 Next 18 Replies Latest reply: Feb 24, 2014 7:39 AM by Lao Bo
Lao Bo Level 1 (0 points)

Hello everybody !  I am in trouble and would greatly appreciate any help !   I am a Swiss guy living in a small town of southwest China, thousands of miles away from the nearest Genius Bar… 


With my Macbook Pro plugged in, I was downloading an updated version of Skype while doing some routine task at the same time (probably email) and the whole system froze. Keyboard dead. I waited for a while, disconnected ethernet and did a hard shutdown with the power button. Waited a couple of minutes and restarted. Since then…


The Mac powers up but booting freezes half-way !   First chimes OK, startup screen appears with Apple logo and progress indicator spinning for about 1.5 minutes. Then stops spinning.  Waiting a long time brings no change.  Only way out is a hard shutdown again.


I looked in my OS X book and in Apple support group discussions, then tried a few things (with the Mac plugged in; FileVault is not enabled) :


- Safe mode boot : also gets stuck the same way

- Booting with the original OS X install DVD (10.6.3, about 2.5 year older than the OS X 10.8 version that I am using on the Mac) --> gives me the same startup screen with Apple logo and spinning indicator but, after a while both disappear, leaving an empty screen while the DVD is still making noises.  After another while, DVD stops running. That's it.

- Console mode :  boots OK, then did a check disk while in console mode, --> "HD appears OK" !   But when I type "reboot" to exit console mode and boot with OS X, it goes through exactly the same problem as above: chimes, indicator spinning then freezes.

- Verbose mode boot: everything goes well for a while, then it gets stuck at : "SMC::smcReadKeyAction ERROR : smcReadDATA8 failed for key MOTP (kSMCKeyNotFound)"

- NVRAM reset ( Command (⌘), Option, P, and R at startup) : the second chimes comes alright but then booting gets stuck like all other attempts.

- Apple Hardware Test with the original Apple DVD : the test boots OK; I did both short and extended memory tests : both cases report one error with code 4SNS/1/40000001:TN1D--18.000

- Since some of these tests were made on day two, I suppose that SMC was reset, but that did not change anything.


This Mac is my workhorse...    Many, many THANKS for trying to help !


Lao Bo  (that's my Chinese name  :-)

MacBook Pro, OS X Mountain Lion (10.8.5), 4 GB memory, HD plenty free space
  • Melophage Level 5 (7,140 points)

    Lao Bo,


    that Apple Hardware Test error code is pointing to a problem with a temperature sensor on the northbridge of your logic board. I don’t know which options are available to you in the part of the planet where you’re living, but your logic board should be investigated more thoroughly.

  • Lao Bo Level 1 (0 points)

    Thank you Melophage !   I  appreciate your concern and help.


    Short of traveling to Beijing, do you have any idea how to investigate further ?

    Or confirm that it is indeed a logic board problem ?


    By the way, in the meanwhile I did a correct SMC reset [Ctrl + Opt + Shift] -->  identical problem, with identical error message in verbose mode.


    I also noted two possibly relevant lines on verbose listing, above the SMCKey error message :

    "BootCacheControl : Unable to open/db/BootCaches/PreheatedUser/Merged.playlist: 2 No such file or directory"   And :

    "SMC::InitHelper ERROR : MMIO regMap == NULL - fall back to old SMC mode"


    Does that ring any bell ?


    Cheers !

    :-))    Lao Bo

  • Melophage Level 5 (7,140 points)

    Lao Bo,


    to my knowledge, only Apple has the more detailed diagnostic tests that would allow further investigation of the temperature sensor problem that the Apple Hardware Test reported. If the nearest Apple store to you is in Beijing, then I can only recommend making an appointment at that Apple store the next time that you travel to Beijing. Unfortunately, neither of those two lines from the verbose listing rings any bell for me.

  • Lao Bo Level 1 (0 points)

    Further help needed !  


    Is it possible to locate and copy a file from my HD to a USB key (for instance), using UNIX commands while in Console Mode ?!    That could save me lots of headache !...      Very grateful for tips !!      :-)


    Lao Bo

  • Lao Bo Level 1 (0 points)

    Thank you Melophage !     Looks like I am stuck... 


    Before I try to find a hardware solution, I need to get one file that is on that hard disk.  It looks like Target Disk Mode is not an option with the hardware combination I have at hand. But what about UNIX ?  Since it is possible to boot on Console Mode on the root account...  I know that's dangerous !  Would need guidance.  So I posted a general question about it.  If you know how to proceed, please tell me ! 


    Lao Bo

  • Melophage Level 5 (7,140 points)

    Lao Bo,


    yes, you can locate and copy a file from your HD to a USB key using UNIX commands. If you know the exact name of the file which you’re trying to locate, try this:


    find / -iname filename -print


    This command will search your entire internal disk for the particular filename. If you know that it’s within a particular user account, then you can save search time with this variation:


    find /Users/username -iname filename -print


    Either variation of this command will print all files found which have the given filename. Presuming that you’re able to identify the correct file, you can copy it to a USB key using the command


    cp -p filename_returned_by_find /Volumes/USB_volume


    If you’re not sure which volume name your USB key has, this command will show you what the possibilities are:


    ls /Volumes


    Please let me know if you have any trouble with these commands.

  • Lao Bo Level 1 (0 points)

    Thank you !  That looks good and should help me to secure one important item before I try anything like repairing the hardware !   I know the name of the file and it is in the Document directory.


    I suppose the "print" command actually prints a listing of the files on the screen; no printer involved, right ?


    Please let me know if there is any pitfall I should be careful about. 



  • Melophage Level 5 (7,140 points)

    Lao Bo,


    that’s right — the -print predicate of the find command just prints the matching filenames to the screen, with no printer involved. The only possible pitfall is if you have folders that are not searchable; in that case, an error message saying so will be printed for each such folder. To silence those error messages, you could append 2> /dev/null to the find command.

  • Lao Bo Level 1 (0 points)

    Hi Melophage,


    I have been working from my iPhone lately, but really miss my Mac...


    Thanks to your previous tips, I tried to get the critical info first, (the one that would allow me to unlock my backup HD ... yes, I know... [ blush} {blush])  before I go and look for a hardware solution / trip to Beijing....  So I logged in Console Mode and used UNIX commands but :


    The command "ls" works fine when used alone, and one can see the "Users" directory. But adding "man" to most commands only got me answers like "no such directory or files". And the command "find" also gives me this kind of feedback whatever I ask, including when asking for "Users" !   I tried with and without blank spaces in my syntax, but get the same result. ---> ??! 

    Am I just messing up the commands or are most UNIX commands powerless ?  I am really worried.

    Here is a screenshot example below, with the results of "ls" and then an attempt at "ls/Users" and another at "find/Users". 


    I am at a loss...  Thanks for helping !


    Lao Bo


    UNIX screenshot.jpg

  • Melophage Level 5 (7,140 points)

    Lao Bo,


    you need to separate the command from its parameters using whitespace, e.g.


    ls /Users

    find /Users/laobo -iname CrispyDuckRecipe.pdf -print


    rather than



    find/Users/laobo […]


    The man command also needs whitespace separation from its parameters, e.g.


    man ls

    man find

  • Lao Bo Level 1 (0 points)

    I am progressing with the syntax. Got the find command to find my file !  One problem seems to be that my username includes one space which doesn't fit well with UNIX.  Now working with ls and cp to prepare the copy...

    It looks brighter now ! 

  • Lao Bo Level 1 (0 points)

    Melophage, are you there ? I found my file !      But when I tried something innocent - witht the find  - print command, obviously did a serious mistake : now the system is printing on the screen the name of ALL the files on my Users Directory !...


    Any way to interrupt / cancel a UNIX command ?


    Sorry !


    Lao Bo

  • Lao Bo Level 1 (0 points)

    I am OK !   Got the tip from a friend : hold down control key and press C !  

    I can go back to work on my cp command...

       Lao Bo

  • Melophage Level 5 (7,140 points)

    Lao Bo,


    to work in Terminal with file names or folder names which have spaces, you can “quote” them [i.e. surround the relevant name(s) with either single quotes or double quotes]:


    ls '/Users/lao bo'

    find "/Users/lao bo" -iname 'Crispy Duck Recipe.pdf' -print

    cp -p "/Users/lao bo/Documents/Culinary/Crispy Duck Recipe.pdf" "/Volumes/Thumb Drive/Chinese recipes"


    (That cp command should be a single line; the forum software will probably wrap it across two lines.)


    Good, your friend has introduced the command interrupt (⎈C) to you.

Previous 1 2 Next