13 Replies Latest reply: Aug 8, 2014 10:00 PM by tim_r_66
piperspace Level 2 Level 2 (305 points)

My Mavericks server is bound to both a Windows AD domain and to its own Open Directory Service.

 

The System Image Utility workflow below completes OK.

 

But target machines are NOT connected to directory servers as expected.

 

Instead I get the error messages shown from NetBootClientHelper.

 

I can subsequently connect manually with no problems.

 

myworkflow.jpg

 

 

 

2/11/14 2:52:51.858 PM NetBootClientHelper[189]: bindToServersFromList: bind to enceladus-svr.piperspace.com failed. The operation couldn’t be completed. Host not found

 

2/11/14 2:52:51.859 PM com.apple.launchd[1]: (com.apple.NetBootClientHelper[189]) Exited with code: 1

 

2/11/14 2:52:51.859 PM com.apple.launchd[1]: (com.apple.NetBootClientHelper) Throttling respawn: Will start in 4 seconds

 

2/11/14 2:53:05.771 PM NetBootClientHelper[217]: bindToServersFromList: bind to enceladus-svr.piperspace.com failed. existing connection is not authenticated: password change denied

 

2/11/14 2:53:06.122 PM NetBootClientHelper[217]: bindToServersFromList: bind to PIPERSPACE failed. Authentication server could not be contacted.


OS X Mavericks (10.9.1)
  • Antonio Rocco Level 6 Level 6 (10,340 points)

    ". . . bind to enceladus-svr.piperspace.com failed. The operation couldn't be completed. Host not found"

     

    Sounds like DNS hostname resolution might not be what it should be? Is your DHCP service configured to hand out the appropriate search domain information?

     

    You can use the tools available in the RecoveryHD to run basic network diagnostics such as ping, nslookup etc. Try using it to test hostname resolution of the server you're trying to bind to on both pointers.

     

    If you're familiar with DeployStudio you can create a minimal netboot set (SIU can do the same if you're more familiar with it?) that will give you similar tools you use in the same way.

     

    Maybe the problem is as simple as that?

  • piperspace Level 2 Level 2 (305 points)

    Thanks for your thoughts. I agree it seems like  a networking issue.

     

    However my DNS setup seems good. I am able to bind the target manually right after NedtBootClientHelper fails.

     

    Has anyone ever seen this feature work?

     

    Or are we saying its been busted so long (since 10.6.x) we should just give it a decent burial and forget about it?

  • Antonio Rocco Level 6 Level 6 (10,340 points)

    The point I'm trying to make is whether DNS solution is working or being given time enough to work when booting clients using the network bootloader or a DS netboot set? I've seen similar issues as yours and it turned out clients were not getting the correct information when booting using the service yet were when booting normally simply because it took longer to boot normally.

  • piperspace Level 2 Level 2 (305 points)

    Sorry, I still don't get it.

     

    Why would my DHCP and/or DNS service work differently when a client is booting?

     

    And anyway the helper runs after NetRestore completes and the machine is booting normally.

     

    Unless someone has seen this feature working I think its reasonable to conclude it does not.

     

    That is the point I am trying to make.

  • Antonio Rocco Level 6 Level 6 (10,340 points)

    No I did not get it either but it turned out to be true as there was another DHCP server on the network. It was a cheap SOHO router that had fallen behind a filing cabinet in the admin office. The network administrator had used it temporarily to get over a problem in the mistaken belief it was a small 4 port hub and forgotten all about it.

     

    I'm not saying this is the case for your situation and I'm only offering it as a possibility. If it's not a real or even remote possibility then please ignore whatever I've offered.

  • piperspace Level 2 Level 2 (305 points)

    OK. I isolated my lab gear & tested your idea.

     

    The set up is a new Apple Airport providing DHCP, a Mavericks Server providing NetInstall and Open Directory services, a Windows 2008 Server providing DNS plus Active Directory and a Mac Mini client.

     

    Its still busted.

     

    To your point though, I did notice that the Airport DHCP takes quite a while to assign an IP to the client.

     

    Will this feature work properly if I use a faster DHCP service? 

  • Antonio Rocco Level 6 Level 6 (10,340 points)

    Possibly although I'm confused about how your network is arranged? Are you saying you're using the Airport Express DHCP Service rather than what's coming from your DC? Do you have more than one DHCP server on your network? If so are you certain which DHCP Service your clients are using?

     

    IMHO I class Apple's networking products as SOHO and its DHCP service is not something I'd give serious consideration to in an 'enterprise' environment. Don't get me wrong they're nice enough products (if slightly over-priced IMO) and I've used them many times as WAPs and nothing else.

     

    What happens if you use what your Windows Server is providing or even OS X Server instead?

  • piperspace Level 2 Level 2 (305 points)

    Yes, I am using an Airport for DHCP in the lab.

     

    For production we use a Cisco router.

     

    Will it work if I try other arrangements - I asked first. :-)

     

    I was hoping to save some lab time by learning here of configurations known to work.

  • Antonio Rocco Level 6 Level 6 (10,340 points)

    What can I tell you? If configured correctly it works and it has worked for me in the past when I used it although I did use other methods to bind to AD and OD or OD on its own as part of the deployment. I've never used an Airport Express as the DHCP Server at any time. I do have a Cisco based DHCP Server and router which I have used on occasion and it has worked and continues to work well for me. However since 10.7 I moved to a DeployStudio and Munki based deployment solution which does everything I want. Prior to that (10.6, 10.5, 10.4 and 10.3) NetBoot did all I asked of it.

     

    I occasionally still use SIU/NetBoot in smaller (20 or less) environments simply because it's easier for my customers to understand than other similar products.

  • piperspace Level 2 Level 2 (305 points)

    Antonio - Thanks so much for your thoughts & ideas. I really appreciate it.

     

    You are probably right that the symptoms will change if I use a faster DHCP service.

     

    However, my specific issue is that I have never yet seen the "connect to directory" feature work.

     

    It seems to lack robustness (i.e. Its busted.)

     

    IMHO - Apple should either make it work under field conditions or deprecate/remove the feature from SIU.

     

    If it works properly for someone I would love to hear about it.

  • piperspace Level 2 Level 2 (305 points)

    Follow up - I moved DHCP service to the Windows 2008 server.

     

    This reduces IP acquisition time from 37 seconds to 3 seconds.

     

    NetBootClientHelper is still busted. Same symptoms.

  • piperspace Level 2 Level 2 (305 points)

    Additional follow up: I adpated for 10.9.x the Bash script I wrote four years ago to get around a very similar issue in Mac OSX 10.6.

     

    See https://discussions.apple.com/thread/2258855?tstart=0

     

    The script works.

     

    NetBootClientHelper still does not.

     

    Opened bug report 619689 with Apple.

  • tim_r_66 Level 1 Level 1 (40 points)

    @piperspace,

     

    I would appreciate a copy of your script if you're still willing to make it available?

     

    Tim