9 Replies Latest reply: Feb 14, 2014 12:40 PM by thomas_r.
bertair Level 1 Level 1 (0 points)

I no longer seem to be able to play mp4 videos in Quicktime. (version 10.3)

They will play in a VLC Player and even when I disable that, the QT is not working.

I run Mavericks and all my other apps seem to go okay.

Is there a download or update for Quicktime I can get ?


MacBook Air, iOS 6.1.3, I have another 6 Apple devices
  • arthur Level 5 Level 5 (4,965 points)

    They should play in QT 7: QuickTime Player 7 for Mac OS X v10.6.3 or later

     

    Why don't you just use VLC?

  • citroenDS Level 1 Level 1 (10 points)

    it's not much help, but it's not a missing update that's causing it - QT (10.3) works fine for me in 10.9.1

  • bertair Level 1 Level 1 (0 points)

    Thanks

    I have tried VLC and when I try to load a AVI file, it throws up a screen "Fixing AVI Index". This sometimes works, sometimes it doesn't, and it does take a long time to complete the action anyway whether it works or not.

    My Mavericks Quicktime has somehow been damged I think as the Quicktime version I have when I look at "About" shows 10.3 when I think it should be 10.9.1

    My Mavericks is 10.9.1,so that is okay.

     

    If I could get  the Quicktime upgrade it may solve the problem, but where is the support to get the upgrade ?

     

    I have a current version of AVI and checked for an update, when shows it is current.

     

    I have even gone to the trouble of trying to convert AVI files to MP4 with no sucess.

     

    I am left to wonder if there is a remote possiblity of a virus in my Mavericks, which is unlikely in the extreme though.

    Any where I can download a Quicktime, a link would be appreciated.

    I prefer Quicktime over AVI anyway.

  • thomas_r. Level 7 Level 7 (30,540 points)

    This is not due to a virus, or any other kind of malware. However, it may be the result of something that experts refer to as "crapware" installed on your machine. Try restarting in safe mode. Does it work then?

  • VikingOSX Level 6 Level 6 (12,060 points)

    No separate QT update. Running 10.9.1 and every mp4 (audio, video, both) that I feed QT just plays. VLC 2.1.3?

  • bertair Level 1 Level 1 (0 points)

    Thanks, It has helped by restarting in Safe Mode, but there are still a few MP4 files that when opened, the Quicktime goes into Converting Mode with the progress bar that starts but doesn't complete.

     

    Hence the MP4 Files do not play and will be deleted as soon as time permits.

    VLC will now open MKV and AVI files what appears to be okay.

     

    I shall do further testing as time permits.

     

    Thank you again for your assistance.

     

    BTW How does "Crapware" get into my Apple when I only use the Apple store and Apple software ?

    I do not download software or apps from other than Apple iTunes.

    Is there a Crapware detector out there ?

  • thomas_r. Level 7 Level 7 (30,540 points)

    If it's continuing in safe mode, either the movies themselves are damaged or contain video formats that QuickTime can't handle, or the system is damaged and needs to be reinstalled.

     

    If you have only installed software from the App Store, that should not be affecting QuickTime playback. Such apps cannot install system modifications of any kind. That doesn't mean everything in the App Store is good - there's quite a lot of junk in there. There's no way to automatically identify such junk software... you just need to be cautious about what you download, and pay attention to unbiased reviews (which can, in some cases, be hard to find, as some crapware companies get involved in unethical behaviors like astroturfing).

  • bertair Level 1 Level 1 (0 points)

    Thank you.

    Would a complete re instal of Mavericks help and my other Apps be removed and reinstalled  as well ?

  • thomas_r. Level 7 Level 7 (30,540 points)

    You could start by just reinstalling Mavericks on top of your current system. That will replace all system files, and if something relating to QuickTime is corrupt or missing, that will fix it. If the problem is due to some addition to your system, that won't fix it.

     

    BTW, note that VLC is neither an Apple app nor an App Store app... I didn't pay close enough attention to that before. So you do have at least some software downloaded from other places. So this could still be caused by something that has modified your system somehow.