6 Replies Latest reply: Mar 10, 2014 3:01 PM by Allan Clark
ruiganga Level 1 Level 1 (0 points)

I am almost there

 

As you can see server.symbolbox.pt is working on 80 port. Bu, when I try to access my Server from an outside network using Server App, I can see my server in the list but I can't login and I am not sure why.

 

The Administrator user and pass is working locally so it is not that for sure.

 

Do I have to configure any port in my router to point to my server?

  • Strontium90 Level 4 Level 4 (3,580 points)

    On the server you want to admin, have you enabled "Allow remote administration using Server" on the Settings tab of the device?

     

    Server.app > Server > You actual server > Settings > Allow remote administration using Server

     

    R-

    Apple Consultants Network

    Apple Professional Services

    Author "Mavericks Server – Foundation Services" :: Exclusively available in Apple's iBooks Store

  • ruiganga Level 1 Level 1 (0 points)

    Thanks but that option is selected.

     

    I believe that it could be some kind of routing between my Router and my Server. I've opened several ports like HTTP, FTP, SSH... am I missing some port to be able to reach the server using Server.app?

  • ruiganga Level 1 Level 1 (0 points)

    One more half victory. I've found this ports:

     

    311TCPSecure server administration-asip-webadminServer app, Server Admin, Workgroup Manager, Server Monitor, Xsan Admin.

     

    In this link: http://support.apple.com/kb/TS1629

     

    I've configured this one specifically and try to login my server using Server.app again. This time I was prompt with a message to confirm, SSL certificate if I am not mistaken.

     

    Anyway, I still can't log. The app tries and quit without any message or suggestion.

     

    Should I try any other port from the list?

  • ukraul Level 1 Level 1 (30 points)

    You need TCP port 625 open as well to get access to the server app on the server remotely.

    For Security reason its better to geht a VPN Connection to the server and Open only the needed Ports, and After this you didn't Need to Open additional Service Ports.

     

    Best Regards

    Uwe

  • ruiganga Level 1 Level 1 (0 points)

    Thanks for the tip. I'll try.

     

    I am curious about VPN Connection. I thought that it was what I am trying to do.

     

    How can I configure a VPN Connection with my server and protect it?

  • Allan Clark Level 1 Level 1 (10 points)

    Hi;

     

    I solved a similar problem, but it's even in the local subnet.  I can connect to tcp/311 and tcp/625 from (remote) to (server) -- of course the connection is dropped as soon as I type anything but is confirmed with netstat and tcpdump -- and the checkbox for remote administration is enabled.

     

    Connection is refused identically whether using the correct password or not: the annoying shake-the-dialog animation, and ZERO detail about the failure.  The dialog doesn't even register any red text to help indicate why it's shaking, I simply assume it's an authentication issue.

     

    System Preferences, FWIW, show "Sharing->Remote Management" both "on" and "allow all users".  Shared Screen works fine to this host, but the host is slow to respond due to workload, the show cursor movement makes me less frustrated if I could just Server.App it.

     

    I found that my server failued to update the external name (so server109.local is also server109.example.com on the internet, and when I connected to server109.local, it seemed to retry to server109.example.com).  server109.example.com (or whatever your public-service IP address) might not be working correctly... so when trying to telnet to tcp/311 or tcp/625, check all addresses that your Server.App shows on the first screen in the "Server" section, above "Alerts".