3 Replies Latest reply: Nov 14, 2014 8:57 AM by Mauricio Andrades
HugoMe Level 1 (25 points)

mds[89]: (Error) Volume: Could not find requested backup type:2 for volume


I get the above message in my system.log every time I use Time Machine.


I'm backuping on a time capsule, which is networked by Ethernet.

I don't seem to have any issue with the backup itself, which is performing Ok and from which I can retrieve files.


I've issue with

1) it is polluting my log and i always fear i got a backup issue i haven't detected

2) I have an issue with searching my backups

     a) if I enter Time Machine (the UI with stars everywhere), I get unreliable results by searching for a file (present when search performed from a directory, absent when performed from the parent directory)

     b) I cannot enter Time Machine from a search window in the finder (see an example here http://mac101.net/content/tips-tricks/tips-tricks-doing-a-spotlight-search-in-ti me-machine/ ) which prevents me from doing a exact search on file name for example)




This may be related to a permission issue.


I've setup Time Capsule to allow for file sharing, based on peripheric password (from Airport Utility/MyCapsule/disks)

When I look at my Time capsule from finder,


a) I see MyCapsule on the network. I choose it


b) I can mount MyCapsuleDisk in MyCapsule (by connecting to it in finder).

     It has a weird permission state : (unknown) with read & write, everyone : forbidden access. No group.

     From terminal (from ls -l) I see "drwx------   1 hugome hugome" permission


     > this is when I get the

          mds[89]: (Error) Volume: Could not find requested backup type:2 for volume

     > most of the time I have a second error (which sems apple file sharing related

          mds[89]: ERROR: _MDSChannelInitForAFP: AFPSendSpotLightRPC failed -1

     > i wonder wether the cause is the permission issue above, that prevents indexing (mds is not accessing the backup disk), and that I haven't been able to solve


c) I can see the MyMac.sparsebundle with permission

     "drwxr-xr-x 7 hugome hugome" from terminal

     hugome read & write, "fetching" read, everyone read from finder


d) if I click on it backups.backupdb, 

     drwxr-xr-x+ 5 root  staff


e) and inside dated backups with same permissions

     drwxr-xr-x@ 4 root  hugome


f) and inside the hierarchy of my backups

     MyOSDisk drwxr-xr-x@ 14 root      wheel

     MyMediaDisk drwxrwxr-x@  8 hugome staff





My guess is that:


i) I had a group permission issue related to my hugome account. the group I was associated was my username, which did not exist. This is documented and linked to Apple migration bug from Tiger OS.

- I solved it yesterday on my home folder on MyOSDisk  by creating a staff group, following the advice here http://www.fixkb.com/2011/08/reset-home-folder-permissions.html

- I solved it yesterday on MyMediaDisk by a chown cmd 

- this can be traced in my older Time Machine backups as these changes are only visible on today's backups


ii) I believe the problem is still present on my Time Capsule (see b)

> as said, i wonder wether the cause of mds errors is the permission issue, that prevents indexing (mds is not accessing the backup disk)

> i haven't been able neither through chmod or chgrp to change permissions on MyCapsuleDisk. Any idea ?


iii) same permission problem on c), and same lack of solution


iv) surprise on d) to see a staff group above a root user


v) bigger surprise on e) to see a hugome group


vi) this seems OK


Any advice greatly appreciated (please note that I have only very basic notions of unix)


Mac Pro, Mac OS X (10.7.5), 2x2.66 dual core xeon
  • HugoMe Level 1 (25 points)

    Just to make it clearer. the structure of my (networked) backup:


    MyCapsuleDisk                                                      drwx------ 1   hugome hugome b)

           |___     MyMac.sparsebundle                           drwxr-xr-x 7   hugome hugome c)


    which when clicked mounts the following disk :


    MyBackupdisk                                                         drwxr-xr-x   7      hugome staff

          | ___     backups.backupdb                                drwxr-xr-x+ 5     root staff         d)

                          |___MyMac                                         drwxr-xr-x@ 43   root hugome

                                      |___2014-02-19-2011          drwxr-xr-x@ 4     root hugome   e)

                                      |              |___MyOsDisk         drwxr-xr-x@ 14   root wheel      f)

                                      |              |___MyMediaDisk    drwxrwxr-x@  8    hugome staff   f)


                                      |___ etc...

  • HugoMe Level 1 (25 points)



    I have figured why I can't chown my directories.

    There is a parallel set of rights called ACL on any file.

    You can access them with ls -le


    In my case:


    d) ls - le  MyBackupDisk

    drwxr-xr-x+ 5 root  staff  170 21 jan 20:43 Backups.backupdb

    0: group:everyone deny add_file,delete,add_subdirectory,delete_child,writeattr,writeextattr,chown



    ls -le Backups.backupdb

    drwxr-xr-x@ 43 root  hugome  1496 19 fév 20:11 MyMac

    0: group:everyone deny add_file,delete,add_subdirectory,delete_child,writeattr,writeextattr,chown


    e) ls -le MyMac

    drwxr-xr-x@ 4 root  hugome  238 22 jan 03:09 2014-01-22-030958

    0: group:everyone deny add_file,delete,add_subdirectory,delete_child,writeattr,writeextattr,chown


    f) ls -le 2014-02-19-2011

    drwxr-xr-x@ 14 root      wheel  782 18 fév 16:59 Mac

    0: group:everyone deny add_file,delete,add_subdirectory,delete_child,writeattr,writeextattr,chown

    drwxrwxr-x@  9 hugome  staff  408 12 jui  2012 Medias

    0: group:everyone deny add_file,delete,add_subdirectory,delete_child,writeattr,writeextattr,chown



    To bypass this, there 's a trick using option chmod -N but it strips off all ACL , and i'm a little afraid to do that.

    Any advice ?

  • Mauricio Andrades Level 1 (0 points)

    is this an afp disk? issue the mount command and post what the -o options for the disk are...