1 Reply Latest reply: Feb 19, 2014 12:36 PM by léonie
LuvApple59 Level 1 Level 1 (0 points)

My current version of Aperture is 1.5.6  My operating system is 10.7.5  When I try to update Aperture, it goes to Aperture 3 which requires operating system 10.9  Can I upgrade to a lower version of Aperture? 


MacBook Pro, Mac OS X (10.7.5)