1 Reply Latest reply: Feb 22, 2014 1:32 AM by K Shaffer
unserame Level 1 Level 1 (0 points)

When I tried to share my Ethernet connection via Airport my wifi showed yellow status with the message "self obtained IP" (2nd device could not obtain IP). I proceeded to repair my disk permissions and retry with the result of "no IP" (again no IP found on second device). Internet sharing was indeed on and I have tried with Firewall both on and off. Ive done much googling to no avail. Please help!


MacBook, OS X Mavericks (10.9.1), Internet sharing
  • K Shaffer Level 6 Level 6 (10,610 points)

    You may have to check Help in your version OS X 10.9 to see what is suggested as some older systems have different instructions on how to troubleshoot this self-assigned ISP issue. The Help is built-in to OS X and also looks to the internet for additional information related to your system version.

     

    While I have some ideas on how to attempt to troubleshoot the general issue, I am not so sure if the methods to fix problem areas are the same now. I see in the main menu bar (not in an application) Help and it opens in another window, and is searchable. Mine is based on an older OS X, and so does not even give a reply or definition of 'self obtained IP' because the issue had a different name when this one was new.

     

    A more standard search result in Apple Support online gives this topic:

     

    • "Internet connection does not work with IP address space of 169.254.xxx.xxx from ISP, router, or manual configuration"

    http://support.apple.com/kb/TS3798

     

    So maybe the Help viewer in your OS X may offer better ideas.

     

    If you are setting up an AirPort base station router, see that

    product Support page, articles for setup issues are there.

     

    •Apple - Support:

    http://www.apple.com/support/

     

    •Apple - Support - OS X:

    http://www.apple.com/support/osx/

     

    Good luck & happy computing!