2 Replies Latest reply: Feb 26, 2014 6:08 AM by Locomotief
Locomotief Level 1 Level 1 (10 points)

This problem started with the update to version 3.5 (now on 3.5.1).

 

Generally I can import new raw images without problems. Files are copied to the library, previews created. When I start editing (or perhaps even just viewing) the images, at some point an image will suddenly turn black with the exclamation mark saying 'unsupported image format. When this happes, going back to a previously correctly shown image will also turn black.

 

Closing and re-opening Aperture often helps. Once I open the image and open the hud, Aperture retries reading the RAW file and the image comes back. Occasionally Aperture will persist in claiming that the RAW file is unsupported and there is nothing I can do but restart the iMac completely.

 

Sometimes it will not show this exclamation mark, but it will distort the image. Wrong orientation, in all shades of pink or just some lines of pixels showing. This is more difficult to correct, as Aperture 'thinks' that it has already read the image. Which it has, but incorrectly.

 

Again occasionally the thumbnail of the image will flicker between the exclamation mark and the correct preview. 'Show activity' shows that Aperture is looping and constantly trying to generate a preview for whatever reason.

 

Displaying the HUD sometimes helps to get Aperture to read the RAW file correctly, other times it slows down completely and fades into a a complete hangup that I can do nothing about other then forcefully quit Aperture.

 

I use RAW files from two cameras, the Pentax K5 (.DNG) and Sony A7 (.ARW). Both cameras are supported. Then I use NIK software with the latest release and using TIFF as file type. I created a new Aperture library i.e. without older files edited with NIK (.PSD I beleive) 'contaminating' the preview creation process - to no avail. The issue happens every Aperture session and will result in me having to quit and restart Aperture again and again and again.

 

Unfortunately I was not able to discover a scenario or that the issue is limited to a particular file type. I've worked for years with the .DNG's from the Pentax K5 without any issues, now I get the same problems with them as the .ARW's and .TIFF's.

 

What can I do?


Aperture 3, OS X Mavericks (10.9.1), in combination with NIK software
  • firstlaunch Level 3 Level 3 (620 points)

    It sounds like the Nik Software issue if the images return after restating the application. Confirm you've updated to 10.9.2 and the latest Nik updates.

  • Locomotief Level 1 Level 1 (10 points)

    Yes, I thought along the same lines. My NIK suite however is up to date. I also made sure that the file type for the external editors is TIFF (16 bit).

     

    Yes, I have installed 10.9.2.

     

    In the meantime I removed some remainders of the old NIK Software collection (before it was purchased by google) from the Aperture plugin folder. After a restart at first Aperture felt quicker, and doing a lot of editing on an image using NIK went OK to. But then I tried to open up a DNG from the K5 and whooops - unsupported image format. Which off course it isn't. So that did not help (much).

     

    There are some more buggy things with my Aperture - for instance if I go to full screen and then back to normal and then minimize to the dock, I cannot maximize Aperture by clicking on the icon in the dock. The only thing that helps it clicking on the icon on the dock to select Aperture and then hit the F key to get full screen.

     

    Another wierd thing, which I believe I read elsewhere, is that Aperture does't allow me to overwrite the previous filename when I export to .jpg using a custom name.

     

    If this were a Microsoft/Windows programm, I would suspect some broken .ddl's, but apparently there is no such thing in MAC OS.