13 Replies Latest reply: Jul 15, 2014 3:57 PM by cybercussion
SFLapple Level 1 (0 points)

I upgraded to 10.9.2 on my mid-2012 Macbook air and now when i wake the laptop from sleep the wifi will not automatically reconnect. I have to physically click on my network to re-join it.


MacBook Air (13-inch Mid 2012), OS X Mavericks (10.9.2)
  • Linc Davis Level 10 (192,161 points)

    Test after taking each of the following steps that you haven't already tried. Back up all data before making any changes.

    1. Make sure the network is on the preferred list by following these instructions. It's important to read the article carefully, as it's the starting point for any further efforts to solve the problem. If you skip any of the steps, the problem may not be solved. Make sure the box marked

    Remember networks this computer has joined

    is checked.

    2. Follow the instructions in this support article under the heading

    Symptom: After restarting or waking from sleep, my computer might not connect to the Internet

    3. Reset the PRAM.

    4. Make a note of all your settings for Wi-Fi in the Network preference pane, then delete the connection from the connection list and recreate it with the same settings. You do this by clicking the plus-sign icon below the connection list, and selecting Wi-Fi as the interface in the sheet that opens. Select Join other network from the Network Name menu, then select your network. Enter the password when prompted and save it in the keychain.

    5. From the Location menu at the top of the Network preference pane, select Edit Locations. A sheet will drop down. Click the plus-sign button to create a new location. Give it any name you want. In the new location, set up the Wi-Fi service with the same settings you used before. Click Apply and test.

    6. Launch the Keychain Access application. Search for and delete all AirPort network password items that refer to the network. Make a note of the password first.

    7. Repair permissions on the startup volume.

    8. Turn off Bluetooth and test.

    9. Reset the System Management Controller.

    10. Reinstall OS X.

  • benchernif Level 1 (0 points)

    Had this issue after migrating from a 13" 2012 MBA to a 2013 13" rMBP - it really was the only issue that I was having after cloning the data over the Thunderbolt port.  But it's also a very annoying issue everytime you open the lid from sleep.

     

    I removed all my saved networks from the network options, reset the SMC and PRAM, now it's working fine.

     

    Thanks!

     

    Ben

  • benchernif Level 1 (0 points)

    Okay - and nevermind - it intermittnetly works but I'm still having the same issue.  Seems that after a longer sleep (10+ minutes) it does not want to reconnect.  If it's only a few minutes of sleep it'll reconnect no issue.  Ideas?

     

    Ben

  • SFLapple Level 1 (0 points)

    I've tried them all except reinstalling the OS and nothing has corrected it so far. I've also noticed that during short sleep and wake periods it automatically reconnects it's just during the longer ones when it doesn't.

  • benchernif Level 1 (0 points)

    Exactly SFLapple!  Did you do an upgrade to 10.9.2 with your current Mac, or did you just get a new Mac and transfer/clone/migrate from another older device?

     

    Ben

  • Xepherys1 Level 1 (0 points)

    I'm having the same issue with a brand new iMac 27".  My MBP worked fine, but this iMac won't connect when it comes back from an extended sleep.  Wifi indicates that it's connected, and I can get to my router's web admin panel, but Chrome spins trying to resolve DNS every time (I have DNS entries setup in networking prefs).  I have to turn wifi off and back on for it to function properly.  I'm using OSX 10.9.2, which came pre-installed.

  • kevin_ Level 4 (1,535 points)

    I also had the same problem and came up with a fix.  Just type the following into the Terminal.

     

    sudo defaults delete /Library/Preferences/com.apple.Bluetooth LastA2DPDevice

  • ns_svk Level 1 (0 points)

    Has anyone tried Kevin_'s suggested fix for the WiFi reconnect issue ? I would like to do it as well, if it has worked. Appreciate a confirmation.

  • kevin_ Level 4 (1,535 points)

    Hi ns,

     

    The fix that I posted has resolved several people's issues in other discussions. 

     

    The problem is that so many people post and it gets lost in the tons of other posts out there.

     

    The terminal command just deletes 1 entry in the BlueTooth property list file that for soem reason at least on my system and several others has been resposnible for WIFI not reconnecting after sleep.  It's been about 2 months now since I applied this on my system and it resolves the issue 95% of the time.. the other few times it just takes a little longer to connect.

  • Steppenwolf_74 Level 1 (0 points)

    Thanks, this work for me.

  • Steppenwolf_74 Level 1 (0 points)

    Yes, and work fine.

  • dll31p Level 1 (0 points)

    Most home WiFi connections and Bluetooth share the same frequencies, which is probably the reason so many people are having this issue.  If you have an 802.11n or a new 802.11ac wifi access point (usually a router) and can afford to go 'n only' or 'ac only' and opt to use the 5ghz range, you will probably find it okay to leave both WiFi and Bluetooth on.  I can't test this theory myself, so I'm just leaving off the wireless headphones for now...

     

    Cheers!

  • cybercussion Level 1 (5 points)

    Possibly related, but my 09' 17" Macbook pro started dropping wifi on me and I was leaving it on to do some work when I would remote into it.  Before I left I put it in "Better Battery Life" mode vs "High Performance".  Not sure if that was what was causing the WIFI to disconnect but sleep was 'never', and display was set to off after a minute.

     

    Switched it back to High Performance and it hasn't done it again.