6 Replies Latest reply: Mar 1, 2014 2:33 PM by craigst2
craigst2 Level 1 Level 1 (0 points)

The new Mavericks update (10.9.2) crashed my system so had to restore from Time Machine. Then when I had iTunes going and plugged in iPhone, I got a message that this iphone was not authorized for "copying" files from this computer so I would neet to Authorize. So I authorized just fine and the next window says "this computer is already authorized."  But when that window is closed, the "not authorized" window comes back. Back and forth, nothing changes.

 

I tried:

1. Deauthorizing this computer then reautorizing

2. Turning off my iphone then restarting

3. Deleting the SC Info folder (according to the Apple Support web page)

 

None of this has worked.

 

Any suggestions?


Mac Pro, OS X Mavericks (10.9)
  • sberman Level 7 Level 7 (28,790 points)

    There is a subtle difference between authorizing and associating a device to your Apple ID.

     

    I suggest reading this article and follow the directions to make sure your computer is associated to your Apple ID.

     

    http://support.apple.com/kb/HT4627

  • craigst2 Level 1 Level 1 (0 points)

    OK, read the article. Went to iTunes-My Account and Manage Devices. It only shows my iphone as being "associated." It does not show my computer as being authorized or associated. Went back to itunes, chose Authorize, entered my password, and it says "this computer and one other computer is already authorized." I assume the "one other" is the iphone, but the problem remains: it apparently doesn't recongize my Mac as being authorized.

  • sberman Level 7 Level 7 (28,790 points)

    You specifically omitted saying your computer is associated with your Apple ID.  So, if it is not, get it assocated as it says at the top of the HT4627 article (repeated below):

     

    When you turn on iTunes Match or Automatic Downloads, or when you download past purchases on an iOS device or computer, that device or computer becomes associated with your Apple ID.


  • craigst2 Level 1 Level 1 (0 points)

    OK, went to Preferences>Store, choose Automatic Downloads for Music and Apps, which weren't previously checked for some reason. Now when I go to My Account, it does indeed sow my computer as being associated, as does my iphone.

     

    but when I plug in my iphone still get this message:

    ++++++++++++++++++++++++++

    Some of the items in the iTunes library, including "Round Midnight", were not copied to the iPhone "myiphonename" because you are not authorized for them on this computer.

     

    To authorize this computer for items purchased from the iTunes Store, choose Store>Authorize this Computer.

    ++++++++++++++++++++++++++

     

    I bought a new song and it downloaded fine. I've had to upadte my billing information. Tried restarting iTunes 3 times during these changes.

     

    So now it appears that both the Mac and the iPhone are "associated" with iTunes and this Mac is authorized. So now what?

  • sberman Level 7 Level 7 (28,790 points)

    Well, some items ("Round Midnight" in particular) must have been purchased using some other Apple ID.  They therefore do not legally belong to you.

     

    Do you know what Apple ID was used to purchase those items that are not copied?  If not, you can control-click on the song in iTunes, and click "Get Info" and see the owner's name displayed on the "Summary" tab.

  • craigst2 Level 1 Level 1 (0 points)

    I changed my password about a week ago but everything worked fine and got no error messages. This problem did not occur until I tried to install the new Mavericks update Thrusday and it crashed my system. Had to rebuild from Time Machine. I used the backup from Wednesday to make sure that I got the latest operational build re-installed.

     

    I guess I'll have to call Apple to see if they have a different Apple ID for some reason for those 81 songs. I can't imagine why they would though since the ID hasn't changed ever (many many years). I now have OS X 10.9.2 installed and everything's working ok except when I hook up my iphone.